TensorFlow Version Upgrade and Deprecation of Unsecure Versions

1 min read

Watson Machine Learning will support TensorFlow versions 1.14 in deployment and training runtimes.

Also, due to a recent security vulnerability for multiple TensorFlow versions, Watson Machine Learning (WML) will deprecate unsecure TensorFlow versions, including 1.5 and 1.11. We have extended the deprecation date announced in a previous blog post to give users more time and options for migration.

At the same time, Keras 2.1.3 support will also be deprecated together with TensorFlow 1.5. Keras 2.2.4 users will need to switch TensorFlow backend from 1.11 to 1.14.

If you are training or deploying the following impacted models:

  • TensorFlow 1.5
  • TensorFlow 1.11
  • Keras 2.1.3 with TensorFlow 1.5 backend
  • Keras 2.2.4 with TensorFlow 1.11 backend

You have the following upgrade options:

  • TensorFlow 1.13
  • TensorFlow 1.14
  • Keras 2.1.6 with TensorFlow 1.13 backend
  • Keras 2.2.4 with TensorFlow 1.14 backend

Depending on the implementation of the code or model, you may need to make minor modifications based on the TensorFlow version compatibility guide for a smooth transition. In many cases, TensorFlow is backward compatible.

You can read more about working with Watson Machine Learning runtimes, including the new TensorFlow 1.14 runtime, in our documentation.

Here are the dates you need to know

  • TensorFlow 1.14 runtimes available: October 29, 2019
  • Deprecate unsecure TensorFlow versions announcement: October 29, 2019
  • End of Life for unsecure TensorFlow versions: November 26, 2019 

Be the first to hear about news, product updates, and innovation from IBM Cloud