IBM Support

A7004761 Expired Update Access Key (UAK) Order and Apply new UAK on Stand Alone IBM i or HMC-Managed POWER8 or POWER9 servers.

Question & Answer


Question

How do we order and apply firmware update access keys (UAK) on POWER8 or POWER9 servers when firmware policy is set to IBM i OS or Managed by an HMC ?

Cause

A7004761 The update access key has expired. Only firmware updates with a date prior to the expiration date are allowed.
Firmware Update Access Key Policy
POWER8, POWER9 and later systems utilize an Update Access Key (UAK) that is built in code that expires every 180 Days after warranty periods expire.
Warranty Update Access Keys
During manufacturing initial UAK(s) are applied and align with the sever machine type and model warranty expiration date, plus a grace period depending on the Machine Type and Model. 
Low end models have 36 months plus a 2 month grace period for UAK warranty.
High end models have 12 months plus a 3 month grace period for UAK warranty.
Post Warranty 180 Day Update Access Keys
The terms of post-warranty agreements, duration of an IBM hardware maintenance service agreements or special bid agreements renewals vary.  Because IBM hardware agreements renewals vary Update Access Keys are generated every 180 days to verify IBM hardware maintenance service agreements are registered for firmware downloads.
Customers with POWER8 and later systems require a current UAK on their server in order to install current firmware.  If the update access key date has expired, only firmware updates with a date before the UAK expiration date are allowed.
Firmware code is built in such that you can apply code levels published before the expiration of the UAK.  Firmware code is built to allow Hiper fixes in firmware in situations were an UAK has expired, therefore having a current UAK is always recommended to prevent emergency situations.
An Expired UAK does not affect normal server operation. UAK is checked only when server firmware update is applied.  Update access keys do not require a dedicated system to apply.

Answer


IBM i V7R1M0 OS Managed Systems (stand-alone) is a Manual process to enter Update Access Keys.
IBM i V7R1M0 OS Managed Systems Update Access Keys can only be entered using Advanced System Management Interface until the system is updated to IBM i V7R2M0 or higher is installed.
-

Step 1. Order an Update Access Key(s)

Determine your system serial number by entering IBM i Command and options
===> GO HARDWARE
  4. Work with processor resources
  7=Display resource detail
    Opt  Resource        Type-model  Status     
       7   CEC01             8286-41A   Operational
Type-model . . . . . . . . . :   8286-41A
Serial number  . . . . . . . :   21-12345
Record the Type and Serial number. . . . :    21xxxxx (21 Plant ID can vary)
  • You must have an IBMid to use this website. If you do not have one yet, register here.
    Using your IBM WebID, Login to Entitled Systems Support
    https://www.ibm.com/servers/eserver/ess/OpenServlet.wss
  • Select >My entitled hardware
  • Select >UAK - View, Download, and Request Keys
  • Enter >Machine Type (4 numerals)*
  • Enter >Machine Serial (7 Characters) Press the +Add button
  • Select >Request new standard key
  • Select >View Keys - record, or download the new UAK
  • EXAMPLE:image-20190206183406-3

Step 2. Manually enter the Update Access Key by using Advance System Management Interface

image-20190206184242-4

Step 3. Update the Server Firmware to SV840 or higher to support ESA Automatic UAK at IBM i
               V7R2M0 OS or higher

  • Check and record your *ACTIVE Firmware and Update Access Key expiration date by entering IBM i command  ===> DSPFMWSTS
    Firmware entitlement date . . . . . . . . . :   04/01/40
     *ACTIVE      SV860_212
  • Find the IBM i OS Firmware PTF MHxxxxx Format for your Type and Model (MHxxxx are not included in Cume or Hardware group PTF's)
    Server Firmware for stand-alone IBM i systems
    https://www.ibm.com/support/pages/node/666875
  • For additional Power System Recommendations: refer to the Fix Level Verification Tool (FLRT) at: http://www14.software.ibm.com/webapp/set2/flrt/power

  • From IBM i command line download the latest Server Firmware example:
    POWER8 IBM i command ===> SNDPTFORD PTFID((MH0xxxx 5733908 V7R1M0))
    POWER9 IBM i command ===> SNDPTFORD PTFID((MH0xxxx 5733909 V7R2M0))

(End of IBM i V7R1M0 OS Managed Systems (stand-alone) Manual Update Access Keys Steps)


IBM i V7R2M0 or higher OS Managed Systems (stand-alone) ESA Automatic Firmware Update Access Key setup.
Step 1. Update IBM i OS with recommended PTFs for ESA/ECS
Step 2.  Set up Automatic Manage Update Access Keys with IBM Electronic Service Agent (ESA)
  • Check and record your *ACTIVE Firmware and Update Access Key expiration date by entering IBM i command  ===> DSPFMWSTS
    Firmware entitlement date . . . . . . . . . :   04/01/40
     *ACTIVE      SV860_212
  • If the Server Firmware Level is below SV840 Skip to Steps 3, 4 and 5, otherwise continue here:
  • Prepare your server before the next A7004761 is logged in 180 Days or six months. Perform every step in the following document to completion:
    Manage update access keys with IBM Electronic Service Agent (ESA) on IBM i
    https://www.ibm.com/support/pages/node/635899
  • DSPMSG QSYSOPR search for message id CPIEF87: Update Access Key has been handled successfully. This message indicates that the UAK refresh processing determined that the expiration date of the UAK was within the next 30 days. The processing downloaded the new UAK and applied the new UAK successfully. This ends the ESA Automatic Firmware Update Access Key setup.
  • If CPIEF87 is not logged you will need to manually order a UAK.  There are cases once A7004761 is logged the Auto UAK with IBM eSA may not work, in this case manual intervention is needed to order and enter a new UAK via ASMi  Complete Steps 3 and 4.

Step 3.  Order a new Update Access Key for manual entry, this will allow for a more current Server Firmware above SV840 or higher.
  • Determine your system serial number by entering IBM i Command and options
    ===> GO HARDWARE
      4. Work with processor resources
      7=Display resource detail
        Opt  Resource        Type-model  Status     
           7   CEC01             8286-41A   Operational
    Type-model . . . . . . . . . :   8286-41A
    Serial number  . . . . . . . :   21-12345
    Record the Type and Serial number. . . . :    21xxxxx (21 Plant ID can vary)
    You must have an IBMid to use this website. If you do not have one yet, register here.
    Using your IBM WebID, Login to Entitled Systems Support
  • Select >My entitled hardware
  • Select >UAK - View, Download, and Request Keys
  • Enter >Machine Type (4 numerals)*
  • Enter >Machine Serial (7 Characters) Press the +Add button
  • Select >Request new standard key
  • Select >View Keys - record, or download the new UAK
  • EXAMPLE:image-20190206183406-3

Step 4. Manually enter the Update Access Key by using Advance System Management Interface

image-20190206184242-4
  • Continue to Step 5 if your server is below SV840 or you want to download and update server firmware.

Step 5. Update the Server Firmware to SV840 or higher to support ESA Automatic UAK at IBM i V7R2M0 OS or higher

  • Check and record your *ACTIVE Firmware and Update Access Key expiration date by entering IBM i command  ===> DSPFMWSTS
    Firmware entitlement date . . . . . . . . . :   04/01/40
     *ACTIVE      SV860_212
  • Find the IBM i OS Firmware PTF MHxxxxx Format for your Type and Model (MHxxxx are not included in Cume or Hardware group PTF's)
    Server Firmware for stand-alone IBM i systems
    https://www.ibm.com/support/pages/node/666875
  • For additional Power System Recommendations: refer to the Fix Level Verification Tool (FLRT) at: http://www14.software.ibm.com/webapp/set2/flrt/power

  • From IBM i command line download the latest Server Firmware example:
    POWER8 IBM i command ===> SNDPTFORD PTFID((MH0xxxx 5733908 V7R2M0))
    POWER9 IBM i command ===> SNDPTFORD PTFID((MH0xxxx 5733909 V7R3M0))

  • Prepare your server before the next A7004761 is logged in 180 Days or six months.
    If you completed this task in Step 2. ignore it otherwise perform every step in the following document to completion:
  • Manage update access keys with IBM Electronic Service Agent (ESA) on IBM i
    https://www.ibm.com/support/pages/node/635899
(End of IBM i V7R2M0 or higher OS Managed Systems (stand-alone) ESA Automatic Firmware Update Access Key setup)

  • HMC Managed System Steps:
  • Setup Servers Managed by an HMC for Automatic Firmware Update Access Key

  • Step 1. Setup HMC Automatic Firmware Update Access Key
  • Starting with HMC V8.840.0 the Hardware Management Console (HMC) provides the option to update the access key automatically.
  • If the Primary HMC or HMC Virtual Appliance is below HMC V8.840.0 Skip to Step 2 otherwise continue here:
  • To automatically setup your HMC Reference:
    How To Automatically Update Access Key (Enhanced Version of HMC OS)
    https://www.ibm.com/support/pages/node/6238172

Step 2. Update Primary Hardware Management Console (HMC) or HMC Virtual Appliance

Step 3. Setup HMC Automatic Firmware Update Access Key
  • Complete: How To Automatically Update Access Key (Enhanced Version of HMC OS)
    https://www.ibm.com/support/pages/node/6238172
  • Note: If HMC is lower than V8.840.0 with A7004761 already logged and you do not update your HMC to V8.840.0, manual intervention is required. Continue to Step. 4

Step 4. Manually request a new Update Access Key

  • Determine your system serial number by entering IBM i Command
  • ===> GO HARDWARE
    4. Work with processor resources
    7=Display resource detail
    Opt  Resource        Type-model  Status
       7   CEC01             9080-MME   Operational
    Type-model . . . . . . . . . :   9090-MME
    Serial number  . . . . . . . :   78-12345
Record the Type and Serial number. . . . :    78xxxxx (78 Plant ID can vary)
-- Or --

Example: 9080 13xxxxx (Type 9080 13 Plant Code xxxxx Serial Number)

image 8416

  • You must have an IBMid to use this website. If you do not have one yet, register here.
    Using your IBM WebID, Login to Entitled Systems Support
  • Select >My entitled hardware
  • Select >UAK - View, Download, and Request Keys
  • Enter >Machine Type (4 numerals)*
  • Enter >Machine Serial (7 Characters) Press the +Add button
  • Select >Request new standard key
  • Select >View Keys - record, or download the new UAK
    image-20190206183406-3

Continue to Step. 4

Step 4. Manually Enter Update Access Key

 
Ordering your Power Server Update Access Key via My Entitled Systems Support website (Navigation menus) details

Step 1. Determine the System Machine Type and Serial Number
To order a UAK you must know your server’s machine type, plant ID and serial number. Find your servers machine type, plant ID and serial using ASMi.

Determine your system serial number by entering IBM i Command
===> GO HARDWARE
  4. Work with processor resources
  7=Display resource detail
    Opt  Resource        Type-model  Status     
       7   CEC01             8286-41A   Operational
Type-model . . . . . . . . . :   8286-41A
Serial number  . . . . . . . :   21-12345
Record the Type and Serial number. . . . :    21xxxxx (21 Plant ID can vary)

Another method:  Accessing the ASMI by using the HMC
https://www.ibm.com/support/knowledgecenter/POWER9/p9hby/asmihmc.htm

Example: 9080 13xxxxx (Type 9080 13 Plant Code xxxxx Serial Number)
image 8416

Step 2. Entitled System Support

  • You must have an IBMid to use this website. If you do not have one yet, register here.
    Using your IBM WebID, Login to Entitled Systems Support
  • Navigate to the “My Entitled Hardware” Section and select “View, download, and request update access keys”
  • Select >My entitled hardware
  • Select >UAK - View, Download, and Request Keys
  • Enter >Machine Type (4 numerals)*
  • Enter >Machine Serial (7 Characters) Press "+Add" button
  • Select >Request new standard key
  • Select >View Keys - record, or download the new UAK

If your system has a current registered hardware maintenance agreement a new key and new expiration date are shown on the screen.

Select >Request new standard key
image 8419

3. New Key (Update Access Key is created)

Email questions to Customer support center contacts for your country:
https://www-304.ibm.com/servers/eserver/ess/ProtectedServlet.wss
If you have a question or issue and require a response, please contact Customer Support. All contact information is available under Contacts.

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Product Synonym

AS400; iSeries; IBMi; IBM i; OS/400

Document Information

Modified date:
07 December 2021

UID

nas8N1022509