IBM Support

Latest version of CICS Explorer and CICS Tools plug-ins for CICS Explorer

Question & Answer


Question

What is the latest release that you can download of the IBM CICS Explorer and CICS Tools plug-ins for CICS Explorer, that support CICS Transaction Server for z/OS (CICS TS) V5.5, V5.4, V5.3, V5.2, or V5.1?

Answer

Click on one of the following CICS Explorer releases to see the version highlights and the corresponding CICS Tools plug-in releases. The releases are in order from latest (newest) to oldest.

Latest release

Product
Latest Version
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1
5.5.0.4 (1)(2)
CICS Configuration Manager 5.4 plug-in for CICS Explorer
5.4.0.8 (3)
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.5 plug-in for CICS Explorer
CICS Performance Analyzer 5.4 plug-in for CICS Explorer
CICS Transaction Gateway plug-in for CICS Explorer
  1. CICS Transaction Server for z/OS APAR PH07632 needs to be applied in order for CICS Explorer 5.5.0.3 to take advantage of the new CICS system rules.
  2. For the initial releases of CICS Explorer V5.5, IBM Installation Manager is not available as an installation method, see IBM z/OS Explorer Aqua 3.2 does not offer installation packages for IBM Installation Manager for further details.
  3. The client side APAR PH02076 (PTFs UI59966, UI59967 and UI59968) must already be applied.
  4. The client side APAR PH02419 (PTF UI59872) must already be applied.
  5. The client side APAR PH02077  (PTF UI59957, UI59960, UI59958, and UI59959) must already be applied.

Previous releases

Product
Latest Version
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, and 4.2
5.4.0.16 (1) *
IBM Explorer for z/OS
2.1.0.13 *****
CICS Configuration Manager plug-in for CICS Explorer
CICS Interdependency Analyzer plug-in for CICS Explorer
5.3.0.10 (3)(4)(5)
CICS Performance Analyzer plug-in for CICS Explorer
  1. CICS Transaction Server for z/OS APAR PH14288 needs to be applied in order for the fix to fully function.
  2. a) If the plug-in for CICS Interdependency Analyzer is installed, then it must be upgraded to Version 5.3.0.8 (APARs IV94230 and IV95004), or later.
    b) If the plug-in for CICS Performance Analyzer is installed, then it must be upgraded to Version 5.3.0.4 (APAR IV95011), or later.
  3. CICS Explorer must be upgraded to Version 5.4 or Version 5.3.0.13 (APARs IV95659 and IV96224), or later, at the same time as applying this fix.
  4. The host side APAR PI74028 (PTF UI44728) must already be applied.
  5. On 26th January 2018 this was also made available via the z/OS Explorer Aqua V3.0 repository (as well as the Aqua V3.1 repository): http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/ .

****** NEW 9 March 2017
***** NEW 30 August 2017
**** NEW 19 December 2017
*** NEW 26 October 2018
** NEW 24 May 2019
* NEW 6 September 2019

IBM Explorer for z/OS V3.0 and CICS Explorer V5.3, or later
Information on IBM Explorer for z/OS and CICS Explorer V5.3 or later is available on the Mainframe Development page under "Mainframe DevOps Solutions".

This latest release does not permit you to download maintenance from IBM Fix Central. Instead, installation instructions are available under Install Eclipse Tools which you can get to from the Mainframe Development page -> Downloads -> Eclipse Tools.
IBM Explorer for z/OS V2.1 and CICS Explorer V5.2, or earlier
IBM provides three methods for you to obtain the maintenance for CICS Explorer:
  1. Update to the new version from within the CICS Explorer by applying the maintenance from an IBM-hosted Eclipse update site
  2. Use Installation Manager *
  3. Download the maintenance from IBM Fix Central
* Note that for the initial releases of CICS Explorer V5.5, IBM Installation Manager is not available as an installation method, see IBM z/OS Explorer Aqua 3.2 does not offer installation packages for IBM Installation Manager for further details.
 
See the "Installation instructions" in the Readme for each product for more details. The Readme also contains the prerequisites and the list of enhancements and bugs fixed by each new version.

Many of the new releases of CICS Explorer and CICS Tools plug-ins for CICS Explorer contain bug fixes in addition to new functionality. To see a complete list of applicable APARs*, click on the link for each product's Fix list from the Fixes by version for CICS product document.

*There are no PTFs associated with the applicable APARs.

To determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with each release of CICS Explorer, refer to the z/OS Explorer, CICS Explorer, and CICS tools plug-ins release compatibility reference tables . Details of the underlying Eclipse release for CICS Explorer are also provided in these tables.

To get the download packages for previous releases of CICS Explorer, see  Downloads for older releases of IBM Explorer for z/OS and IBM CICS Explorer .

If you are new to CICS Explorer, see  Getting started with the CICS Explorer .


CICS Explorer 5.5.0.4 fix pack and CICS Interdependency Analyzer plug-in 5.5.0.2 fix pack

Available: 13 September 2019


CICS Explorer 5.5.0.4 provides a fix for:

  • IJ17712
    • When starting CICS Explorer with the Liberty and Java EE SDK installed, some included software has an implicit dependency on Eclipse Buildship.  This Eclipse Buildship software is now included.  
  • IJ17644
    • The Java service level shipped with CICS Explorer has been updated to Java 8 SR5 FP35.
    • For CICS resource and definition editors, a right-click Edit menu option is now provided and non-editable attribute names are greyed out.
    • When an EP Adapter is created in a bundle project, some adapter types with long descriptions were not being fully displayed.  The EP editor layout has been altered so that EP adapter type descriptions can now be fully viewed.
  • IJ16750

CICS Interdependency Analyzer 5.5.0.2 provides fixes for:

  • IJ18469
    • Checks are now made to find out if an IA Collector connection has SSL/TLS security enabled and the HTTPS protocol is now used when communicating with the IA web service or atom service in the target CICS region.
  • IJ18540
    • When a user attempts to produce a command flow report a null pointer exception (NPE) is no longer thrown when DBFUNC handles unexpected data in the CMD_TCB_CPUTIME_BEFORE of the CIU_CMDFLOW_DATA table.

CICS Configuration Manager 5.4.0.8 containing APAR IJ18020 was shipped via the z/OS Explorer Aqua V3.1 repository on 6th September 2019.  This is now available via the z/OS Explorer Aqua V3.2 repository as well: https://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.2/.  See section CICS Explorer 5.4.0.16 fix pack and CICS Configuration Manager plug-in 5.4.0.8 fix pack in this document for information about the fixes.

For more information about the update, click on the links to the Readme and APAR in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1 
IJ16750 (1)
CICS Interdependency Analyzer 5.5 plug-in for CICS Explorer 5.5.0.2
  1. This was shipped as part of CICS Explorer 5.4.0.16 fix pack via the z/OS Explorer repository on 6th September 2019.  For details see section CICS Explorer 5.4.0.16 fix pack and CICS Configuration Manager plug-in 5.4.0.8 fix pack in this document for information about this APAR.  


In order to obtain the update, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.


CICS Explorer 5.4.0.16 fix pack and CICS Configuration Manager plug-in 5.4.0.8 fix pack

Available: 6 September 2019


CICS Explorer 5.4.0.16 provides fixes for:

  • IJ16750
    • A Shared TS Queue Hexname field has been added which contains the binary name of the Shared TS Queue converted to hex. This is a unique primary key to ensure that only the intended Shared TS Queue is deleted.
  • IJ18775
    • The Java Runtime Environment has been updated.

CICS Configuration Manager 5.4.0.8 provides fixes for:

  • IJ18020
    • When using the CICS CM explorer plug-in to define a TCPIPSERVICE with Protocol(ECI) with the URM not set, it no longer fails.  The default values for URM in TCPIPSERVICE have been updated for the ECI and IPIC Protocols. 

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1
CICS Configuration Manager 5.4 plug-in for CICS Explorer 5.4.0.8 IJ18020


In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Explorer 5.3.0.21 fix pack

Available: 24 May 2019


CICS Explorer 5.3.0.21 provides a fix for:

  • IJ13503
    • When CICS Explorer queried bundles within a region during the export of an application to an installed platform with no active regions and a NOTAVAILABLE/SCOPE error was received an error was thrown and processing stopped. This has now been corrected, processing will continue.

This was fixed in CICS Explorer 5.4.0.14 (IJ12659) via the z/OS Explorer Aqua V3.1 repository on 14th January 2019 and in CICS Explorer 5.5.0.1 (IJ12659) via the z/OS Explorer Aqua V3.2 repository on 25th January 2019.  

For more information about the update, click on the links to the Readme and APAR in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1 
 

In order to obtain the update, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Configuration Manager plug-in 5.4.0.7 fix pack and CICS Performance Analyzer plug-in 5.4.0.5 fix pack

Available: 17 May 2019


CICS Configuration Manager 5.4.0.7 provides fixes for:

  • IJ14773
    • CICS Configuration Manager has been added as an Net Promoter Score (NPS) feedback option.


CICS Performance Analyzer 5.4.0.5 provides fixes for:

  • IJ14775
    • CICS Performance Analyzer has been added as an Net Promoter Score (NPS) feedback option.

For more information about the updates, click on the links to the Readmes and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Configuration Manager 5.4 plug-in for CICS Explorer
CICS Performance Analyzer 5.4 plug-in for CICS Explorer 5.4.0.5 IJ14775
 

In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Explorer 5.3.0.20 fix pack and CICS Deployment Assistant 5.3.0.7 fix pack

Available: 25 January 2019


CICS Explorer 5.3.0.20 provides fixes for:

  • IJ09035
    • The Java Runtime Environment has been updated.


CICS Deployment Assistant plug-in 5.3.0.7 containing APAR IJ11424 was shipped via the z/OS Explorer Aqua V3.1 repository on 7th December 2018 and the z/OS Explorer Aqua V3.2 repository on 14th December 2018. This is now available via the z/OS Explorer Aqua V3.0 repository as well: https://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/. See here for information about the fixes.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1
CICS Deployment Assistant 5.3 plug-in for CICS Explorer 5.3.0.7 IJ11424


In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Explorer 5.5, CICS Interdependency Analyzer 5.5, CICS Configuration Manager 5.4.0.6 fix pack, CICS Deployment Assistant 5.3.0.7 fix pack, and CICS Performance Analyzer 5.4.0.4 fix pack

Available: 14 December 2018

Version 5.5.0.0 of the CICS Explorer and CICS Interdependency Analyzer plug-in provide support for CICS Transaction Server for z/OS V5.5.

CICS Explorer V5.5 includes the following new functionality as documented in the  release notes :

  • Aggregation in resource views
    • With aggregation, you can merge resource records together to display a summarized view for one or more attributes in any resource view. Aggregation helps you identify similarities and differences in a set of CICS® resources.
  • New Map view to show related CICSPlex® SM resources
  • New Feature Toggles view available
  • New Global TCP/IP Statistics view available
  • New Policy Rules view available
  • New BAS Resource Assignments view available
    • The BAS Resource Assignments (RASGNDEF) view displays information about the characteristics of resource definitions of a particular resource group and class, and how those resources are to be assigned to and installed in a set of CICS systems.
  • Resource Group and Group List Definitions views changed for enhanced capabilities
  • Enhancements to the policy definition editor
  • Quickly add filters in a resource view
    • In most resource views, you can add a quick filter to a resource attribute by right-clicking the column header of that attribute.
  • Faster CICS Explorer connections to CICS TS through GZIP compression CMCI connections to CICS Transaction Server for z/OS® servers now support GZIP compression to reduce payloads and speed up connections.

Version 5.5.0.0 of the CICS Interdependency Analyzer plug-in provides support for CICS Transaction Server for z/OS V5.5.

CICS Interdependency Analyzer V5.5 includes the following enhancements as documented in the release notes: 

  • More detailed and meaningful messages in the 'Used By' view giving an advanced level of resource discovery for improved usability.
  • Improved resource visualization.
  • Bug fixes and modification of Expand and Collapse feature in the Resource Usage Visualization.
  • Enhancement of 'User Command Flow' in IA Navigation view.
  • Integration with ADDI.


CICS Configuration Manager plug-in 5.4.0.6 containing APAR IJ09181, CICS Deployment Assistant plug-in 5.3.0.7 containing APAR IJ11424, and CICS Performance Analyzer 5.4.0.4 containing APAR IJ09179 were shipped via the z/OS Explorer Aqua V3.1 repository on 7th December 2018. This is now available via the z/OS Explorer Aqua V3.2 repository as well: http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.2/. See  here for information about the fixes.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.5, 5.4, 5.3, 5.2, and 5.1
5.5.0.0
none
CICS Configuration Manager 5.4 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.5 plug-in for CICS Explorer
5.5.0.0
none
CICS Performance Analyzer 5.4 plug-in for CICS Explorer


In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Explorer 5.4.0.13, CICS Configuration Manager 5.4.0.6 fix pack, CICS Deployment Assistant 5.3.0.7 fix pack, and CICS Performance Analyzer 5.4.0.4 fix pack

Available: 7 December 2018

These APARs enable the plug-ins to work with CICS Explorer V5.5 which supports CICS Transaction Server for z/OS V5.5.

CICS Explorer 5.4.0.13 provides a fix for:

  • IJ11158
    • Toleration is provided for CICS TS V5.5.

CICS Configuration Manager 5.4.0.6 provides a fix for:

  • IJ09181
    • Toleration is provided for CICS TS V5.5.

CICS Deployment Assistant 5.3.0.7 provides a fix for:

  • IJ11424
    • Toleration is provided for CICS TS V5.5.

CICS Performance Analyzer 5.4.0.4 provides a fix for:

  • IJ09179
    • Toleration is provided for CICS TS V5.5.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, and 5.1
CICS Configuration Manager 5.4 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.4 plug-in for CICS Explorer

In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.


To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Configuration Manager 5.3.0.6 fix pack, CICS Deployment Assistant 5.3.0.6 and CICS Performance Analyzer 5.3.0.6 fix pack

Available: 26 October 2018

CICS Configuration Manager 5.3.0.6 provides a fix for:

  • IJ09658
    • The translation for the in-product help was not being displayed; it is now available in Japanese.

CICS Performance Analyzer 5.3.0.6 provides a fix for:

  • IJ09661
    • The translation for the in-product help was not being displayed; it is now available in Chinese (Simplified Han) and Japanese.

CICS Deployment Assistant 5.3.0.6 containing APAR IJ10156 was shipped via the z/OS Explorer Aqua V3.1 repository on 19th October 2018. This is now available via the z/OS Explorer Aqua V3.0 repository as well: http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/. See here for information about the fix.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer

In order to obtain the updates, see  Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.


To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer.



CICS Configuration Manager 5.4.0.5 fix pack, CICS Deployment Assistant 5.3.0.6 and CICS Performance Analyzer 5.4.0.3 fix pack

Available: 19 October 2018

CICS Configuration Manager 5.4.0.5 provides a fix for:

  • IJ09660
    • The translation for the in-product help was not being displayed; it is now available in Japanese.

CICS Deployment Assistant 5.3.0.6 provides a fix for:

  • IJ10156
    • The translation for the in-product help was not being displayed; it is now available in Chinese (Simplified Han) and Japanese.

CICS Performance Analyzer 5.4.0.3 provides a fix for:

  • IJ09662
    • The translation for the in-product help was not being displayed; it is now available in Chinese (Simplified Han) and Japanese.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Configuration Manager 5.4 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.4 plug-in for CICS Explorer


(1) Important: APAR IJ10156 is not currently available from the z/OS Explorer Aqua V3.0 repository; this will be made available at a later date. The fix pack can be accessed via the z/OS Explorer Aqua V3.1 repository http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.1/ .

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.


To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .



CICS Explorer 5.3.0.19 fix pack, CICS Deployment Assistant 5.3.0.5 fix pack and CICS Performance Analyzer 5.3.0.5 fix pack

Available: 27 July 2018

CICS Explorer 5.3.0.19 provides a fix for:

  • IJ03780
    • When installing CICS Explorer via Installation Manager, only the languages that have been selected in the installation wizard are now included.

CICS Deployment Assistant 5.3.0.5 containing APAR  IJ05323  was shipped via the z/OS Explorer Aqua V3.1 repository on 15th June 2018. This is now available via the z/OS Explorer Aqua V3.0 repository as well:  http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/.

CICS Performance Analyzer 5.4.0.1 containing APAR  IJ06794  was shipped via the z/OS Explorer Aqua V3.1 repository on 20th July 2018. This is now available via the z/OS Explorer Aqua V3.0 repository in CICS Performance Analyzer 5.3.0.5 as well:  http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, and 4.2
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer


In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.


To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .



CICS Explorer 5.3.0.17 fix pack, CICS Configuration Manager plug-in 5.3.0.5 fix pack and CICS Interdependency Analyzer 5.3.0.10 fix pack

Available: 26 January 2018

CICS Explorer 5.3.0.17 provides fixes for:

  • IJ00794
    • The DB2 JDBC driver has been updated to version 4.21.29 to allow support for DB2 V11.
  • IJ01483
    • When there is a scrollable data set and an exception is thrown from DB2, it was possible for an infinite loop to be encountered. This has been amended so that every error on a scrollable data set will only be tried once.

CICS Configuration Manager 5.3.0.5 provides a fix for:

  • IJ01776
    • A custom-written CICS Explorer plug-in establishes its own https connection to a back end server with a certificate which is not known to the CICS Explorer or any of the CICS Tools plug-ins. When connecting with a CM connection that has the SSL flag set, the CM plug-in invokes a CICS Explorer method who has now been updated so that the SSL socket factory and hostname verifier are set for the specific connection rather than using the default.

CICS Interdependency Analyzer 5.3.0.10 containing APAR IJ00790 was shipped via the z/OS Explorer Aqua V3.1 repository on 17th November 2017. This is now available via the z/OS Explorer Aqua V3.0 repository as well: http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua/. See here for information about the fix.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, and 4.2
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer


In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .


CICS Explorer 5.4.0.5 and 5.2.0.9 fix packs and CICS Configuration Manager plug-in 5.4

Available: 20 December 2017

CICS Explorer 5.4.0.5 provides a fix for:

  • IJ02247
    • Updates have been made around the retry/disconnect mechanism when CICS Explorer handles 401 errors from the server.
    • The SMCPSMConnection has been updated so that if it detects a 403 and a valid XML document with the tag structure /error/full then the full error message is taken and sent back.
    • When reconnecting after an exception, resources views now respond correctly.
    • Updates to the resources view have been made to support CICS Configuration Manager 5.4.
    • Redraw on the Resource Views table is suspended before making any changes and is then resumed once all changes have been made. The changes can then be applied in one go.
    • An incorrect message no longer appears in the Browse dialogue if the browse button in Export dialogue of Policy editor is used to pick a "To directory".
    • The user will get an error message in the policy editor when a named counter task rule and a file open system rule are defined in the same policy and CICS tries to install the policy on CICS TS 5.1 or 5.2. When exporting policy event specification, some error messages which should have been flagged as warnings are being logged as errors. This has been corrected and errors are flagged in the policy editor.


In addition, a fix pack for V5.2 of CICS Explorer was made available on 19th December 2017. This fix pack for the older release has been included in the Downloads for older releases of IBM Explorer for z/OS and IBM CICS Explorer page.

CICS Explorer 5.2.0.9 provides a fix for:

  • IV99265
    • When a user creates an application (bundle) using a misconfigured environment, because of the way that Eclipse builds, the application builds correctly in the workspace even though there are compile errors. When the user tries to export the bundle to HFS, Explorer checks the success of the export and if there are compile errors or missing dependencies, it will fail.

Version 5.4.0.0 of the CICS Configuration Manager plug-in provides support for CICS Transaction Server for z/OS V5.4.

CICS Configuration Manager V5.4 includes the following new functionality as documented in the release notes: 

  • Support for zFS Configurations
    • The option to create zFS directory CICS configurations is added in the New Configuration wizard where you can define a file or subdirectory using the new ZFSFILE resource definition type.
  • DFHCSDUP audit flag
    • The option Collect audit records for DFHCSDUP updates is added to the configuration editor. Select this option to set up CICS Configuration Manager to collect resource definition changes made by DFHCSDUP. Note: This option is only available if the repository is a CSD file.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, and 4.2
CICS Configuration Manager 5.4 plug-in for CICS Explorer
5.4.0.0
none


* This APAR was raised against CICS Explorer 5.4 and has been backported to CICS Explorer 5.3 ( 5.3.0.16 was released on 29 September 2017) and CICS Explorer 5.2.

CICS Configuration Manager V5.4 plug-in for CICS Explorer is shipped as a new release so no APARs are associated with it. The new code is available on the Mainframe development page . If your current version of CICS Explorer is Version 5.3, or earlier, you must install a new copy of CICS Explorer. You cannot just upgrade CICS Explorer. It is advisable to back up any existing workspace before you install this new release of CICS Explorer.

The CICS Configuration Manager V5.4 plug-in is required for CICS Explorer V5.4. The plug-in supports CICS Explorer V5.4 and many of the new functions in CICS TS V5.4.

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .


CICS Explorer 5.4.0.4 fix pack and CICS Interdependency Analyzer plug-in 5.3.0.10 fix pack


Available: 17 November 2017

CICS Explorer 5.4.0.4 provides a fix for:

  • IJ00990
    • When exporting policy event specification, some error messages which should have been flagged as warnings are being logged as errors. This has been corrected and errors are flagged in the policy editor.
    • When an authentication failure occurs, CICS Explorer tries to reconnect automatically hence incrementing the failed logon count. The CMCI connection now disconnects fully to prevent incrementing the failed logon count.
    • Background work has been completed in order to provide support for future CICS APAR PI87691 which provides Multi-Factor Authentication (MFA) support for CMCI and CICS Explorer.

CICS Interdependency Analyzer 5.3.0.10 provides a fix for:

  • IJ00790
    • The Interdependency Analyzer plug-in repositories have had all references to DBFunc removed as it has been moved to CICS Explorer.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, and 4.2
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer


(1) Important: APAR IJ00790 is not currently available from the z/OS Explorer Aqua V3.0 repository; this will be made available at a later date. The fix pack can be accessed via the z/OS Explorer Aqua V3.1 repository http://public.dhe.ibm.com/ibmdl/export/pub/software/htp/zos/tools/aqua3.1/ .

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .



CICS Explorer 5.3.0.15 and 5.2.0.8 fix packs and z/OS Explorer 2.1.0.13 fix pack


Available: 30 August 2017

CICS Explorer 5.3.0.15 provides a fix for:

  • IV97801
    • z/OS Explorer has been updated to fix pack 3.0.1.11. CICS Explorer has been rebuilt to include this.

In addition, fix packs for a Java security vulnerability are provided by the following APARs for V5.2 of CICS Explorer and V2.1 of IBM Explorer for z/OS, available on 30th August 2017. These fix packs for the older releases have been included in the Downloads for older releases of IBM Explorer for z/OS and IBM CICS Explorer page.

CICS Explorer 5.2.0.8 provides a fix for:

  • IV95476
    • An unspecified vulnerability related to the Libraries component in IBM Java SDK could allow a remote attacker to obtain sensitive information resulting in a high confidentiality impact using unknown attack vectors. CICS Explorer has been updated to package a new Java Runtime Environment (JRE).

IBM Explorer for z/OS 2.1.0.13 provides a fix for:

  • IV95475
    • An unspecified vulnerability related to the Libraries component in IBM Java SDK could allow a remote attacker to obtain sensitive information resulting in a high confidentiality impact using unknown attack vectors. CICS Explorer has been updated to package a new Java Runtime Environment (JRE).

For more information about the updates, click on the links to the Readmes and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, 4.2, and 4.1
IV95476*
IBM Explorer for z/OS
IV95475*


*APARs IV95476 and IV95475 are not on the web because they are security integrity APARs. See related Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Explorer for z/OS V2.1 and V3.0.1 (CVE-2016-5548 and CVE-2016-5549) for more information. There are no related Java security vulnerability APARs for the CICS Tools plug-ins for CICS Explorer.

See Finding security and integrity APARs for System z products like CICS TS for the best way to stay current and be notified when there is a security and integrity APAR for CICS Transaction Sever for z/OS and the CICS Tools that run on z/OS.

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .



CICS Interdependency Analyzer plug-in 5.2.0.6 fix pack


Available: 9 March 2017

CICS Interdependency Analyzer 5.2.0.6 provides fixes for:

  • IV92181
    • The CICS IA plug-in display of output for the collected command function was not indenting the program name from the left margin window at each new logical level change when a program transferred control using an EXEC CICS LINK or dynamic CALL and a CICS TS user exit was being invoked. This has been corrected.

For more information about the update, click on the links to the Readme and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer


In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .



CICS Explorer 5.3.0.10 and CICS Transaction Gateway plug-in 3.0.0.3 fix packs


Available: 27 January 2017

CICS Explorer 5.3.0.10 provides fixes for:

  • IV92195
    • Icons within resources tables (for example, to indicate whether a resource had been installed from a bundle) have been reinstated.
    • An update has been made so that when searching for Tasks from a TCP/IP service, an error is no longer given.
    • In some instances an IllegalArgumentException could be thrown from the CICS Explorer model. This has been corrected.
    • When installing a definition on Windows, in some situations (for example, where there were no system groups), only one region was shown as a possible install target. This has been corrected.
    • An update has been made so that when editing a filter for a view configuration, the user no longer gets a benign SWTException in some situations.

CICS Transaction Gateway plug-in 3.0.0.3 provides fixes for:

  • PI74695
    • An error no longer occurs when a user tries to connect the CICS Transaction Gateway plug-in to a Gateway daemon using the statistics port.

For more information about the updates, click on the links to the Readmes and APARs in the following table:

Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Transaction Gateway 3.0 plug-in for CICS Explorer
3.0.0.3


In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .


5.2.0.4 CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer enhancements and support for APAR PI38229 and PI22815


Available: 7 October 2015

CICS Interdependency Analyzer plug-in for CICS Explorer V5.2.0.4 provides:

  • Support for CICS Interdependency Analyzer for z/OS APAR PI38229:
    • In the Queries, Command Flow, and Visualization views, TSQNAME and TSQUEUE AUX fields incorrectly appear on the list of CICS Types.
    • In the Queries and Command Flow views, READQ AUX and WRITEQ AUX fields are missing from the list of available CICS Commands.
  • Support is provided for CICS Interdependency Analyzer for z/OS APAR PI22815 compatibility:
    • In the Queries view, Command Flow Queries using a remote name do not produce results.
    • In the Command Flow view the Remote Name and Remote Sysid information is incorrect.
  • Enhancements
    • The resource connections view has been redesigned.
    • Uses Resources view has been redesigned.

For more information about the updates, click on the Readme and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer

The above-mentioned enhancements are also included in 5.1.1.7 CICS Interdependency Analyzer 5.1 plug-in:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer

This fix pack for the older release has been included in the download packages for previous releases of CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .




5.2.0.5 CICS Explorer enhancements and 2.1.0.11 IBM Explorer for z/OS maintenance updates


Available: 29 September 2015

CICS Explorer V5.2.0.5 fixes various problems and minor documentation changes identified in CICS Explorer V5.2:

  • Adding the Regions column to the default task view columns.
  • Improving the way connection exceptions are displayed in installed tools.
  • Correcting the delete button in the drop down in the editor breadcrumb.
  • Corrected an issue where the WLM workload owner is not show in CICS Explorer when installing a routing rule into an existing workload.
  • Fixed a problem whereby the message CNX0593E was issued when removing a CMTCMDEF through CICS Explorer.

IBM Explorer for z/OS V2.1.0.11 provides a fix and minor documentation updates. The fix is to improve the way connection exceptions are displayed in installed tools.

For more information about the updates, click on the Readmes and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer **
CICS Deployment Assistant 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer ***
CICS Performance Analyzer 5.2 plug-in for CICS Explorer ***
CICS Transaction Gateway plug-in for CICS Explorer
3.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.5, however, CICS Configuration Manager's fix pack recently became available so the APARs are included in the table.


*** These have been included to display the most recent fix packs which are available.
If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for CICS Explorer .




5.2.0.2, 5.1.1.6, 5.1.0.2, 1.1.1.5, 1.1.0.4, 1.0.1.4, & 1.0.0.9 POODLE Security update and more


Available: 12 December 2014

Fix packs for the POODLE security vulnerability are provided by the following APARs for the various supported releases of the CICS Explorer and IBM Explorer for z/OS:

Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
1.0.0.9
Update for POODLE security vulnerability
1.0.1.4
1.1.0.4
1.1.1.5
5.1.0.2
5.1.1.6
5.2.0.2
IBM Explorer for z/OS
2.1.0.8

In addition to the APARs for the POODLE security vulnerability, the following APARs are included in the CICS Explorer 5.2.0.2 and IBM Explorer for z/OS 2.1.0.8 fix packs:

Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
5.2.0.2
Update for POODLE security vulnerability
Maintenance roll up
In CICS Explorer 5.2.0.1 programs appear with a 'BUNDLE' icon
Support for Apple OS X Yosemite 10.10 or higher
IBM Explorer for z/OS
2.1.0.8
Update for POODLE security vulnerability
Maintenance roll up
Support for Apple OS X Yosemite 10.10 or higher


The 5.2.0.2 and 2.1.0.8 fix packs have been incorporated into the latest release of CICS Explorer and IBM Explorer for z/OS which are hosted on the primary IBM CICS Explorer Downloads page. The fix packs for the older releases have been included in the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

For more information, refer to the APARs for the fix packs.

There are no related POODLE security vulnerability APARs for the CICS Tools plug-ins for CICS Explorer. If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

See Finding security and integrity APARs for System z products like CICS TS for the best way to stay current and be notified when there is a security and integrity APAR for CICS Transaction Sever for z/OS and the CICS Tools that run on z/OS.

To see if there have been any APARs opened against the CICS Explorer since these versions became available, see the Fix lists for CICS Explorer .




5.1.0.1 provides the fix for APARs IV36046 and IV35382

Available: 9 May 2013

Version 5.1.0.1 of the CICS Explorer includes APAR IV36046 and IV35382:

  • IV36046 fixes a problem stopped CICS Explorer V5.1 from connecting to CICS on z/VSE
  • IV35382 provides additional support for CICS event binding

More details about these APARs can be found by clicking on the links to the APARs in the table below.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for CICS Explorer .

Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, and 4.1
5.1.0.1
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Deployment Assistant 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.0.1
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Transaction Gateway plug-in for CICS Explorer
2.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.0
none


There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates, however, an updated CICS IA 5.1 plug-in is also available (V5.1.0.1).

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

Internal Use Only

6/16/2017 email between Theresa and Rebecca with changes that were made by Theresa


6/16/2017 email between Theresa and Rebecca with changes that were made by Theresa
I changed "CICS Performance Analyzer 5.3 plug-in for CICS Explorer" to "...5.4 ..." in the table at the top of the document. Great spot, thanks
CICS Performance Analyzer 5.3 plug-in for CICS Explorer

These are my outstanding questions:

1) Changed "5.3.0.0 Support for CICS TS 5.4" to "5.4.0 Support for CICS TS 5.4" in the section heading that is linked to. Do you think it should read "5.4.0 CICS Explorer and CICS Performance Analyzer plug-in" instead? --currently nothing indicates CICS PA plug-in in the Title. But the words that follow way "Version 5.4.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.4".. It would be a good idea to include PA in the title but the text below is only relevant to CICS Explorer. Do you think that this would be an appropriate substitution?
"Version 5.4 of the CICS Explorer and CICS Performance Analzyer plug-in provide support for CICS Transaction Server for z/OS V5.4. CICS Explorer V5.4 includes the following new functionality as documented in the release notes: "

2) In the 5.4.0 section, these 2 bullets and 2 lines are in the list of new functionality -- I am guessing these 4 lines should be moved down below the list of enhancements: OK


If your current version of CICS Explorer is Version 5.3, or earlier, you must install a new copy of CICS Explorer. You cannot just upgrade CICS Explorer.
It is advisable to back up any existing workspace before you install this new release of CICS Explorer.


3) The URL for CICS DA 5.3.0.3 is incomplete: http://www-01.ibm.com/support/docview.wss?rs=0&uid=isg40 -- I tried to find the readme on the web but it wasn't on the 1st Google page - Sorry don't know what happened there - it should be http://www.ibm.com/support/docview.wss?uid=isg400003366

4) The doc says "CICS Performance Analyzer V5.4 plug-in supports CICS Explorer V5.4. The V5.3 plug-ins for the CICS tools that have not been updated to V5.4 provide compatability with CICS Explorer V5.4." making me think that a specific release of the plugins isn't required. But, per Debbie Butts:
"You are correct. The plug-ins will work with CICS TS V5.4 but you will need to download the latest versions. These have been specifically enhanced and tested with CICS TS V5.4. The plug-ins are downwards compatible with older CICS TS releases. For the Aqua 3.1 release (being shipped on 16th June) with CICS Explorer V5.4 we will have the following plug-ins:

  • PA V5.4.0
  • CM V5.3.0.2
  • DA V5.3.0.3
  • IA V5.3.0.9"
so should this read something like this? Agreed and have just added in PA as well as that was released on 26th May giving 5.4 compatability.
CICS Performance Analyzer V5.4 plug-in supports CICS Explorer V5.4. The latest releases of V5.3 plug-ins for the CICS tools that have not been updated to V5.4 provide compatibility with CICS Explorer V5.4:
  • CICS CM V5.3.0.2
  • CICS DA V5.3.0.3
  • CICS IA V5.3.0.9
  • CICS PA V5.3.0.4

I did notice that CICS IA Fix Pack 8 (5.3.0.8) contains an APAR for toleration: (yes everything that went out on 26th May is compatible but for ease if we say latest at the moment then that works)
APAR Abstract
IV94230 MISCELLANEOUS ROLL UP CICS EXPLORER IA PLUG-IN
IV95004 CICS TS 5.4 TOLERATION FROM CICS IA 5.3

changed exp date and updated keywords to included CTS 5.4 release.

before changes on 6/15/2017 tmh


before changes on 6/15/2017 tmh
Click on one of the following CICS Explorer releases to see the version highlights and the corresponding CICS Tools plug-in releases. The releases are in order from latest (newest) to oldest.

Latest release
 
Product
Latest Version
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, 4.2, and 4.1
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for the CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
5.3.0.9 (1)(2)
CICS Performance Analyzer 5.3 plug-in for CICS Explorer
CICS Transaction Gateway plug-in for the CICS Explorer
  1. CICS Explorer must be upgraded to Version 5.4 or Version 5.3.0.13 (APARs IV95659 and IV96224) at the same time as applying this fix.
  2. The host side APAR PI74028 (PTF UI44728) must already be applied.

Previous releases
 
Product
Latest Version
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, and 4.1
IBM Explorer for z/OS
CICS Configuration Manager plug-in for CICS Explorer
CICS Interdependency Analyzer plug-in for CICS Explorer
CICS Performance Analyzer plug-in for CICS Explorer
  1. a) If the plug-in for CICS Interdependency Analyzer is installed, then it must be upgraded to Version 5.3.0.8 (APARs IV94230 and IV95004). b) If the plug-in for CICS Performance Analyzer is installed, then it must be upgraded to Version 5.3.0.4 (APAR IV95011).
  2. CICS Explorer must be upgraded to Version 5.4 or Version 5.3.0.13 (APARs IV95659 and IV96224) at the same time as applying this fix.
*** NEW 9 March 2017
** NEW 13 July 2016
* NEW 19 January 2016

 
IBM Explorer for z/OS V3.0 and CICS Explorer V5.3, or later
Information on IBM Explorer for z/OS and CICS Explorer V5.3 or later is available on the Mainframe Development page under "Mainframe DevOps Solutions".

This latest release does not permit you to download maintenance from IBM Fix Central. Instead, installation instructions are available under Install Eclipse Tools which you can get to from the Mainframe Development page.
IBM Explorer for z/OS V2.1 and CICS Explorer V5.2, or earlier
IBM provides three methods for you to obtain the maintenance for CICS Explorer:
  1. Update to the new version from within the CICS Explorer by applying the maintenance from an IBM-hosted Eclipse update site
  2. Use Installation Manager
  3. Download the maintenance from IBM Fix Central

See the "Installation instructions" in the Readme for each product for more details. The Readme also contains the prerequisites and the list of enhancements and bugs fixed by each new version.

Many of the new releases of CICS Explorer and CICS Tools plug-ins for CICS Explorer contain bug fixes in addition to new functionality. To see a complete list of applicable APARs*, click on the link for each product's Fix list from the Fixes by version for CICS product document.

*There are no PTFs associated with the applicable APARs.

To determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with each release of CICS Explorer, refer to the z/OS Explorer, CICS Explorer, and CICS tools plug-ins release compatibility reference tables . Details of the underlying Eclipse release for CICS Explorer are also provided in these tables.

To get the download packages for previous releases of CICS Explorer, see Downloads for older releases of IBM Explorer for z/OS and IBM CICS Explorer.

If you are new to CICS Explorer, see Getting started with the CICS Explorer .




5.3.0.0 Support for CICS TS 5.4 and many enhancements, CICS Interdependency Analyzer plug-in 5.3.0.9 and CICS Deployment Assistant plug-in 5.3.0.3 fix packs

Available: 16 June 2017

Version 5.4.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.4 and includes the following new functionality as documented in the release notes: If your current version of CICS Explorer is Version 5.3, or earlier, you must install a new copy of CICS Explorer. You cannot just upgrade CICS Explorer.
It is advisable to back up any existing workspace before you install this new release of CICS Explorer.

  • The policy definition editor is available to work with task rules and system rules in policies, instead of manually editing an XML file. For more information, see  The policy definition editor .
  • Explorer is enhanced to support PERFORM SHUTDOWN keywords. For more information, see  System Commands .
  • The transaction tracking search feature is enhanced to present a useful hierarchy of tasks.
  • Smart cards can now be used to authenticate connections.
  • When you are installing a CICS resource, you can use a text box to filter the list of install targets (groups or systems) in the Perform Operation dialog.
  • The multi-select option can be used to "multi-select" in the Perform Operation dialog.
  • You can override a record count warning option.
  • You can load all resource records by using the Load All button.
  • You can now define and install WebSphere MQ monitors to manage WebSphere MQ trigger and bridge monitors.
  • You can also use WebSphere MQ monitors to manage user-written transactions that use messages that arrive on an input queue that is not an initiation queue or a bridge queue.
  • A new MQ Monitors (MQMON) view is provided in SM Operations views.
  • A new MQ Monitor Definitions (MQMONDEF) view is provided in SM Definition views.
  • Use the Transient data queue (TDQ) EP adapter when you create or configure an event processing (EP) adapter.
  • Message capture in CICS event binding is enhanced.
  • For resources that are installed from a bundle, a simpler method has been provided to locate the originating bundle.
  • The version of z/OS Explorer within CICS Explorer is updated to support importing certificates. Support for client certificate authentication from a keystore file on disk, or from a smart card, is available. For more information, see  Defining connection credentials  and  Managing SSL security and certificates .
  • Two new views are added for LSR Pools (LSRPOOL) and LSR Pool Buffers (LSRPBUF). You can access the LSR Pool and LSR Pool Buffer views from the CICS Explorer Operations menu.
  • Two options are now provided for you to use to import view customizations. You can browse locally for your imported file, or you can use the HTTP URL option.
  • From a zFS UNIX file system path, you can use the hyperlinks to directly open the files or folders.
  • When you perform an install operation, a new check box is added to "Verify the resource enables successfully".
  • In order to update and simplify the Operations menu, some older views are now removed from the operations menu.
  • The Liberty libraries, available in CICS Explorer target platforms, are upgraded to Liberty 16.0.0.3.
  • The information that was in the Java Developer Guide is now included in CICS TS for z/OS® 5.4.0, see  Developing Java™ applications for CICS .

For more information about the new and changed function, see  What's new in Version 5.4.0  in the product documentation or the CICS Explorer Help Contents.

CICS Performance Analyzer V5.4 plug-in supports CICS Explorer V5.4. The V5.3 plug-ins for the CICS tools that have not been updated to V5.4 provide compatability with CICS Explorer V5.4.

In addition, CICS Deployment Assistant Analyzer 5.3.0.3 provides a fix for:
  • IV96469
  • Translations missing from CICS DA plug-in 5.3.0.2 have been included.
  • The Plug-in has been recompiled to enable its look-up tables to recognise entries for v5.4 when creating a v5.4 Management Facility.

CICS Interdependency Analyzer 5.3.0.9 provides fixes for:
  • IV96468
  • Translations missing from CICS IA plug-in 5.3.0.8 have been included.
 
Product
Version
APAR
CICS Explorer for CICS TS 5.4, 5.3, 5.2, 5.1, 4.2, and 4.1
5.4.0.0
none
CICS Deployment Assistant 5.3 plug-in for the CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.4 plug-in for CICS Explorer
5.4.0.0
none

CICS Explorer V5.4 and the CICS Performance Analyzer plug-in for CICS Explorer are shipped as new releases so no APARs are associated with them. The new code is available on the Mainframe development page .

CICS Explorer V5.4 is compatible with CICS TS V5.4, V5.3, V5.2 and V5.1 therefore, you can install the new version of CICS Explorer and take advantage of a lot of the new functionality regardless of the release of CICS TS that you are using.

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the z/OS Explorer, CICS Explorer, and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

 



CICS Explorer 5.3.0.13, CICS Interdependency Analyzer plug-in 5.3.0.8, CICS Deployment Assistant plug-in 5.3.0.2 and CICS Performance Analyzer plug-in 5.3.0.4 fix packs


Available: 26 May 2017

CICS Explorer 5.3.0.13 provides fixes for:

  • IV96224
  • Clipboard contents are prevented from being replaced if non-loaded records are selected.
  • IV95659
  • The view menu will now be preserved across upgrades.
  • DBFunc has been removed from the CICS IA Plug-in and CICS PA Plug-in packaging and is now shipped as part of CICS Explorer.
NOTE:
  1. If the plug-in for CICS Interdependency Analyzer is installed, then it must be upgraded to Version 5.3.0.8 (APARs IV94230 and IV95004).
  2. If the plug-in for CICS Performance Analyzer is installed, then it must be upgraded to Version 5.3.0.4 (APAR IV95011).

CICS Deployment Assistant Analyzer 5.3.0.2 provides a fix for:
  • IV95006
  • Toleration has been provided for CICS TS Version 5.4.
  • Hyperlinks have been corrected to point to the correct addresses.

CICS Interdependency Analyzer 5.3.0.8 provides fixes for:
  • IV94230
  • Support is provided for Eclipse Neon (4.6).
  • IV95004
  • Toleration has been provided for CICS TS Version 5.4.
  • The CICS types: ANY, CHILD, DATATOJSON, JSONTODATA and CICS commands: FETCH, RUN TRANSID have been added into the CICS query editor.
  • Java 8 is now supported.
  • DBFunc has been removed from the CICS IA Plug-in packaging and is now shipped as part of CICS Explorer.
NOTE: CICS Explorer must be upgraded to Version 5.3.0.13 (APARs IV95659 and IV96224) at the same time as applying this fix.

CICS Performance Analyzer 5.3.0.4 provides a fix for:
  • IV95011
  • Toleration has been provided for CICS TS Version 5.4.
  • DBFunc has been removed from the CICS PA Plug-in packaging and is now shipped as part of CICS Explorer.
NOTE: CICS Explorer must be upgraded to Version 5.3.0.13 (APARs IV95659 and IV96224) at the same time as applying this fix.

For more information about the update, click on the links to the Readme and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer

In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .
 



CICS Explorer 5.3.0.11, CICS Interdependency Analyzer plug-in 5.3.0.7 and CICS Configuration Manager plug-in 5.3.0.2 fix packs


Available: 31 March 2017

CICS Explorer 5.3.0.11 provides fixes for:

  • IV92934
  • CICS Explorer 5.3.0.11 has been updated to allow connections to CICS TS V5.4 open beta systems (function is limited to 5.3 level).
  • A correction has been made so that undoing a change in a resource (definition) editor now updates the field correctly.
  • Connections to the SM Data Interface now support the new UNAUTHORIZED error message as well as specific USERIDUNKNOWN and PASSWORDINVALID messages.
  • The WLMDEF, WLMGROUP, and MGMTPART views were available in CICS Explorer but did not work correctly and have now been removed (this function is provided by the Workload Specification Editor).
  • The display name of the Bundle Parts for Bundle view has been improved in cases where the bundle ID and versions were not complete.
  • A context menu option on a bundle-installed resource to open an editor on the source bundle has been added.
  • In a CICS resource editor view, the CICS Name field will only be matched against filter text while the CICS Name column is visible.
  • Generating a URI Map from a Web Service using the wizard now works correctly if variables are used in the pipeline name.
  • IV94490
  • In response to a client's request for enhancement ( RFE 64191 ), CMCI connections have been updated to support client certificate authentication (including smart cards).

CICS Configuration Manager 5.3.0.2 provides fixes for:
  • IV91558
  • In the deployment analysis reports, a new section was created that now shows the referential integrity verification messages. The message codes have been included within the section as hyperlinks and, once clicked, these will open a new browser window, that would link to the direct page within the IBM Knowledge Center, showing the full written message.

CICS Interdependency Analyzer 5.3.0.7 provides fixes for:
  • IV93761
  • 'TSQUEUE SHARED' and 'TSQUEUE AUX' has been added to the data structure so that they are no available in the query editor.
  • IV94026
  • A correction has been made so that queries can now be run from the 'Supplied Samples -> CICS -> Affinities' folder.
  • IV94287
  • The collection ID is passed to the stored procedure as the user types it, without making any changes to the case so that it is possible to create a threadsafe report when the collection ID is in lower case.

For more information about the update, click on the links to the Readme and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer

In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .
 



CICS Interdependency Analyzer plug-in 5.2.0.6 fix pack


Available: 9 March 2017

CICS Interdependency Analyzer 5.2.0.6 provides fixes for:

  • IV92181
  • The CICS IA plug-in display of output for the collected command function was not indenting the program name from the left margin window at each new logical level change when a program transferred control using an EXEC CICS LINK or dynamic CALL and a CICS TS user exit was being invoked. This has been corrected.

For more information about the update, click on the links to the Readme and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer

In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .
 



CICS Explorer 5.3.0.10 and CICS Transaction Gateway plug-in 3.0.0.3 fix packs


Available: 27 January 2017

CICS Explorer 5.3.0.10 provides fixes for:

  • IV92195
  • Icons within resources tables (for example, to indicate whether a resource had been installed from a bundle) have been reinstated.
  • An update has been made so that when searching for Tasks from a TCP/IP service, an error is no longer given.
  • In some instances an IllegalArgumentException could be thrown from the CICS Explorer model. This has been corrected.
  • When installing a definition on Windows, in some situations (for example, where there were no system groups), only one region was shown as a possible install target. This has been corrected.
  • An update has been made so that when editing a filter for a view configuration, the user no longer gets a benign SWTException in some situations.

CICS Transaction Gateway plug-in 3.0.0.3 provides fixes for:
  • PI74695
  • An error no longer occurs when a user tries to connect the CICS Transaction Gateway plug-in to a Gateway daemon using the statistics port.

For more information about the updates, click on the links to the Readmes and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Transaction Gateway 3.0 plug-in for CICS Explorer
3.0.0.3

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .
 



CICS Explorer 5.2.0.7 fix pack


Available: 13 July 2016



CICS Explorer V5.2.0.7 provides fixes for:
  • IV86033
  • CICS Explorer V5.2.0 has been enhanced so that it can create a CMCI connection to CICS Transaction Server for z/OS 5.3. Connections to CICSPlex SM or to single CICS regions (SMSS) are supported.
  • When connected to a CICS TS V5.3 system, CICS Explorer V5.2 will function as if the CICS system were at V5.2 or lower. CICS Explorer V5.2 cannot be used to manage resources added at CICS TS V5.3.

For more information about the updates, click on the Readmes and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

There are no updates to the CICS Tools plug-ins that are associated with this APAR, however, if you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .




5.2.0.6 CICS Explorer documentation changes and 2.1.0.12 IBM Explorer for z/OS maintenance updates


Available: 19 January 2016



CICS Explorer V5.2.0.6 addresses various documentation problems identified in CICS Explorer V5.2:
  • Removed fast views topic from CICS Explorer V5.2 help.
  • Fixed broken link in the Event Processing resources topic.
  • Provided an update and added missing information to the Policy Actions topic in V5.2.
  • Corrected default routing targets in the help section of the "About the Default Routing Targets" page.
  • Various updates to policy topics.

IBM Explorer for z/OS V2.1.0.12 provides a fix and minor documentation updates. The fix is to reset the password to the default value, if IBM Explorer for z/OS cannot access the secure storage to load key or trust store passwords.

For more information about the updates, click on the Readmes and APARs in the following table:

 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, and 4.1
IBM Explorer for z/OS
 

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.



To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

 



5.2.0.4 CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer enhancements and support for APAR PI38229 and PI22815

Available: 7 October 2015

CICS Interdependency Analyzer plug-in for CICS Explorer V5.2.0.4 provides:
  • Support for CICS Interdependency Analyzer for z/OS APAR PI38229:
  • In the Queries, Command Flow, and Visualization views, TSQNAME and TSQUEUE AUX fields incorrectly appear on the list of CICS Types.
  • In the Queries and Command Flow views, READQ AUX and WRITEQ AUX fields are missing from the list of available CICS Commands.
  • Support is provided for CICS Interdependency Analyzer for z/OS APAR PI22815 compatibility:
  • In the Queries view, Command Flow Queries using a remote name do not produce results.
  • In the Command Flow view the Remote Name and Remote Sysid information is incorrect.
  • Enhancements
  • The resource connections view has been redesigned.
  • Uses Resources view has been redesigned.

For more information about the updates, click on the Readme and APARs in the following table:

 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer
 

The above-mentioned enhancements are also included in 5.1.1.7 CICS Interdependency Analyzer 5.1 plug-in:

 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
 

This fix pack for the older release has been included in the download packages for previous releases of CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .



If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

   



5.2.0.5 CICS Explorer enhancements and 2.1.0.11 IBM Explorer for z/OS maintenance updates


Available: 29 September 2015



CICS Explorer V5.2.0.5 fixes various problems and minor documentation changes identified in CICS Explorer V5.2:
  • Adding the Regions column to the default task view columns.
  • Improving the way connection exceptions are displayed in installed tools.
  • Correcting the delete button in the drop down in the editor breadcrumb.
  • Corrected an issue where the WLM workload owner is not show in CICS Explorer when installing a routing rule into an existing workload.
  • Fixed a problem whereby the message CNX0593E was issued when removing a CMTCMDEF through CICS Explorer.

IBM Explorer for z/OS V2.1.0.11 provides a fix and minor documentation updates. The fix is to improve the way connection exceptions are displayed in installed tools.

For more information about the updates, click on the Readmes and APARs in the following table:

 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer **
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer ***
CICS Performance Analyzer 5.2 plug-in for CICS Explorer ***
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.5, however, CICS Configuration Manager's fix pack recently became available so the APARs are included in the table.


*** These have been included to display the most recent fix packs which are available.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

   



5.2.0.2, 5.1.1.6, 5.1.0.2, 1.1.1.5, 1.1.0.4, 1.0.1.4, & 1.0.0.9 POODLE Security update and more


Available: 12 December 2014


Fix packs for the POODLE security vulnerability are provided by the following APARs for the various supported releases of the CICS Explorer and IBM Explorer for z/OS:
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
1.0.0.9
Update for POODLE security vulnerability
1.0.1.4
1.1.0.4
1.1.1.5
5.1.0.2
5.1.1.6
5.2.0.2
IBM Explorer for z/OS
2.1.0.8


In addition to the APARs for the POODLE security vulnerability, the following APARs are included in the CICS Explorer 5.2.0.2 and IBM Explorer for z/OS 2.1.0.8 fix packs:
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
5.2.0.2
Update for POODLE security vulnerability
Maintenance roll up
In CICS Explorer 5.2.0.1 programs appear with a 'BUNDLE' icon
Support for Apple OS X Yosemite 10.10 or higher
IBM Explorer for z/OS
2.1.0.8
Update for POODLE security vulnerability
Maintenance roll up
Support for Apple OS X Yosemite 10.10 or higher

The 5.2.0.2 and 2.1.0.8 fix packs have been incorporated into the latest release of CICS Explorer and IBM Explorer for z/OS which are hosted on the primary IBM CICS Explorer Downloads page. The fix packs for the older releases have been included in the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

For more information, refer to the APARs for the fix packs.

There are no related POODLE security vulnerability APARs for the CICS Tools plug-ins for CICS Explorer. If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

See Finding security and integrity APARs for System z products like CICS TS for the best way to stay current and be notified when there is a security and integrity APAR for CICS Transaction Sever for z/OS and the CICS Tools that run on z/OS.

To see if there have been any APARs opened against the CICS Explorer since these versions became available, see the Fix lists for the CICS Explorer .

   



5.1.0.1 provides the fix for APARs IV36046 and IV35382
Available: 9 May 2013

Version 5.1.0.1 of the CICS Explorer includes APAR IV36046 and IV35382:
  • IV36046 fixes a problem stopped CICS Explorer V5.1 from connecting to CICS on z/VSE
  • IV35382 provides additional support for CICS event binding
More details about these APARs can be found by clicking on the links to the APARs in the table below.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

 
Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, and 4.1
5.1.0.1
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.0.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.0.1
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
2.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.0
none

There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates, however, an updated CICS IA 5.1 plug-in is also available (V5.1.0.1).

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

 


****

I have added section 14 in to cover CICS Explorer 5.3.0.10 and CTG plug-in 3.0.0.3. The only thing is that I have included CTG in the table where it says about a readme and APAR document however the CTG team have not been able to provide me with either of these documents so I have just put them in the table with no link. I am happy for you to take it out of the table if you think that it will cause confusion - the text above says what is being included in the fix pack.

Have updated section 13 and have added in the note about the known issue referencing the technote that we spoke about

As a result of IBM Explorer for z/OS 3.0.1, upon which CICS Explorer is built, CICS Explorer has been rebuilt and, as such, there is no associated APAR. In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

before changes to doc on 6/28/2016

Click on one of the following CICS Explorer releases to see the version highlights and the corresponding CICS Tools plug-in releases. The releases are in order from latest (newest) to oldest.

Latest release
 
Product
Latest Version
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, and 4.1
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Deployment Assistant 5.3 plug-in for the CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer
CICS Transaction Gateway plug-in for the CICS Explorer

Previous releases
 
Product
Latest Version
CICS Explorer for CICS TS 5.2, 5.1, 4.2, and 4.1
IBM Explorer for z/OS
CICS Configuration Manager plug-in for CICS Explorer
CICS Interdependency Analyzer plug-in for CICS Explorer
CICS Performance Analyzer plug-in for CICS Explorer
** NEW 24 May 2016
* NEW 19 January 2016


 
IBM Explorer for z/OS V3.0 and CICS Explorer V5.3
Information on IBM Explorer for z/OS and CICS Explorer V5.3 is available on the Mainframe Development page under "Eclipse Tools for Mainframe Development".

This latest release does not permit you to download maintenance from IBM Fix Central. Instead, installation instructions are available under Download Eclipse Tools which you can get to from the Mainframe Development page.
IBM Explorer for z/OS V2.1 and CICS Explorer V5.2, or earlier
IBM provides three methods for you to obtain the maintenance for CICS Explorer:
  1. Update to the new version from within the CICS Explorer by applying the maintenance from an IBM-hosted Eclipse update site
  2. Use Installation Manager
  3. Download the maintenance from IBM Fix Central

See the "Installation instructions" in the Readme for each product for more details. The Readme also contains the prerequisites and the list of enhancements and bugs fixed by each new version.

Many of the new releases of CICS Explorer and CICS Tools plug-ins for CICS Explorer contain bug fixes in addition to new functionality. To see a complete list of applicable APARs*, click on the link for each product's Fix list from the Fixes by version document.

*There are no PTFs associated with the applicable APARs.

To determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with each release of CICS Explorer, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . Details of the underlying Eclipse release for CICS Explorer are also provided in these tables.

To get the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

If you are new to CICS Explorer, see Getting started with the CICS Explorer .

CICS Deployment Assistant plug-in 5.3.0.1 and CICS Interdependency Analyzer plug-in 5.3.0.2 fix packs

Available: 24 June 2016

CICS Deployment Assistant plug-in for CICS Explorer V5.3.0.1 provides fixes for:
  • IV81257
  • The CICS Deployment Assistant plug-in has been changed to check for both an explicit and generated start policy.

CICS Interdependency Analyzer plug-in for CICS Explorer V5.3.0.2 provides fixes for:
  • IV83417
  • The Context menu for a Program Resource in the CICS Interdependency Analyzer plug-in has been changed to add the menu item “Purge” with two options: “All regions” and “Specific region". This allows the user to purge obsolete data based on program version.
  • IV83108
  • The CICS Interdependency Analyzer plug-in has been updated so that the Application Context option is available. This APAR contains a fix to make the plug-in compatible with CICS Interdependency Analyzer Host APAR PI61475.
For more information about the updates, click on the Readmes and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Deployment Assistant 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


CICS Explorer 5.3.0.5, CICS Performance Analyzer plug-in 5.3.0.2, and CICS Interdependency Analyzer plug-in 5.2.0.5 fix packs

Available: 27 May 2016

CICS Explorer V5.3.0.5 provides fixes for:
  • IV85026
  • The buttons for Active workload application owning regions (AORs) have been enabled so that they can be activated or quiesced when multi-selected.
  • IV83887
  • Improvements have been made to filtering within CICS Explorer views. The Customize View dialog has been moved into the Explorer Preferences panel. The ability to right-click on any column in the CICS SM perspective, and add quick filter within a view has been added.
  • CICS Explorer now only allows users to specify URI or URIMAP on an INVOKE SERVICE Event Specification because they are mutually exclusive.
  • Toolbar names have been improved when customizing a perspective using Window > Customize Perspective.
  • Validation when importing resources to a bundle has been improved.
  • View summary information to CICS Explorer service data has been added.
  • The "Local delete count" attribute in the Local Files view has been changed to "Delete count".
  • A Programs view has been added to the default stack in the CICS SM perspective.
  • A Regions column has been added to the default set in the Programs view.
  • The list of sample pipeline configurations has been updated to include non-Java JSON support when configuring within a CICS bundle.
  • A new system intialization table (SIT) Parameter XPTKT has been added to the list of attributes that are displayed in the Explorer 'SIT Parameters' view. This SIT parameter was added by CICS TS V5.3 APAR PI60602.
  • In the CICS JDBC example, the default imports have been updated in the manifest.
CICS Performance Analyzer plug-in for CICS Explorer V5.3.0.2 provides fixes for:
  • IV84342
  • When trying to access the Performance List table, an error no longer occurs when one, or more, STATS interval types are deselected.
CICS Interdependency Analyzer plug-in for CICS Explorer V5.2.0.5 provides fixes for:
  • IV82726
  • A change to the user interface has been made to support the INITIAL context option to get the application context. This APAR provides compatibility with APAR PI53503 for the CICS Interdependency Analyzer host component.
For more information about the updates, click on the Readmes and APARs in the following table:
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer *
CICS Performance Analyzer 5.3 plug-in for CICS Explorer

* This was made available on 24th May 2016.

In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

 
5.3.0.4 CICS Explorer rebuilt due to a security vulnerability affecting IBM Explorer for z/OS V3.0 fix packs


Available: 10 May 2016

As a result of a security vulnerability in the IBM Java SDK that affects IBM Explorer for z/OS 3.0, upon which CICS Explorer is built, CICS Explorer has been rebuilt. See Security Bulletin: Multiple vulnerabilities in IBM Java SDK affect IBM Explorer for z/OS V3.0 (CVE-2016-0363 and CVE-2016-0376) for details.

CICS Explorer itself is not affected by the security vulnerability so there is no associated APAR. In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

There are no updates to the CICS Tools plug-ins that are associated with this security vulnerability. But, if you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


5.3.0.3 CICS Explorer and CICS Tools plug-in 5.3.0.1 fix packs


Available: 29 April 2016

CICS Explorer V5.3.0.3 provides fixes for:

  • IV83649
  • CICS Transaction Server for z/OS APARs PI55497 and PI58639 add support for specifying a user ID on JCICS StartRequests. CICS Explorer has been updated to support the new method.
  • IV83682
  • The user agent string presented by CICS Explorer has been enhanced to include the CICS Explorer, z/OS Explorer, and JRE identification information.


CICS Configuration Manager plug-in for CICS Explorer V5.3.0.1 provides fixes for:

  • IV80881
  • An IO request that was causing the plug-in to hang when the user right-mouse clicks on a package in the CM Change Packages view has been removed.

CICS Interdependency Analyzer plug-in for CICS Explorer V5.3.0.1 provides fixes for:

  • IV82885
  • The Affinity Report generation has been updated to allow for empty result sets to be returned from SQL requests.


CICS Performance Analyzer plug-in for CICS Explorer V5.3.0.1 provides fixes for:

  • IV81114
  • When a customised layout with a filter is created and saved if the layout is changed, and the filter cleared, with the saved layout and filter being restored the "Run" button is now enabled.


For more information about the updates, click on the Readmes and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer


In order to obtain the updates, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


5.2.0.6 CICS Explorer documentation changes and 2.1.0.12 IBM Explorer for z/OS maintenance updates


Available: 19 January 2016

CICS Explorer V5.2.0.6 addresses various documentation problems identified in CICS Explorer V5.2:

  • Removed fast views topic from CICS Explorer V5.2 help.
  • Fixed broken link in the Event Processing resources topic.
  • Provided an update and added missing information to the Policy Actions topic in V5.2.
  • Corrected default routing targets in the help section of the "About the Default Routing Targets" page.
  • Various updates to policy topics.


IBM Explorer for z/OS V2.1.0.12 provides a fix and minor documentation updates. The fix is to reset the password to the default value, if IBM Explorer for z/OS cannot access the secure storage to load key or trust store passwords.

For more information about the updates, click on the Readmes and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, and 4.1
IBM Explorer for z/OS

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.


To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


5.3.0.0 Support for CICS TS 5.3 and many enhancements


Available: 11 December 2015

Version 5.3.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.3 and includes the following new functionality as documented in the release notes:

When you open CICS Explorer, the first screen displays the name IBM Explorer for z/OS Aqua 3.0.0.0 before the CICS Explorer workbench opens.

When the CICS Explorer workbench opens, if the CICS SM perspective is not displayed by default, you can open it. Click the Open Perspective icon on the workbench toolbar or
Window > Open Perspective > Other in the main menu for the workbench. In the Open Perspective window, click CICS SM, then click OK.

  • CICS Explorer requires Eclipse 4.4.2.

If your current version of CICS Explorer is Version 5.3 Beta, Version 5.2, or earlier, you must install a new copy of CICS Explorer. You cannot just upgrade CICS Explorer.

It is advisable to back up any existing workspace before you install this new release of CICS Explorer.

  • The name of the default workspace is changed to .zosexplorer. To use the previous .cicsexplorer workspace, use one of the following methods:
  • When you start CICS Explorer, when the Workspace Launcher dialog is displayed, specify directory_path/.cicsexplorer.
  • In the main menu for the CICS Explorer workbench, click File > Switch Workspace > Other, then specify directory_path/.cicsexplorer in the Workspace Launcher dialog.

In the CICS Explorer and CICS® Transaction Server documentation, any references to the .cicsexplorer workspace name also mean .zosexplorer.

  • If you install the CICS Explorer direct download, the name of the executable file is changed to zosexplorer.exe (Windows) or zosexplorer (Linux or OS X).

    In the CICS Explorer and CICS Transaction Server documentation, any references to the cicsexplorer.exe (Windows) or cicsexplorer (Linux or OS X) executable file also mean zosexplorer.exe (Windows) or zosexplorer (Linux or OS X).

     
  • CICS Explorer is available for the OS X Yosemite (10.10) and later operating system.
  • CICS Explorer can connect to a CICS TS for z/VSE 2.1 system to browse and process supported resources.
  • Creating a customized resource view
  • Setting a default connection
  • Automatic connection at startup
  • Defining a TRANSACTION resource as an application entry point
  • Phasing in a new version of an OSGi bundle
  • Specifying a version range for an OSGi project
  • Defining a PACKAGESET resource in a CICS bundle project
  • Querying PACKAGESET resources by platform, region type or application
  • Exporting selected connections
  • Filtering resources by expression
  • Further support for CICS policies
  • Support for new NQRNL system initialization (SIT) parameter
  • IBM CICS Event Binding Editor help is included in CICS Explorer product documentation


For more information about the new and changed function, see What's new in Version 5.3 in the product documentation or the CICS Explorer Help Contents.

The new plug-ins for the CICS tools that support CICS Explorer V5.3 provide compatibility, new functionality, and some defect fixes. Much of the new functionality is not dependent on you having CICS TS V5.3.

Product
Version
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, and 4.1
5.3.0.0
none
CICS Configuration Manager 5.3 plug-in for CICS Explorer
5.3.0.0
none
CICS Deployment Assistant 5.3 plug-in for the CICS Explorer
5.3.0.0
none
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
5.3.0.0
none
CICS Performance Analyzer 5.3 plug-in for CICS Explorer
5.3.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.1.0
none

CICS Explorer V5.3 and the CICS Tools plug-ins for CICS Explorer are shipped as new releases so no APARs are associated with them. The new code is available on the Mainframe development page .

CICS Explorer V5.3 is compatible with CICS TS V5.3, V5.1, V4.2, and V4.1 therefore, you can install the new version of CICS Explorer and take advantage of a lot of the new functionality regardless of the release of CICS TS that you are using.

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.
 


5.2.0.4 CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer enhancements and support for APAR PI38229 and PI22815


Available: 7 October 2015

CICS Interdependency Analyzer plug-in for CICS Explorer V5.2.0.4 provides:

  • Support for CICS Interdependency Analyzer for z/OS APAR PI38229:
  • In the Queries, Command Flow, and Visualization views, TSQNAME and TSQUEUE AUX fields incorrectly appear on the list of CICS Types.
  • In the Queries and Command Flow views, READQ AUX and WRITEQ AUX fields are missing from the list of available CICS Commands.
  • Support is provided for CICS Interdependency Analyzer for z/OS APAR PI22815 compatibility:
  • In the Queries view, Command Flow Queries using a remote name do not produce results.
  • In the Command Flow view the Remote Name and Remote Sysid information is incorrect.
  • Enhancements
  • The resource connections view has been redesigned.
  • Uses Resources view has been redesigned.


For more information about the updates, click on the Readme and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer

The above-mentioned enhancements are also included in 5.1.1.7 CICS Interdependency Analyzer 5.1 plug-in:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer

This fix pack for the older release has been included in the download packages for previous releases of CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .


If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


5.2.0.5 CICS Explorer enhancements and 2.1.0.11 IBM Explorer for z/OS maintenance updates


Available: 29 September 2015

CICS Explorer V5.2.0.5 fixes various problems and minor documentation changes identified in CICS Explorer V5.2:

  • Adding the Regions column to the default task view columns.
  • Improving the way connection exceptions are displayed in installed tools.
  • Correcting the delete button in the drop down in the editor breadcrumb.
  • Corrected an issue where the WLM workload owner is not show in CICS Explorer when installing a routing rule into an existing workload.
  • Fixed a problem whereby the message CNX0593E was issued when removing a CMTCMDEF through CICS Explorer.


IBM Explorer for z/OS V2.1.0.11 provides a fix and minor documentation updates. The fix is to improve the way connection exceptions are displayed in installed tools.

For more information about the updates, click on the Readmes and APARs in the following table:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer **
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer ***
CICS Performance Analyzer 5.2 plug-in for CICS Explorer ***
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.5, however, CICS Configuration Manager's fix pack recently became available so the APARs are included in the table.


*** These have been included to display the most recent fix packs which are available.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .


5.2.0.2, 5.1.1.6, 5.1.0.2, 1.1.1.5, 1.1.0.4, 1.0.1.4, & 1.0.0.9 POODLE Security update and more


Available: 12 December 2014

Fix packs for the POODLE security vulnerability are provided by the following APARs for the various supported releases of the CICS Explorer and IBM Explorer for z/OS:

Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
1.0.0.9
Update for POODLE security vulnerability
1.0.1.4
1.1.0.4
1.1.1.5
5.1.0.2
5.1.1.6
5.2.0.2
IBM Explorer for z/OS
2.1.0.8


In addition to the APARs for the POODLE security vulnerability, the following APARs are included in the CICS Explorer 5.2.0.2 and IBM Explorer for z/OS 2.1.0.8 fix packs:

Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
5.2.0.2
Update for POODLE security vulnerability
Maintenance roll up
In CICS Explorer 5.2.0.1 programs appear with a 'BUNDLE' icon
Support for Apple OS X Yosemite 10.10 or higher
IBM Explorer for z/OS
2.1.0.8
Update for POODLE security vulnerability
Maintenance roll up
Support for Apple OS X Yosemite 10.10 or higher


The 5.2.0.2 and 2.1.0.8 fix packs have been incorporated into the latest release of CICS Explorer and IBM Explorer for z/OS which are hosted on the primary IBM CICS Explorer Downloads page. The fix packs for the older releases have been included in the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

For more information, refer to the APARs for the fix packs.

There are no related POODLE security vulnerability APARs for the CICS Tools plug-ins for CICS Explorer. If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

See Finding security and integrity APARs for System z products like CICS TS for the best way to stay current and be notified when there is a security and integrity APAR for CICS Transaction Sever for z/OS and the CICS Tools that run on z/OS.

To see if there have been any APARs opened against the CICS Explorer since these versions became available, see the Fix lists for the CICS Explorer .


5.1.0.1 provides the fix for APARs IV36046 and IV35382

Available: 9 May 2013

Version 5.1.0.1 of the CICS Explorer includes APAR IV36046 and IV35382:

  • IV36046 fixes a problem stopped CICS Explorer V5.1 from connecting to CICS on z/VSE
  • IV35382 provides additional support for CICS event binding

More details about these APARs can be found by clicking on the links to the APARs in the table below.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

 

Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, and 4.1
5.1.0.1
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.0.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.0.1
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
2.0.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.0
none


There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates, however, an updated CICS IA 5.1 plug-in is also available (V5.1.0.1).

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.3, 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
CICS Configuration Manager 5.3 plug-in for CICS Explorer
CICS Interdependency Analyzer 5.3 plug-in for CICS Explorer
CICS Performance Analyzer 5.3 plug-in for CICS Explorer


https://www.ibm.com/support/docview.wss?uid=isg400002360 Readme and Release notes for release 1.3.0.11 Parallel Environment Runtime Edition 1.3.0.11 PERTE-1.3.0.11-power-Linux Readme

Removed when 5.3.0.2 was added:

Removed when 5.3.0.2 was added:
5.3.0.1 CICS Explorer rebuilt due to a security vulnerability affecting IBM Explorer for z/OS 3.0


Available: 23 February 2016

As a result of a security vulnerability in the IBM Java SDK (referred to as “SLOTH”) that affects IBM Explorer for z/OS 3.0, upon which CICS Explorer is built, CICS Explorer has been rebuilt. See Security Bulletin: Vulnerability in IBM Java SDK affects IBM Explorer for z/OS 3.0 (CVE-2015-7575) for details.

CICS Explorer itself is not affected by the security vulnerability so there is no associated APAR. In order to obtain the update, see Ordering maintenance for IBM CICS Explorer and CICS Explorer plug-ins for details.

There are no updates to the CICS Tools plug-ins that are associated with this security vulnerability. But, if you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

before changes 1/21/2016 tmh

before changes 1/21/2016 tmh
Latest version of CICS Explorer and CICS tools plug-ins for CICS Explorer
Technote (FAQ)

Question

What is the latest release that you can download of the IBM CICS Explorer and CICS Tools plug-ins for CICS Explorer, that support CICS Transaction Server for z/OS (CICS TS) V5.2, V5.1, V4.2, V4.1, V3.2, or V3.1?

Answer

Click on one of the following CICS Explorer releases to see the version highlights and the corresponding CICS tools plug-in releases. The releases are in order from latest (newest) to oldest.


Many of the new releases of CICS Explorer and CICS Tools plug-ins contain bug fixes in addition to new functionality. To see a complete list of APARs for the CICS Explorer and CICS tools plug-ins for the CICS Explorer, click on the link for each of the products Fix list from the Fixes by version document.

Note: There are no PTFs associated with the APARs for CICS Explorer or the CICS tools plug-ins for CICS Explorer.

IBM provides two methods for you to obtain the maintenance for the CICS Explorer. You can use the preferred method and update to the new version from within the CICS Explorer by applying the maintenance from an IBM-hosted Eclipse update site, or you can download the maintenance from IBM Fix Central. See the "Installation instructions" in the Readme for each product for more details. The Readme also contains the prerequisites and the list of enhancements and bugs fixed by each new version.

The latest release of CICS Explorer and CICS Tools plug-ins for CICS Explorer are hosted on the primary IBM CICS Explorer Downloads page. This simplifies what you will have to do if downloading the CICS Explorer for the first time. To get the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The reference tables also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

The CICS Explorer downloads are free. See Getting started with the CICS Explorer if you are a new to the CICS Explorer and would like more information about installation and getting updates.

5.2.0.4 CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer enhancements and support for APAR PI38229 and PI22815


Available: 7 October 2015

CICS Interdependency Analyzer plug-in for CICS Explorer V5.2.0.4 provides:
  • Support for CICS Interdependency Analyzer for z/OS APAR PI38229:
  • In the Queries, Command Flow, and Visualization views, TSQNAME and TSQUEUE AUX fields incorrectly appear on the list of CICS Types.
  • In the Queries and Command Flow views, READQ AUX and WRITEQ AUX fields are missing from the list of available CICS Commands.
  • Support is provided for CICS Interdependency Analyzer for z/OS APAR PI22815 compatibility:
  • In the Queries view, Command Flow Queries using a remote name do not produce results.
  • In the Command Flow view the Remote Name and Remote Sysid information is incorrect.
  • Enhancements
  • The resource connections view has been redesigned.
  • Uses Resources view has been redesigned.

For more information about the updates, click on the Readme and APARs in the following table:
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer
 

The above-mentioned enhancements are also included in 5.1.1.7 CICS Interdependency Analyzer 5.1 plug-in:

Product (and link to Readme)
Version
(Readme)
APAR
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
 

This fix pack for the older release has been included in the download packages for previous releases of CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

Back to top


5.2.0.5 CICS Explorer enhancements and 2.1.0.11 z/OS Explorer maintenance updates


Available: 29 September 2015

CICS Explorer V5.2.0.5 fixes various problems and minor documentation changes identified in CICS Explorer V5.2:
  • Adding the Regions column to the default task view columns.
  • Improving the way connection exceptions are displayed in installed tools.
  • Correcting the delete button in the drop down in the editor breadcrumb.
  • Corrected an issue where the WLM workload owner is not show in CICS Explorer when installing a routing rule into an existing workload.
  • Fixed a problem whereby the message CNX0593E was issued when removing a CMTCMDEF through CICS Explorer.

IBM Explorer for z/OS V2.1.0.11 provides a fix and minor documentation updates. The fix is to improve the way connection exceptions are displayed in installed tools.

For more information about the updates, click on the Readmes and APARs in the following table:
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer **
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer ***
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.0.0
none
CICS Performance Analyzer 5.2 plug-in for CICS Explorer ***
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.5, however, CICS Configuration Manager's fix pack recently became available so the APARs are included in the table.
*** These have been included to display the most recent fix packs which are available.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

Back to top


5.2.0.4 CICS Explorer enhancements and 2.1.0.10 z/OS Explorer documentation updates


Available: 24 June 2015

CICS Explorer V5.2.0.4 fixes various problems identified in CICS Explorer V5.2:
  • A number of documentation improvements.
  • Fixed a problem whereby the CICS Event Processing Adapter editor field was not accepting multiple lines of information.
  • Corrected an issue where an IllegalArgumentException loop occurred when selecting the menu 'OSGi Application Project Reference' in RDz.
  • An update to improve our Eclipse support.

IBM Explorer for z/OS V2.1.0.10 provides various documentation updates.

For more information about the updates, click on the Readmes and APARs in the following table:
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer ***
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer ***
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.0.0
none
CICS Performance Analyzer 5.2 plug-in for CICS Explorer **
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.4, however, CICS Performance Analyzer's fix pack recently became available so the APARs are included in the table.
*** These have been included to display the most recent fix packs which are available.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

Back to top


5.2.0.3 CICS Explorer and z/OS Explorer bug fixes


Available: 25 March 2015

CICS Explorer V5.2.0.3 fixes various problems identified in CICS Explorer V5.2:
  • A number of documentation improvements.
  • CICS Explorer 5.2.0.2 should require z/OS Explorer 2.1.0.8 to be present but does not. To resolve this, CICS Explorer 5.2.0.3 cannot be installed without z/OS Explorer 2.1.0.9.
  • Fixed a regression (introduced in CICS Explorer 5.2.0.0) in the safety checking when exporting a new version of an application where some bundles (which are still active in the old installed application) are overwritten.

IBM Explorer for z/OS V2.1.0.9 fixes various problems identified in z/OS Explorer v2.1:
  • CICS Explorer 5.2.0.2 should require z/OS Explorer 2.1.0.8 to be present but does not. To resolve this, CICS Explorer 5.2.0.3 cannot be installed without z/OS Explorer 2.1.0.9.
  • When trying to delete a symlink to a directory, z/OS Explorer recursed into the symlinked directory rather than deleting the symlink itself.

For more information about the updates, click on the Readmes and APARs in the following table:
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2 and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.2 plug-in for CICS Explorer **
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer **
CICS Transaction Gateway plug-in for the CICS Explorer
3.0.0.0
none
CICS Performance Analyzer 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.2.0.3, however, both CICS Interdependency Analyzer's and CICS Configuration Manager's fix packs recently became available so the APARs are included in the table.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this version became available, see the Fix lists for the CICS Explorer .

Back to top


 


5.2.0.2, 5.1.1.6, 5.1.0.2, 1.1.1.5, 1.1.0.4, 1.0.1.4, & 1.0.0.9 POODLE Security update and more


Available: 12 December 2014

Fix packs for the POODLE security vulnerability are provided by the following APARs for the various supported releases of the CICS Explorer and z/OS Explorer:
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
1.0.0.9
Update for POODLE security vulnerability
1.0.1.4
1.1.0.4
1.1.1.5
5.1.0.2
5.1.1.6
5.2.0.2
z/OS Explorer
2.1.0.8



In addition to the APARs for the POODLE security vulnerability, the following APARs are included in the CICS Explorer 5.2.0.2 and z/OS Explorer 2.1.0.8 fix packs:
Product APAR
Version / Fix Pack
Description of Fix
CICS Explorer
5.2.0.2
Update for POODLE security vulnerability
Maintenance roll up
In CICS Explorer 5.2.0.1 programs appear with a 'BUNDLE' icon
Support for Apple OS X Yosemite 10.10 or higher
z/OS Explorer
2.1.0.8
Update for POODLE security vulnerability
Maintenance roll up
Support for Apple OS X Yosemite 10.10 or higher


The 5.2.0.2 and 2.1.0.8 fix packs have been incorporated into the latest release of CICS Explorer and z/OS Explorer which are hosted on the primary IBM CICS Explorer Downloads page. The fix packs for the older releases have been included in the download packages for previous releases of CICS Explorer, see Releases of the CICS Explorer that are no longer available on the primary download page .

For more information, refer to the APARs for the fix packs.

There are no related POODLE security vulnerability APARs for the CICS Tools plug-ins for CICS Explorer. If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

See Finding security and integrity APARs for System z products like CICS TS for the best way to stay current and be notified when there is a security and integrity APAR for CICS Transaction Sever for z/OS and the CICS Tools that run on z/OS.

To see if there have been any APARs opened against the CICS Explorer since these versions became available, see the Fix lists for the CICS Explorer .

Back to top


 


5.2.0.1 Miscellaneous Fixes for CICS Explorer V5.2.0


Available: 23 September 2014

Version 5.2.0.1 of the CICS Explorer provides fixes to various APARs including IV63723 which contains a maintenance roll-up for CICS Explorer. To see a complete list of APARs, see the List of Fixes in the Readme documentation for the CICS Explorer 5.2.0 fix pack 1 (5.2.0.1) .

The latest code is available on the main CICS Explorer downloads page .

There are no fix packs for the CICS Tools plug-ins that are related to CICS Explorer 5.2.0.1. If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

Back to top


 


5.2.0.0 Support for CICS TS 5.2 and many enhancements


Available: 13 June 2014

Version 5.2.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.2 and includes the following new and changed functionality as documented in the release notes:
  • Define FILE, JVMSERVER, PIPELINE, TCPIPSERVICE and WEBSERVICE resources in a CICS® Bundle project
  • View details of, and work with, an application installed on a platform
  • Manage multiple versions of applications installed on a platform
  • Additional content in the CICSplex Explorer view
  • Further support for CICS policies
  • New Repository Explorer view
  • New Operation views:
  • Task related User Exits
  • Global User Exits
  • Shared TS Queues
  • Transaction Dumps
  • System Dumps
  • Unit of Work Links
  • Updated Pipelines view
  • New Workload Management views:
  • WLM Specifications
  • WLM Specification Editor
  • Active Workload Definition, also known as Routing Rules, Editor

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents, then click CICS Explorer User Guide > What's new in version 5.2.

The new CICS Tools V5.2 plug-ins for CICS Explorer provide support and compatibility for the new V5.2 release, as well making use of any new functionality, and some defect fixes.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .
Product
Version
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2, and 3.1
5.2.0.0
none
CICS Configuration Manager 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
2.1.0.0
none
CICS Performance Analyzer 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
2.1.0.0
none
 

CICS Explorer V5.2 and the CICS Tools plug-ins for CICS Explorer are shipped as new releases so no APARs are associated with them. The new code is available on the main CICS Explorer downloads page .

CICS Explorer V5.2 is compatible with CICS TS V5.2, V5.1, V4.2, V4.1, V3.2, and V3.1. Therefore, you can install the new version of CICS Explorer and take advantage of a lot of the new functionality regardless of the release of CICS TS you are using.

In CICS Performance Analyzer for z/OS (CICS PA) V5.2, the Explorer plug-in Historical Database (HDB) templates EXPLOR42 and EXPLOR51 have been significantly enhanced. The enhancements include many new fields and data format changes to some of the existing fields. Therefore if you use CICS TS V4.2 or V5.1 with the CICS PA V5.2 plug-in, refer to Significant changes to CICS PA 5.2 Explorer plug-in HDB templates require action if using CICS TS 4.2 and 5.1 for more information .

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of CICS Explorer or the release of a CICS Tool that you are using, refer to the CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables also give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

Back to top


 


5.1.1.4 CICS Explorer and z/OS Explorer bug fixes

Available: 6 February 2014

CICS Explorer V5.1.1.4 fixes a problem with duplicate host connections being created in the CICS Explorer when upgrading from CICS Explorer V1.1.1 to V5.1.1. Version 5.1.1.4 also fixes java.lang.NullPointerExceptions that occur while using the CICS Explorer Files view to browse FILE resources in CICS. The error occurs when switching between local and remote files.

IBM Explorer for z/OS V2.1.0.4 provides support for CICS Explorer APAR IV52926.

For more information about the updates, click on the Readmes and APARs in the following table.
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.1.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.1.1
none
CICS Transaction Gateway V9.0 plug-in for the CICS Explorer
9.0.1.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

As documented in the Readme for APAR IV52044 and IV52926, "If CICS Explorer has been installed using IBM Installation Manager with IBM Explorer for z/OS 2.1.0.x as the base package group, then the CICS Explorer V5.1.1.4 and IBM Explorer for z/OS V2.1.0.4 fix packs must be applied simultaneously." This means that if you used Installation Manager to install both z/OS Explorer and CICS Explorer then you will need to install both CICS Explorer V5.1.1.4 and IBM Explorer for z/OS V2.1.0.4 fix packs at the same time. If you only used Installation Manager to install z/OS Explorer, however, these updates are independent of each other, and if you installed CICS Explorer into another base (such as Rational Application Developer) or standalone, the updates are independent of each other.

There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.1.1.4.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top


 


5.1.1.3 CICS Explorer and z/OS Explorer bug fixes

Available: 2 December 2013

CICS Explorer V5.1.1.3 fixes a language structure parsing error and a compile error on program link method calls.

IBM Explorer for z/OS V2.1.0.3 fixes an internal error that occurs when trying to save changes and a connection failure.

For more information about the updates, click on the Readmes and APARs in the following table.
 
Product (and link to Readme)
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.1.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer **
CICS Transaction Gateway V9.0 plug-in for the CICS Explorer
9.0.1.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

As documented in the Readme for APAR IV51448 and IV51452,"If CICS Explorer has been installed using IBM Installation Manager with IBM Explorer for z/OS 2.1.0.x as the base package group, then the CICS Explorer V5.1.1.3 and IBM Explorer for z/OS V2.1.0.3 fix packs must be applied simultaneously." This means that if you used Installation Manager to install both z/OS Explorer and CICS Explorer then you will need to install both CICS Explorer V5.1.1.3 and IBM Explorer for z/OS V2.1.0.3 fix packs at the same time. If you only used Installation Manager to install z/OS Explorer, however, these updates are independent of each other, and if you installed CICS Explorer into another base (such as Rational Application Developer) or standalone, the updates are independent of each other.

** There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.1.1.3, however, CICS Interdependency Analyzer fix packs recently became available so the APARs are included in the table. Note that IV47344 is only for CICS IA Tools plug-in V5.1.1.1, but the other 2 APARs are in both versions 5.1.0.2 and 5.1.1.1. The CICS IA V5.1.0.2 fix pack is compatible with CICS Explorer V5.1.0.x and the CICS IA V5.1.1.1 fix pack is compatible with CICS Explorer V5.1.1.x.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top


 


5.1.1.2 z/OS Explorer and CICS Explorer compatibility APAR

Available: 19 September 2013

CICS Explorer V5.1.1.2 only contains the compatibility APAR IV47936 for the IBM Explorer for z/OS 2.1.0.2.

IBM Explorer for z/OS V2.1.0.2 fixes a job submission failure and allows for mixed case user IDs.

For more information about the updates, click on the Readmes and APARs in the following table.
 
Product
Version
(Readme)
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
IBM Explorer for z/OS
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.1.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Transaction Gateway V9.0 plug-in for the CICS Explorer
9.0.1.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

As documented in the Readme for APAR IV47936,"If CICS Explorer has been installed using IBM Installation Manager with IBM Explorer for z/OS 2.1.0.x as the base package group, then the CICS Explorer V5.1.1.2 and IBM Explorer for z/OS V2.1.0.2 fix packs must be applied simultaneously." This means that if you used Installation Manager to install both z/OS Explorer and CICS Explorer then you will need to install both CICS Explorer V5.1.1.2 and IBM Explorer for z/OS V2.1.0.2 fix packs at the same time. If you only used Installation Manager to install z/OS Explorer, however, these updates are independent of each other, and if you installed CICS Explorer into another base (such as Rational Application Developer) or standalone, the updates are independent of each other.

There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.1.1.2.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top


5.1.1.1 PHP support for Dynamic Scripting and some bug fixes

Available: 16 August 2013

CICS Explorer V5.1.1.1 adds PHP support in CICS Explorer SDK V5.1.1 to allow you to create the sample PHP applications for CICS TS Feature Pack for Dynamic Scripting V2.0 . There are also a few bug fixes included in version 5.1.1.1 of CICS Explorer.

IBM Explorer for z/OS V2.1.0.1 also contains some fixes to a couple problems.

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents, then click CICS Explorer User Guide > What's new in version 5.1.1.1.

For more information about the updates, click on the APARs in the following table.
 
Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
5.1.1.1
IBM Explorer for z/OS
2.1.0.1
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.1.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Transaction Gateway V9.0 plug-in for the CICS Explorer
9.0.1.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
 

As documented in the Readme for these APARs. "If CICS Explorer has been installed using IBM Installation Manager with IBM Explorer for z/OS 2.1.0.0 as the base package group, then the CICS Explorer V5.1.1.1 and IBM Explorer for z/OS V2.1.0.1 fix packs must be applied simultaneously." This means that if you used Installation Manager to install both z/OS Explorer and CICS Explorer then you will need to install both CICS Explorer V5.1.1.1 and IBM Explorer for z/OS V2.1.0.1 fix packs at the same time. If you only used Installation Manager to install z/OS Explorer, however, these updates are independent of each other, and if you installed CICS Explorer into RAD or standalone the updates are independent of each other.

There are no updates to the CICS Tools plug-ins that are related to CICS Explorer V5.1.1.1.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top


5.1.1.0 Support for Eclipse 4.2.2 and IBM Explorer for z/OS V2.1

Available: 14 June 2013

CICS Explorer V5.1.1.0 provides support for Eclipse 4.2.2 and z/OS Explorer V2.1. The plug-ins for the following products in the CICS Tools family are also updated. They deliver some updated capabilities, tolerating the latest CICS Explorer and Eclipse levels, and providing plug-ins in Installation Manager format:
  • CICS Configuration Manager for z/OS, V5.1.1
  • CICS Deployment Assistant for z/OS, V5.1.1
  • CICS Interdependency Analyzer for z/OS, V5.1.1
  • CICS Performance Analyzer for z/OS, V5.1.1
  • CICS Transaction Gateway for z/OS, V9.0.1

z/OS Explorer, previously an integral part of CICS Explorer, is now available as a separate component. It delivers unified, extensible, workstation connectivity to key IBM z/OS functionality by providing simple and secure access to z/OS datasets, zFS files, and JES jobs, and output from within an Eclipse-based Rich Client Platform (RCP). For more information on IBM Explorer for z/OS V2.1, see the US Announcement Letter IBM Explorer for z/OS V2.1 (213-141), dated 23 April, 2013.

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents, then click CICS Explorer User Guide > What's new in version 5.1.1.

For more information on the new updates, see the release notes for the CICS Explorer and each plug-in available under Further information on the CICS Explorer downloads page .
 
Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
5.1.1.0
none
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.1.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS Transaction Gateway V9.0 plug-in for the CICS Explorer
9.0.1.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.1.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none


CICS Explorer V5.1.1.0 and the updated CICS tools plug-ins are shipped as new releases so no APARs are associated with them. The new code is available on the main CICS Explorer downloads page .

CICS Explorer V5.1.1.0 is compatible with CICS TS V5.1, V4.2, V4.1, V3.2, and V3.1 so you can install the new version of the CICS Explorer and advantage of a lot of the new functionality regardless of the release of CICS TS you are using. All compatible tools have their own 5.1.1 mod release. So for example, to use the CICS Performance Analyzer (CICS PA) plug-in with CICS Explorer V5.1.1, you would need to download and install CICS PA plug-in V5.1.1. There is no option to use CICS Explorer V5.1.1 with CICS PA plug-in V5.1.0.


The IBM Session Manager for z/OS CICS Explorer plug-ins are not compatible with CICS Explorer V5.1.1.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top


5.1.0.1 provides the fix for APARs IV36046 and IV35382

Available: 9 May 2013

Version 5.1.0.1 of the CICS Explorer includes APAR IV36046 and IV35382:
  • IV36046 fixes a problem stopped CICS Explorer V5.1 from connecting to CICS on z/VSE
  • IV35382 provides additional support for CICS event binding
More details about these APARs can be found by clicking on the links to the APARs in the table below.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .
 
Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
5.1.0.1
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.0.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.0.1
CICS Transaction Gateway plug-in for the CICS Explorer
2.0.0.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.0
none


There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates, however, an updated CICS IA 5.1 plug-in is also available (V5.1.0.1).

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

Back to top

5.1.0.0 Support for CICS TS 5.1 and many enhancements


Available: 14 December 2012

Version 5.1.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.1 and includes the following new functionality as documented in the release notes:
  • Composite update site provides a simple way to keep up to date with new versions of CICS Explorer and add new tools and plug ins to your CICS Explorer environment.
  • Ability to perform a system dump.
  • Ability to create an application definition.
  • Ability to create a platform definition.
  • Ability to create a policy definition.
  • Ability to add a CICS® bundle to a platform.
  • Ability to remove a CICS bundle from a platform.
  • Ability to define dependencies in a CICS bundle project.
  • Ability to define and edit resources in a CICS bundle project.
  • Ability to define static data when defining a event.
  • Ability to query the policy rules that have been deployed within a given scope.
  • Ability to define dependencies in a CICS bundle project.
  • System events now support the MESSAGE capture point.
  • Application events now support the Write-to-Operator capture point.
  • Support for combining EP Adapters into EP Adapter Sets.
  • Support in the Event Binding Editor for emitting static data on an event.
  • Ability to rebuild the Secure Sockets Layer (SSL) for a CICS region.
  • CICS Explorer can connect to CICS servers using Secure Sockets Layer (SSL).
  • A new perspective has been added: The CICS Cloud perspective which you can use to view all cloud resources in a CICSplex, in a platform or application-centric way.
  • Seven new Operation views are added: Applications view; Cloud Explorer view; Data Tables view, EP Adapter Sets view; Physical Data Sets view, Platforms view, and z/OS® Workload Management view.
  • Two new Definition views are added: Application Definitions view, and Platform Definitions view.
  • New fields have been added to the Task and Completed Tasks views.
  • CICS Explorer SDK support for CICS TS 5.1 JCICS.
  • CICS Explorer SDK support for Java™ 7.
  • CICS Explorer SDK field names in the Task view have been changed to be more meaningful.
  • The CICS Explorer SDK Active Workloads view has been renamed to the Workloads view.

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents, then click CICS Explorer User Guide > What's new in version 5.1.

The new plug-ins for the CICS tools that support CICS Explorer V5.1 provide compatibility, new functionality, and some defect fixes. Much of the new functionality is not dependent on you having CICS TS V5.1.

There is also a new SupportPac CS1V: CICS VSAM Transparency for z/OS plug-in for CICS Explorer that will help you manage your migrated files if you use CICS VSAM Transparency for z/OS (CICS VT).

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .
Product
Version
APAR
CICS Explorer for CICS TS 5.1,4.2, 4.1, 3.2, and 3.1
5.1.0.0
none
CICS Configuration Manager 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Deployment Assistant 5.1 plug-in for the CICS Explorer
5.1.0.0
none
CICS Interdependency Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
2.0.0.0
none
CICS Performance Analyzer 5.1 plug-in for CICS Explorer
5.1.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.0
none
 

CICS Explorer V5.1 and the CICS tools plug-ins are shipped as new releases so no APARs are associated with them. The new code is available on the main CICS Explorer downloads page .

CICS Explorer V5.1.0.0 is compatible with CICS TS V5.1, V4.2, V4.1, V3.2, and V3.1 so you can install the new version of the CICS Explorer and advantage of a lot of the new functionality regardless of the release of CICS TS you are using. With Java™ 7, however, some of the weaker ciphers are no longer loaded into the JVM by default at runtime which can result in difficulties connecting to weakly configured servers. See CICS Explorer 5.1.0.0 contains important security updates and enhancements for more details.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer or the release of a CICS tool that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The tables in this document also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

Back to top


 


1.1.0.3 and 1.1.1.3 Miscellaneous fixes


Available: 05 October 2012

The table below lists the APARs in version 1.1.0.3 and 1.1.1.3 of the CICS Explorer. Details about these APARs can be found by clicking on the APARs or the Readmes in the table. The What's New topics in the CICS Explorer User Guide also describe the new and changed items in more detail. To display the topics, click Help > Help Contents on the
The previous CICS Explorer version 1.0.0.8, 1.0.1.3, 1.1.0.2, and CICS Explorer menu.
 
Product (and link to Readme)
Version
APARs
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.1.3
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.0.3
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.2 plug-in for CICS Explorer
none
none
CICS IA 3.1 plug-in for CICS Explorer
none
none
CICS PA 3.2 plug-in for CICS Explorer
none
none
CICS PA 3.1 plug-in for CICS Explorer
none
none
ISM 3.1 plug-in for CICS Explorer
none
none

1.1.1.2 resolves a security risk and the update requires that you manually update the JRE by re-installing the CICS Explorer to one of these new versions. So if you did not install one of these versions, see Manual update of CICS Explorer is required to resolve security risk for more information.

There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates. If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The matrix also contains the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer or the plug-ins for the CICS tools since these new versions became available, see the Fix lists for the CICS Explorer .

Back to top


 


1.0.0.8, 1.0.1.3, 1.1.0.2, and 1.1.1.2 Resolves security risk and more


Available: 08 August 2012

APAR IV20931 includes updates for the CICS Explorer in versions 1.0.0.8, 1.0.1.3, 1.1.0.2, and 1.1.1.2 that resolve a security risk by including an updated IBM Java™ Runtime Environment (JRE) bundled in the stand-alone versions of CICS Explorer.

In addition to the IV20931, there are other APARs available in versions 1.1.0.2 and 1.1.1.2. More details about these APARs can be found by clicking on the APARs or Readmes in the table. The What's New topics in the CICS Explorer User Guide also describe the new and changed items in more detail. To display the topics, click Help > Help Contents on the CICS Explorer menu.
Product (and link to Readme)
Version
APARs
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.1.2
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.0.2
IV20931
IV19014
CICS Explorer for CICS TS 4.1, 3.2, and 3.1
1.0.1.3
IV20931
CICS Explorer for CICS TS 4.1, 3.2, and 3.1
1.0.0.8
IV20931
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.2 plug-in for CICS Explorer
none
none
CICS IA 3.1 plug-in for CICS Explorer
none
none
CICS PA 3.2 plug-in for CICS Explorer
none
none
CICS PA 3.1 plug-in for CICS Explorer
none
none
ISM 3.1 plug-in for CICS Explorer
none
none


This update requires that you manually update the JRE by re-installing the CICS Explorer to one of these new versions. See Manual update of CICS Explorer is required to resolve security risk for more information.

There are no updates to the CICS tools plug-ins that correspond with the CICS Explorer updates. If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The matrix also contains the releases of Eclipse SDK required for the different releases of CICS Explorer.

To see if there have been any APARs opened against the CICS Explorer or the plug-ins for the CICS tools since these new versions became available, see the Fix lists for the CICS Explorer .

Note: You will not find APAR IV20931 on the web since it is a security APAR.

Back to top


 


1.1.1.0 Improved connection management and z/OS support, and more


Available: 11 May June 2011

Version 1.1.0.0 of the CICS Explorer includes the following new functionality as documented in the release notes:
  • A new infrastructure to manage system connections
  • Support for CICS TS for VSE/ESA
  • Support of the z/OS Management Facility (z/OSMF)
  • Ability to copy and paste resource data to a spreadsheet
  • Ability to export a file or folder to a z/OS Unix file system
  • Ability to create a z/OS Unix file
  • Ability to create a data set
  • Ability to create a resource from an existing definition
  • Ability to see the contents resource definition group
  • Support for multiple selection job submission from the z/OS Data Sets view
  • Support for deleting or purging multiple files in the z/OS Explorer
  • Ability to create a Job Submission project and JCL files, in the Project Explorer view in the resource perspective, while working offline
  • You can now use Installation Manager to install the CICS Explorer SDK, however, if you do use this method to install CICS Explorer, you must install all future updates by using Installation Manager.

The What's New topics in the CICS Explorer User Guide describes the new and changed items in more detail. To display the topics, click Help > Help Contents on the CICS Explorer menu.

To see if there have been any APARs opened against the CICS Explorer or the plug-ins for the CICS tools since this version became available, see the Fix lists for the CICS Explorer .
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.1.0
none*
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.1 plug-in for CICS Explorer *
none
none
CICS PA 3.2 plug-in for CICS Explorer **
none
none
ISM 3.1 plug-in for CICS Explorer *
none
none



*CICS Explorer V1.1.1.0 is shipped as a new release so no APAR is associated with it. Now that a newer version of the CICS Explorer is available, the latest level of V1.1.1.0 (like V1.1.1.3) will be available on the web page containing releases of the CICS Explorer that are no longer available on the primary download page

CICS Explorer V1.1.1 stores data in a different way to previous versions:
  • Old workspaces are irreversibly migrated to the new data format when they are used with CICS Explorer V1.1.1.
  • Connection preferences in updated workspaces will not be successfully read by old versions of CICS Explorer
Therefore, IBM recommends that you take a backup of your CICS Explorer workspace before installing CICS Explorer V1.1.1. This will enable you to use an older version of CICS Explorer.

If you need to determine the releases of the CICS tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer that you are using, see CICS Explorer and CICS tools plug-ins release compatibility reference tables . The matrices also contains the releases of Eclipse SDK required for the different releases of CICS Explorer.

Back to top



 


1.1.0.1 Defect fixes for CICS Explorer V1.1 and SDK


Available: 14 October 2011

Version 1.1.0.1 of the CICS Explorer provides defect fixes for the CICS Explorer V1.1 and SDK.

For more information on the new updates, click on the link to the CICS Explorer Readme and APAR. To see the most recent APAR(s) for the CICS Explorer plug-ins for the CICS tools, see the Fix lists for the CICS Explorer or the Readme in the table for each plug-in.
Product (and link to most current Readme)
Version
APAR
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.0.1
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.2 plug-in for CICS Explorer *
3.2.0.0
none
CICS IA 3.1 plug-in for CICS Explorer
none
none
CICS PA 3.2 plug-in for CICS Explorer
none
none
ISM 3.1 plug-in for CICS Explorer
none
none
 

*The CICS IA 3.2 plug-in for CICS Explorer became available when CICS IA 3.2 became generally available on 2 September 2011. It is part of the new release so no APAR is associated with it. It was originally available on the main Explorer download site , but now that newer versions are available see the web page containing releases of the CICS Explorer that are no longer available on the primary download page.

The CICS IA 32 plug-in is NOT currently compatible with CICS IA V3.1. This is why you will still see the CICS IA V3.1 plug-in on the main Explorer download site. The CICS IA 3.2 plug-in is also NOT compatible with CICS Explorer V1.0 because it relies on changes that went into CICS Explorer V1.1 that allow it to have two connections (for the database and the collector) open at the same time.

Back to top


 


1.1.0.0 Support for CICS TS 4.2 and some bug fixes


Available: 24 June 2011

Version 1.1.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V4.2 and includes the following new functionality as documented in the release notes:
  • New SM Administration perspective
  • Support for column sorting in views
  • Support for system events in the CICS event binding editor.
  • Ability to choose an EPADAPTER configuration.
  • Addition of an online and offline EP search function.
  • New edit functions added to the event binding editor.
  • Ability to create new z/OS® UNIX® directories.
  • Ability to change the access permissions for z/OS UNIX files and directories.
  • Addition of a Save as function for z/OS UNIX files.
  • Ability to create Atom configuration files.
  • Ability to disable JVM Servers.
  • Improved support for transaction tracking
  • The System z®.OS perspective is renamed to the z/OS perspective.
  • Changes to the CICS Explorer menu bar.
  • Eight new WLM views have been added in this version.
  • Four new Operations views have been added in this version.
  • Two new general views have been added in this version.
  • The Active Workloads view has been renamed to the Workloads view.
  • CICS Explorer SDK support has been added for creating Java OSGi applications

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents > What's new in version 1.1.0.0.

The new plug-ins for the CICS tools provide compatibility with the CICS TS V4.2 Explorer and some defect fixes. For more information on the new updates, click on the links to the APARs.

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1
1.1.0.0
none*
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.9
CICS DA 1.1 plug-in for the CICS Explorer
1.1.0.2
CICS IA 3.1 plug-in for CICS Explorer *
none
none
CICS PA 3.2 plug-in for CICS Explorer **
3.2.0.1
ISM 3.1 plug-in for CICS Explorer *
none
none
 

*CICS Explorer V1.1.0.0 is shipped as a new release so no APAR is associated with it . It was originally available on the main Explorer download site , but now that newer versions are available see the web page containing releases of the CICS Explorer that are no longer available on the primary download page .

CICS Explorer V1.1.0.0 is compatible with CICS TS V4.2, V4.1, V3.2, and V3.1 so IBM recommends that you upgrade to this new version. See CICS Explorer for CICS TS 4.2 is compatible with earlier releases of CICS TS for more information.

*The CICS IA V3.1 plug-in V3.1.0.9 and ISM V3.1 plug-in V3.1.0.0 work with the CICS Explorer V1.1.0.0.

**The CICS PA V3.2 plug-in works with both CICS PA V3.1 and V3.2, and CICS Explorer V1.1.0.0. When you install this plug-in in the new Explorer, you will be enabling the CICS Explorer update site for the CICS PA V3.2 plug-in.

Back to top


 


1.0.1.2 Fix Explorer signoff errors


Available: 31 May 2011

Version 1.0.1.2 of the CICS Explorer fixes errors that occur intermittently when signing off the CICS Explorer.

For more information on the new updates, click on the links to the Readme and APAR.

CICS tools plug-ins are not being refreshed this time.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.1.2
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.1 plug-in for CICS Explorer
none
none
CICS PA 3.1 plug-in for CICS Explorer
none
none
ISM 3.1 plug-in for CICS Explorer
none
none
 

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Back to top

1.0.1.1 Fix to TS Model view


Available: CICS TS - 11 February 2011 (CICS IA and ISM - 11 March 2011)

Version 1.0.1.1 of the CICS Explorer fixes a problem seen when trying to view TSMODELS which results in an error message that you see when you view the error log:
org.eclipse.ui.PartInitException: Could not create view: com.ibm.cics.sm.ui.views.tsModels

For more information on the new updates, click on the links to the Readmes and APARs.

CICS tools plug-ins are not being refreshed this time.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.1.1
CICS CM 2.1 plug-in for CICS Explorer
none
none
CICS DA 1.1 plug-in for the CICS Explorer
none
none
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.9
CICS PA 3.1 plug-in for CICS Explorer
none
none
ISM 3.1 plug-in for CICS Explorer
3.1.0.0
none
 

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the Fix lists for the CICS Explorer .

Note:
CICS Explorer V1.0.1.1 is the latest version of the CICS Explorer, however, the minimum version of CICS Explorer for the CICS IA plug-in V3.1.0.9 (IZ92175) is V1.0.0.7.

The CICS Explorer plug-in for IBM Session Manager for z/OS (ISM) V3.1 became available when ISM V3.1 became generally available on 11 March 2011. Therefore, there is no APAR for this plug-in.

Back to top


 


1.0.1.0 New System z/OS perspective, ability to view SIT, and more


Available: 24 September 2010

Version 1.0.1.0 of the CICS Explorer provides the following new functionality:
  • The new System z/OS perspective containing a set of new views to help you manage your System z artifacts. These views are named Data Sets, Jobs, z/OS UNIX® Files, and Console.
  • The ability to export and import system connection details using the new Connection Export/Import page in the Connection Preferences view. You can export your connections as an .xml file. This file can be edited, shared with other users, and imported into other CICS Explorer instances.
  • A new breadcrumb trail is displayed in the editor view that shows the location of a resource.
  • The ability to view system initialization table (SIT) parameters, SIT overrides, or a combination of both. You cannot, however, see changes in the values of parameters that were made after startup using system programming interface commands.
  • Four new Operations views have been added in this version. These views are named CMAS to CMAS Links view, Journal Models view, Journal Names view, and Stream Names view.
  • One new Administration view named CMAS to CMAS Link Definitions view.
  • A System z/OS Quick Tips section has been added to the documentation. This topic is intended to provide short answers to frequently asked questions about the System z/OS perspective.
  • Fixes for many defects

For more information on the new updates the topic, click Help > Help Contents > What's new in version 1.0. 1 from the CICS Explorer after applying the updates.

CICS CM plug-in updates also provide new functionality and defect fixes. CICS IA and CICS PA are not being refreshed this time (CICS TG plug-in is also not being refreshed). The existing versions of the plug-ins for CICS IA (3.1.0.7) and CICS PA (3.1.0.4) are supported to be used with both CICS Explorer V1.0.1.0 and V1.0.0.7.

Click on the links to the Readme and APARs for more details.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.1.0
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.8
CICS DA 1.1 plug-in for the CICS Explorer
1.1.0.1
CICS IA 3.1 plug-in for CICS Explorer
none
none
CICS PA 3.1 plug-in for CICS Explorer *
none
none


IMPORTANT Notes:
To get Version 1.1.0.1 of the CICS DA V1.1 plug-in, you might need to enable the CICS DA update site. See IZ86863 provides a new version 1.1.0.1 of the CICS DA 1.1 plug-in for the CICS Explorer for instructions on how to enable the CICS DA update site.

The plug-ins for the CICS tools are supported with both CICS Explorer V1.0.0.x and V1.0.1.x so you can upgrade to V1.0.1.0 but it is not mandatory. The CICS Deployment Assistant (CICS DA) plug-in, however, requires V1.0.1.0 of the CICS Explorer and will not work with V1.0.0.7.


You will need the new V2.1.0.8 of the CICS CM plug-in if you use CICS Explorer V1.0.1.0. But, V2.1.0.8 of the CICS CM plug-in also works with CICS Explorer V1.0.0.7.

* When CICS PA V3.2 became available on 10 December 2010, a CICS PA V3.2 plug-in for the CICS Explorer also became available and is compatible with CICS PA V3.1. If you are running CICS PA 3.1, IBM would like to encourage you to take advantage of this free update.

Back to top

1.0.0.7 Support for Windows 7 32 bit and much more


Available: 16 July 2010

Version 1.0.0.7 of the CICS Explorer provides the following new functionality:
  • A new Preferences Credentials page has been added for recording user IDs and passwords
  • Ability to configure the CICS Explorer to use a proxy server when connecting to the internet
  • Ability to disable a JVM server using the options PHASEOUT, PURGE, FORCEPURGE, or KILL
  • Changes to the Preferences Connections view to use credentials instead of user ID and password
  • One new Operations view and two new Administration views
  • Support for Microsoft Windows 7 32 bit
  • Fixes for many defects

For more information on the new updates search for "What's new in version 1.0.0.7" section in the CICS Explorer Help.

CICS CM, CICS IA, and CICS PA plug-in updates provide new functionality and defect fixes. Click on the links to the Readmes and APARs for more details.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.7
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.7
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.7
CICS PA 3.1 plug-in for CICS Explorer
3.1.0.4

Back to top


1.0.0.6 CorbaServer resource management and HTTP EP adapter


Available: 29 April 2010

Version 1.0.0.6 of the CICS Explorer adds the ability to view and manage CorbaServer resources from a new CorbaServers view, adds a new HTTP Event Processing (EP) adapter in the Event Processing editor, and provides fixes for many defects. For more information on the new updates search for "What's new in version 1.0.0.6" section in the CICS Explorer Help.

CICS CM and CICS IA plug-in updates provide defect fixes. Click on the links to the APARs for more details.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.6
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.6
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.6
CICS PA 3.1 plug-in for CICS Explorer
none
none

Back to top


1.0.0.5 WLM support, search for related tasks, and TASKASSC view


Available: 26 February 2010

Version 1.0.0.5 of the CICS Explorer provides additional support for CICSPlex SM Workload Management (WLM), the ability to search for related tasks that have been started under the same network Unit of Work or Transaction Group ID, a new Task Associations (TASKASSC) view, additional general documentation topics, and fixes for many defects.

CICS CM and CICS IA plug-in updates also provide new functionality. Click on the links to the APARs for more details.
Product
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.5
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.5
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.5
CICS PA 3.1 plug-in for CICS Explorer
none
none
 

Back to top


1.0.0.4 Copy resources, add group to list, and bug fixes


Available: 18 December 2009

Version 1.0.0.4 of the CICS Explorer provides the ability to copy and paste resource definitions between different regions or plexes, the ability to add a GROUP to a LIST, new perform operation dialog, and various bug fixes.
Product (and link to Readme)
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.4
CICS CM 2.1 plug-in for CICS Explorer
2.1.0.4
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.4
CICS PA 3.1 plug-in for CICS Explorer
3.1.0.3

Back to top

1.0.0.3 Fix TS queue deletion


Available: 11 December 2009

Version 1.0.0.3 (APAR IZ65446) of the CICS Explorer sets the filter attributes on the delete temporary storage (TS) queue command to only delete the selected TS queues and not all the other TS queues in scope. Prior to applying this fix, deleting a CICS TS queue in CICS Explorer deletes all TS queues. Therefore, until this APAR has been applied, do not delete any TS queues using the CICS Explorer.
Product
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.3
 

Back to top


 


1.0.0.2 CSD support and bug fixes


Available: 7 October 2009

Version 1.0.0.2 of the CICS Explorer provides CICS System Definition (CSD) support to the CICS Explorer for CICS TS V4.1 and various bug fixes.
Product
Version
APAR
CICS Transaction Server for z/OS 4.1
-
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.2
CICS CM 2.1 plug-in for CICS Explorer *
2.1.0.3
CICS IA 3.1 plug-in for CICS Explorer
3.1.0.2
CICS PA 3.1 plug-in for CICS Explorer
3.1.0.2


* CICS CM plug-in Version 2.1.0.2 and APAR IZ62228 were replaced on 22 October 2009. The new Version adds Japanese (Kanji) language translation support and fixes two bugs as documented in the Readme.

CICS TS V4.1 APAR PK90112 provides the ability to administer CICS through the CSD in the CICS Explorer for CICS TS V4.1. You can apply the PTFs for PK90112 the way you would normally apply maintenance to CICS using SMP/E. See Ordering CICS products and maintenance for the options that are available to order CICS PTF(s).


Notes:
  • APAR IZ62254 for the CICS Explorer is applicable to CICS TS V4.1 and V3. You will see that this APAR is for release 100, not 600 (4.1) or 500 (3.2) or 400 (3.1).
  • Support for CSD access from the CICS Explorer is not available for CICS TS V3.1 and V3.2, however, there are many bugs fixed in 1.0.0.2 so IBM recommends that you upgrade to this new version.

Back to top


1.0.0.1 Support for CICS tools plug-ins and minor bug fixes


Available: July 2009

Version 1.0.0.1 (APAR IZ62213) of the CICS Explorer provides compatibility for the CICS tools plug-ins and fixes a number of minor bugs.
Product
Version
APAR
CICS Explorer for CICS TS 4.1 and 3.2 and 3.1
1.0.0.1
 

Back to top

Related information

Ask questions about CSD support - CICS Explorer forum


CICS Explorer for CICS TS 4.2, 4.1, 3.2, and 3.1


Before attempting to apply these updates see Action required due to change in CICS Explorer update site locations .

The update site location changed last September. Therefore, if you have not already manually updated the update sites within your CICS Explorer then you will still need to follow the process described in Action required due to change in CICS Explorer update site locations to pick up the latest CICS IA updates.

Paul Taylor's recommendations (changes in pink) - 6/13/2014

1404312 PNT version
 
Latest version of z/OS Explorer, CICS Explorer, and CICS tools plug-ins for CICS Explorer
 
Technote (FAQ)

Question
What is the latest release that you can download of the IBM Explorer for z/OS (z/OS Explorer), IBM CICS Explorer, and CICS Tools plug-ins for CICS Explorer, that support CICS Transaction Server for z/OS (CICS TS) V5.2, V5.1, V4.2, V4.1, V3.2, or V3.1?
Answer
Click on one of the following CICS Explorer releases to see the version highlights and the corresponding CICS Tools plug-in releases. The releases are in order from latest (newest) to oldest.
Many of the new releases of the CICS Explorer and CICS Tools plug-ins for CICS Explorer contain bug fixes, in addition to new functionality. To see a complete list of APARs for the CICS Explorer and CICS Tools plug-ins for CICS Explorer, click on the link for each of the products Fix list from the  Fixes by version document.  

Note: There are no PTFs associated with the APARs for the CICS Explorer or the CICS Tools plug-ins for CICS Explorer.

IBM provides two methods for you to obtain the maintenance for the CICS Explorer. You can use the preferred method and update to the new version from within the CICS Explorer by applying the maintenance from an IBM-hosted Eclipse Update-site, or you can download the maintenance from IBM Fix Central. See the "Installation instructions" in the Readme for each product for more details. The Readme also contains the prerequisites and the list of enhancements and bugs fixed by each new version. 

The latest release of CICS Explorer and CICS Tools plug-ins for CICS Explorer are hosted on the primary  IBM CICS Explorer Downloads  page. This simplifies what you will have to do if downloading the CICS Explorer for the first time. To get the download packages for previous releases of CICS Explorer, see  CICS Explorer downloads for older releases of CICS Explorer

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with the release of the CICS Explorer that you are using, see  CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables matrix also contain the releases of Eclipse SDK required for the different releases of CICS Explorer.

The CICS Explorer downloads are free. See  Getting started with the CICS Explorer  if you are a new to the CICS Explorer and would like more information about installation and getting updates.



 
5.2.0.0 Support for CICS TS 5.2 and many enhancements


Available: 13 June 2014 

Version 5.2.0.0 of the CICS Explorer provides support for CICS Transaction Server for z/OS V5.2 and includes the following new and changed functionality as documented in the release notes:
  • Define FILE, JVMSERVER, PIPELINE, TCPIPSERVICE and WEBSERVICE resources in a CICS® Bundle project
    View details of, and work with, an application installed on a platform
    Manage multiple versions of applications installed on a platform
    Additional content in the CICSplex Explorer view
    Further support for CICS policies
    New Repository Explorer view
    New Operation views:
    Task related User Exits
    Global User Exits
    Shared TS Queues
    Transaction Dumps
    System Dumps
    Unit of Work Links
    Updated Pipelines view
    New Workload Management views:
    WLM Specifications
    WLM Specification Editor
    Active Workload Definition, also known as Routing Rules, Editor

The What's New topic in the CICS Explorer help documentation describes the new and changed items in more detail. To display the topic, click Help > Help Contents, then click CICS Explorer User Guide > What's new in version 5.2.

The new CICS Tools V5.2 plug-ins for CICS Explorer provide support and compatibility for the new V5.2 release, as well making use of any new functionality, and some defect fixes. Much of the new functionality is not dependent on you having CICS TS V5.2. 

[Should I just remove this sentence???? I don't think there's an updated version} There is also a ?????? updated ?????  SupportPac CS1V: CICS VSAM Transparency for z/OS plug-in for CICS Explorer  that will help you manage your migrated files if you use CICS VSAM Transparency for z/OS (CICS VT). 

To see if there have been any APARs opened against the CICS Explorer since this versions became available, see the  Fix lists for the CICS Explorer

 
Product
Version
APAR
CICS Explorer for CICS TS 5.2, 5.1, 4.2, 4.1, 3.2, and 3.1
5.2.0.0
none
CICS Configuration Manager 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS Deployment Assistant 5.2 plug-in for the CICS Explorer
5.2.0.0
none
CICS Interdependency Analyzer 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS Transaction Gateway plug-in for the CICS Explorer
2.1.0.0
none
CICS Performance Analyzer 5.2 plug-in for CICS Explorer
5.2.0.0
none
CICS VSAM Transparency (SupportPac) & z/OS components
2.1.0.0
none
IBM Session Manager 3.2 plug-in for CICS Explorer
3.2.0.2
none


CICS Explorer V5.2 and the CICS Tools plug-ins for CICS Explorer are shipped as new releases, so no APARs are associated with them. The new code is available on the  main CICS Explorer downloads page

CICS Explorer V5.2.0.0 is compatible with CICS TS V5.2, V5.1, V4.2, V4.1, V3.2, and V3.1. Therefore, so you can install the new version of the CICS Explorer and take advantage of a lot of the new functionality, regardless of the release of CICS TS you are using. 

If you need to determine the releases of the CICS Tools plug-ins for CICS Explorer that are compatible with a particular release of the CICS Explorer, or the release of a CICS Tool that you are using, then refer to the  CICS Explorer and CICS tools plug-ins release compatibility reference tables . These reference tables in this document also contain the give details of the releases of Eclipse SDK that are required for the different releases of CICS Explorer.

Before changes 6-13-2014

Before changes 6-13-2014
Latest version of CICS Explorer and CICS tools plug-ins for CICS TS

What is the latest version that you can download of the IBM CICS Explorer for CICS Transaction Server for z/OS (CICS TS) V5.2, V5.1, V4.2, V4.1, V3.2, or V3.1, and the corresponding CICS tools plug-ins and IBM Explorer for z/OS?


 

[{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Component":"CICS Explorer","Platform":[],"Version":"5.2;5.3;5.4;5.5","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSPPUS","label":"CICS Interdependency Analyzer for z/OS"},"Component":"CICS Explorer Plug-in","Platform":[],"Version":"5.5;5.3;5.2;5.1","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSPPU4","label":"CICS Performance Analyzer for z/OS"},"Component":"CICS Explorer Plug-in","Platform":[],"Version":"5.4;5.3;5.2;5.1","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SS2L7A","label":"CICS Configuration Manager for z/OS"},"Component":"CICS Explorer Plug-in","Platform":[],"Version":"5.4;5.3;5.2;5.1","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSCLNZ","label":"CICS Deployment Assistant for z/OS"},"Component":"CICS Explorer Plug-in","Platform":[],"Version":"5.3;5.2;5.1","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSGMJ2","label":"CICS Transaction Gateway"},"Component":"CICS Transaction Gateway plug-in for CICS Explorer","Platform":[],"Version":"9.2;9.1;9.0;","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSBQNK","label":"CICS VSAM Transparency for z/OS"},"Component":"CICS Explorer plug-in","Platform":[],"Version":"2.1","Edition":""},{"Business Unit":{"code":"BU011","label":"Systems - zSystems"},"Product":{"code":"SSBDYH","label":"IBM Explorer for z/OS"},"Component":"Maintenance","Platform":[],"Version":"2.1.0;3.0.0;3.0.1;3.1.0","Edition":""}]

Product Alias/Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
16 September 2019

UID

swg21404312