Troubleshooting
Problem
Problem with padmin snap command on PowerVM Virtual I/O Server (VIOS)
Symptom
padmin snap command hangs or fails
Cause
This technote discusses the most frequently causes for snap failures on a VIOS and troubleshooting approach if the command is believed to be hung.
Environment
VIOS 3.1 and 4.1
Diagnosing The Problem
Determine your VIOS level. Login as padmin and run:
$ ioslevel
Then, see Part 3 of this technote for known issues. If they are not applicable to your VIOS level, see Resolving the problem for further investigation.
Resolving The Problem
Part 1 - padmin snap command hangs
A. Refer to Troubleshooting a Hung Process or Command on PowerVM Virtual I/O Server.
Note 1:
During "Gathering tcpip system information.....", snap command also gathers some fcstat data. If the procedure in Part 1.A shows snap is hanging in fcstat, e.g. "/usr/sbin/fcstat -e fcs2", then, that means there is some kind of issue associated with that fibre channel port that needs to be investigated. In such case, run errlog command on the VIOS to determine if there are errors reported by the fibre channel port that might need attention. If no adapter errors are reported, next, work with your SAN administrator to verify all other physical components such as cables, GBIC, switch port, FC adapter port, etc.
Press 'enter' for no action, 's' to attempt to kill
the current operation, or 'q' to quit out altogether:
Part 2 - padmin snap fails
By default, padmin snap command will create 2 compressed files in /tmp and /home file systems:
/tmp/ibmsupt/snap.pax.Z and
/home/padmin/snap.pax.Z
Therefore, these file systems must have enough free space to hold the snap data.
Ensure /tmp and /home are at 50% Used or less. This percentage seems to work for most environments. To check filesystem space, run:
$ df -g
For more details, see Diagnosing Full File Systems in PowerVM VIOS.
If file system space is not an issue, reproduce the snap failure as outlined in Capturing Debug Output of padmin CLI and submit the following:
$ oem_setup_env
# cd /home/ios/logs
# tar cvf home_ios_logs_.tar `find . -type f` ->upload the generated tarball
# ls -la *.tar
-rw-r--r-- 1 root staff 385392640 Jun 19 12:25 home_ios_logs_.tar
Part 3 Known Issues (not exhaustive)
# alog -f /home/ios/logs/viosvc.log -o > /tmp/viosvc.out
# alog -f /home/ios/logs/viosvc.log.err -o > /tmp/viosvc.err
fcs2!7710322514101e04.0320080200
If your adapter firmware is at 0320080200, update to level 0320080270:
Impact: Data Severity: HIPER
Fix for a potential issue during error recovery processing resulting in a possible loss of data that would not be detected if an IO is aborted after partial transfer of the FCP_RSP payload.
Related Information
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Document Information
Modified date:
22 July 2025
UID
isg3T1023492