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OmniFind documentation, articles, useful tips

Question & Answer


Question

Where can I find documentation and tips regarding the usage and optimization of the OmniFind product?

Cause

Information on the OmniFind product is scarce and inconsistent on the web.

Answer

This document seeks to provide the general users of the OmniFind product with all the information they would need to properly utilize it's capabilities. The below is to be understood as a list of separate information sources that can be used to further strengthen/improve one's knowledge of the OmniFind Text Search Server for the IBM i operating system.

The documents and articles listed below are not directly related to each other but are rather gathered in one place in order to provide the clients with easy access to all available documentation at one place. The information is provided as is and any specific questions or concerns that clients may have are to be addressed via the regular support initiation process for further assistance.



1. OmniFind Articles:  

2. OmniFind manuals:

 

3. OmniFind White Papers

 

4. Additional documents and resources:

 

5. How to completely clean up an environment before doing a fresh install of the OmniFind product:

If we want a totally clean system to install OmniFind, as if the system has never been installed with OmniFind before, the following should be done:


A) Stop and shut down OmniFind server

 

For V6R1/V7R1 systems, issue the following instructions.

    • Issue STRSQL from 5250 command line
    • CALL SYSPROC.SYSTS_STOP()
    • Open QShell from 5250 command line - QSH
    • Type /QOpenSys/QIBM/ProdData/TextSearch/server1/bin/shutdown.sh

  • For V7R2/V7R3 systems, issue the following instructions.
    • Issue STRSQL from 5250 command line
    • CALL SYSPROC.SYSTS_SHUTDOWN()
B) Clean up Catalog files
  •  
    • RUNSQLSTM SRCSTMF('/QOpenSys/QIBM/ProdData/TextSearch/resetOMF.sql') COMMIT(*NONE) NAMING(*SQL)

C) Uninstall OmniFind
  •  
    • DLTLICPGM LICPGM(5733OMF)

  • You should receive messages similar to the ones below: 

    • *LNG objects for NLV 2924 for product 5733OMF option *BASE release V1R2M0 deleted.

      *PGM objects for product 5733OMF option *BASE release V1R2M0 deleted.

      Objects for product 5733OMF option *ALL release *ONLY deleted.

    • Verify that library QDBTSLIB does not exist, delete it if exists via DLTLIB QDBTSLIB

D) Manually remove IFS directories (some directories will be preserved during the uninstall)
    • Start QShell from a 5250 command line - QSH
    • Run the following: rm -r /QOpenSys/QIBM/ProdData/TextSearch
6.OmniFind indexing of partitioned tables
When a text search index is built over a range partitioned table, the text index is created over the entire table. The index cannot be isolated to a particular partition.

It is not possible for keys in another member to cause duplicate keys in the text search index.
http://publib.boulder.ibm.com/infocenter/iseries/v7r1m0/index.jsp?topic=/dbmult/partrestrict.htm

Important considerations:
- A primary key cannot be built over a single partition.
- A unique index must contain all keys that make up the partition. (Else SQLSTATE 42997)
- Records are not allowed to be moved from one partition to another (must be dropped and inserted)
- OmniFind Triggers fire for all members of the partition.

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Document Information

Modified date:
15 August 2022

UID

nas8N1022233