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How to collect logs from IBM c-type and Cisco MDS 9000 Series switches

Question & Answer


Question

How to collect logs from Cisco MDS 9000 series switches

Cause

Cisco switch data and logs are needed when their is issue with Cisco switch itself or if there is SAN related issues

Answer

Configure your telnet or ssh application (example putty) to log the screen output to a text file.

Baseline data collection for all types of problems
Then connect to the switch and run commands as below.
# term length 0 (this command allows the text output to scroll)
# show tech-support details
# show logging onboard
# show hardware internal statistics device fabric errors
# show interface transceiver details
# show tech-support fcip (In case FCIP connection is involved)
# show tech-support slowdrain (In case we need to analyse a performance problem)
# exit

Please collect one command set (as listed above) per switch and name the file as below.
            [switchname]_showtech_YYYYMMDD_hhmm.txt
            Example: ibmsw_showtech_20160421_1030.txt

Collect logs from all the switches in your fabric one by one or from the switches in question.

Compress all show tech details of switch belonging one fabric in one compressed file.
Upload a single compressed file per fabric.
            Example:
            Fabric_A_showtech_20160421_1030.zip
            Fabric_B_showtech_20160421_1030.zip

Upload the file to IBM under your PMR number
            http://www.ecurep.ibm.com/app/upload

Error counters on switch are cumulative, so its good practice to clear the stats on switch after collecting the logs, and then to collect another set of logs once problem has re-occurred or after few hours if its ongoing problem.

Run the commands below to clear the stats on switch

#clear counters interface all (Clears the port counters)
#debug system internal clear-counters all (Clears the ASIC counters)
#clear ips stats all (Clears FCIP counters only needed on FCIP enabled switches)

 

If you need additional instructions once the data collection is completed, please review to upload it to Ecurep. If you're a Blue Diamond customer, refer to the Blue Diamond upload instructions.

[{"Product":{"code":"SSU6LN","label":"Cisco MDS 9710 Multilayer Director"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"","label":"N\/A"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"STTQW4","label":"Cisco MDS 9706 Multilayer Director"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"STTQ3Y","label":"Cisco MDS 9513 Multiplayer Director"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"ST7SML","label":"Storage area network (SAN)-\u003ECisco MDS 9509 Multilayer Director"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSBDGXE","label":"Cisco MDS 9506 Multilayer Director"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}},{"Product":{"code":"ST5PVM","label":"Cisco MDS 9396S 16G Multilayer Fabric Switch"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB71","label":"Storage HW"}},{"Product":{"code":"ST6VQW","label":"Storage area network (SAN)-\u003ECisco MDS 9124 Fabric Switch"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SUPPORT","label":"IBM Worldwide Support"},"Business Unit":{"code":"BU051","label":"N\/A"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB33","label":"N\/A"}}]

Document Information

Modified date:
11 November 2025

UID

ssg1S1005787