Question & Answer
Question
Why do I get these errors when installing rpm packages from the AIX Toolbox for Linux Applications site?
# rpm -ivh <package.rpm> error: Failed dependencies: libssl.a(libssl.so.1.0.2) is needed by <package>
libcrypto.a(libcrypto.so.1.0.2) is needed by <package> |
Cause
AIX Toolbox for Linux packages that require openssl are built against the openssl.base file set provided by IBM through the AIX web download pack programs.
- For download instructions, see Downloading and Installing or Upgrading OpenSSL and OpenSSH .
Since the libraries are provided through AIX installp, the AIX-rpm virtual pack must be updated so these libraries are part of the RPM database.
Answer
To resolve the errors:
1) Be sure you have a supported openssl.base file set installed. It is recommended to always use the latest support level. The latest openssl.base file set provides existing and new versioned shared objects to provide compatibility with older packages.
2) Uninstall any openssl.rpm packages, since they often cause conflicts with the Toolbox packages.
3) After the openssl.base file set installation or update, run the following command. This will update the virtual AIX-rpm package so the rpm installer will be aware of the new or updated libraries:
# /usr/sbin/updtvpkg
SUPPORT | ||||
---|---|---|---|---|
A) For all questions or issues with Toolbox packages, the support is handled by the AIX Open Source Team in the forum: https://community.ibm.com/community/user/power/communities/community-home?CommunityKey=10c1d831-47ee-4d92-a138-b03f7896f7c9 ** Cases opened to address Toolbox problems will be canceled and users will be referred to the Open Source Forum.
B) If there is a problem with installing rpm.rte, or executing the rpm binary file, open an AIX Case (See the following C section) for assistance. Examples of rpm.rte issues supported through AIX Support: Example of an rpm.rte rpm loading issue:
C) Opening an AIX Support Case If additional assistance is required due to issues with rpm.rte file set (see preceding B section), use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract. 1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue. 2. Capture any logs or data relevant to the situation. 3. Contact IBM to open a case: -For electronic support, see the IBM Support Community: |
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Document Information
Modified date:
12 August 2020
UID
ibm16258275