IBM Support

Resolving RPM libssl.a and libcrypto.a errors

Question & Answer


Question

Why do I get these errors when installing rpm packages from the AIX Toolbox  for Linux Applications site?

# rpm -ivh <package.rpm>

error: Failed dependencies:

libssl.a(libssl.so.1.0.2) is needed by <package>

libcrypto.a(libcrypto.so.1.0.2) is needed by <package>

Cause

AIX Toolbox for Linux packages that require openssl are built against the openssl.base file set provided by IBM through the AIX web download pack programs.

Since the libraries are provided through AIX installp, the AIX-rpm virtual pack must be updated so these libraries are part of the RPM database.
 

Answer

To resolve the errors:

1)  Be sure you have a supported openssl.base file set installed.  It is recommended to always use the latest support level. The latest openssl.base file set provides existing and new versioned shared objects to provide compatibility with older packages.

2)  Uninstall any openssl.rpm packages, since they often cause conflicts with the Toolbox packages.

3)  After the openssl.base file set installation or update,  run the following command. This will update the virtual AIX-rpm package so the rpm installer will be aware of the new or updated libraries:

# /usr/sbin/updtvpkg

 

SUPPORT

A) For all questions or issues with Toolbox packages, the support is handled by the AIX Open Source Team in the forum: https://community.ibm.com/community/user/power/communities/community-home?CommunityKey=10c1d831-47ee-4d92-a138-b03f7896f7c9

The AIX Open Source Team provides support through the forum, only. They answer questions, if possible, but they don't own the packages, or formally support them. For true expertise in usage of each package, users should consult the community for each respective package. 

** Cases opened to address Toolbox problems will be canceled and users will be referred to the Open Source Forum.
If you experience technical issues accessing the AIX Open Source community or forum, refer to the footer of the IBM Community forum page.
There is email, and "Contact Us" information for community support

B) If there is a problem with installing rpm.rte, or executing the rpm binary file, open an AIX Case (See the following C section) for assistance.

Examples of rpm.rte issues supported through AIX Support:
- Errors updating or migrating the rpm.rte file set
- Commands from the rpm.rte file set coredump, or have runtime errors.

Example of an rpm.rte rpm loading issue:

# rpm -qa
    exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors:
    0509-150 Dependent module libnss3.so could not be loaded.
    0509-022 Cannot load module libnss3.so.
    0509-026 System error: A file or directory in the path name does not exist.

 
This example would be handled through an IBM AIX Support case, and the support team would help resolve the missing modules.
To learn what is provided and supported by the rpm.rte file set:

# lslpp -f rpm.rte

C) Opening an AIX Support Case

If additional assistance is required due to issues with rpm.rte file set (see preceding B section), use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1.  Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2.  Capture any logs or data relevant to the situation.

3.  Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

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Document Information

Modified date:
12 August 2020

UID

ibm16258275