IBM Support

AIX Encryption: libcurl.a errors loading hdcryptmgr

Question & Answer


Question

Why does the following error occur, and how can I resolve it?

exec (): 0509-036 Cannot load program hdcryptmgr because of the following error:
0509-022 Cannot load module /usr/lib/libhdcrypt.a(shr_64.0)
0509-150 Dependent module /usr/lib/libcurl.a(libcurl.so.4) could not be loaded.
0509-103 The module has as invalid magic number

Cause

The hdcryptmgr requires /usr/opt/oss/lib/libcurl.a, which is installed by oss.lib.libcurl.

However, you might have an older curl rpm package installed. The 2020 version of curl-0:7.67.0-2.ppc was the last AIX Toolbox for Open Source Software curl version that created a symlink from /usr/lib/libcurl.a to /opt/freeware/lib/libcurl.a. This symlink is no longer created by the Toolbox packages.

Perhaps your curl package is 2020 or older, or from a non-AIX Toolbox package.

Answer

As a temporary workaround, you can try:

# LIBPATH=/usr/opt/oss/lib:$LIBPATH hdcryptmgr

But to avoid other problems, you can remove any non-AIX Toolbox curl rpms, or update to the latest from the AIX Toolbox.

You can check the curl package version:

# rpm -qi curl | egrep "Name|Version|Build Host"

Name : curl

Version : 8.4.0

Build Host : pokndd5.pok.stglabs.ibm.com

If the Build Host is not an stglabs.ibm.com hostname, it is probably older, or from a non-Toolbox site.

If you use other open source products, you should update this package. If you use other AIX Toolbox packages, we recommend that you use the Toolbox "curl" package as well.

The AIX Toolbox team recommends using DNF to install and manage Open Source software packages and dependencies

SUPPORT

A) For all questions or issues with AIX Toolbox for Open Source Software ("AIX Toolbox") packages, support is provided through the following options:

1) The AIX Open Source Community Discussion forum: 

Cases opened to address AIX Toolbox problems are canceled and users are referred to the Open Source Forum.
 
If you experience technical issues accessing the AIX Open Source community or forum, refer to the footer of the IBM Community forum page. There is email, and "Contact Us" information for community support.
 

B) If there is a problem with installing rpm.rte, or executing the rpm binary file, open an AIX Case (See the following C section) for assistance.

Examples of rpm.rte issues supported through AIX Support:
- Errors updating or migrating the rpm.rte file set
- Commands from the rpm.rte file set core dump, or have runtime errors.

Example of an rpm.rte rpm loading issue:

# rpm -qa
    exec(): 0509-036 Cannot load program /usr/opt/freeware/bin/rpm because of the following errors:
    0509-150 Dependent module libnss3.so could not be loaded.
    0509-022 Cannot load module libnss3.so.
    0509-026 System error: A file or directory in the path name does not exist.

 
This example would be handled through an IBM AIX Support case, and the support team would help resolve the missing modules.
To learn what is provided and supported by the rpm.rte file set:

# lslpp -f rpm.rte
 

C) Opening an AIX Support Case

If more assistance is required for issues with the rpm.rte file set (see preceding B section), use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1.  Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2.  Capture any logs or data relevant to the situation.

3.  Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2. Capture any logs or data relevant to the situation.

3. Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

4. Provide a clear, concise description of the issue.

 - For more information, see: Working with IBM AIX Support: Describing the problem.

5. If the system is accessible, collect a system snap, and upload all of the details and data for your case.

 - For more information, see: Working with IBM AIX Support: Collecting snap data


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Document Information

More support for:
AIX

Software version:
All Versions

Operating system(s):
AIX

Document number:
7112533

Modified date:
30 January 2024

UID

ibm17112533

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