Topic
  • 10 replies
  • Latest Post - ‏2013-09-18T14:53:45Z by irina999
irina999
irina999
23 Posts

Pinned topic TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

‏2013-02-01T11:37:13Z |
Hi,
I have WAS8FP5 Network Deployment Manager server configured with com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus interceptor that connects to TAM eB 6.1.1 with WebSeal.
I created PDPerm.properties using TAM Runtime for Java utility com.tivoli.pd.jcfg.PDJrteCfg and com.tivoli.pd.jcfg.SvrSslCfg on all nodes in NDM cell and configured custom properties for the TAM interceptor:
com.ibm.websphere.security.webseal.configURL - location of PDPerm.properties file
com.ibm.websphere.security.webseal.loginId - TDS user
com.ibm.websphere.security.webseal.id - iv_creds

Enabled trace in NDM server for TAMTrustAssociationInterceptorPlus. As soon as I restart NDM server (not even go to nodes) I am getting the following exception in the trace:

2/1/13 11:02:49:475 GMT 00000000 TrustAssociat > loadInterceptor Entry
com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus
{com.ibm.websphere.security.webseal.configURL=C:\IBM\WebSphere\AppServer\java\jre\PdPerm.properties, com.ibm.websphere.security.webseal.id=iv_creds, com.ibm.websphere.security.webseal.ssoPwdExpiry=0, com.ibm.websphere.security.webseal.loginId=websealuser, com.ibm.websphere.security.webseal.checkViaHeader=false}
2/1/13 11:02:49:522 GMT 00000000 SystemOut O com.tivoli.pd.as.jacc.cfg.TAMConfigService initialize() About to initialize PDAdmin with the value C:\IBM\WebSphere\AppServer\tivoli\tam
2/1/13 11:02:49:662 GMT 00000000 TrustAssociat A SECJ0121I: Trust Association Init class com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus loaded successfully
2/1/13 11:02:49:662 GMT 00000000 TrustAssociat 3 Trust Properties =
{com.ibm.websphere.security.webseal.configURL=C:\IBM\WebSphere\AppServer\java\jre\PdPerm.properties, com.ibm.websphere.security.webseal.id=iv_creds, com.ibm.websphere.security.webseal.ssoPwdExpiry=0, com.ibm.websphere.security.webseal.loginId=websealuser, com.ibm.websphere.security.webseal.checkViaHeader=false}
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc > com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus initialize(Properties) ENTRY
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc > com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getIDElements(String strList) ENTRY iv_creds
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusgetIDElements(String) Added iv_creds to the list.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusgetIDElements(String) Added iv-creds to the list.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc < com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getIDElements(String) RETURN
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) Check VIA header has been set to false.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc > com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getElements(String strList) ENTRY null
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc < com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getElements(String) RETURN null
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) There are no trusted hostnames configured but via header will not be checked anyway.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc > com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getElements(String strList) ENTRY null
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc < com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus getElements(String) RETURN null
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) There are no trusted host ports configured but via header will not be checked anyway.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) Exception encountered when retrieving webseal.viaDepth : java.lang.NumberFormatException: null VIA Depth has been set to default value of 0
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) webseal.ssoPwdExpiry value is 0. Cached SSO password will never expire.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) WebSeal Login ID has been set to configured login id.
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc 1 com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) PDJRTE config URL = C:\IBM\WebSphere\AppServer\java\jre\PdPerm.properties
2/1/13 11:02:49:662 GMT 00000000 TAMTrustAssoc > com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus createPDContext(String configURL) ENTRY C:\IBM\WebSphere\AppServer\java\jre\PdPerm.properties
2/1/13 11:02:49:725 GMT 00000000 TAMTrustAssoc I com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlusinitialize(Properties) AWXRB0002E An error occurred while creating the Tivoli Access Manager authorization context. The details are:
[java.lang.IllegalStateException: java.lang.NullPointerException
at com.tivoli.pd.jutil.kb$1.run(kb$1.java:41)
at java.security.AccessController.doPrivileged(AccessController.java:229)
at com.tivoli.pd.jutil.kb.c(kb.java:141)
at com.tivoli.pd.jutil.kb.<init>(kb.java:56)
at com.tivoli.pd.jutil.PDContext.<init>(PDContext.java:76)

2/1/13 11:02:49:740 GMT 00000000 TAMTrustAssoc < com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus initialize(Properties) RETURN -1
2/1/13 11:02:49:740 GMT 00000000 TrustAssociat E SECJ0384E: Trust Association Init Error. The Trust Association interceptor implementation com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus initialization failed. The error status/exception is -1. If you receive this error message in association with a trust association interceptor that you are not using, you can ignore this message.
2/1/13 11:02:49:740 GMT 00000000 TrustAssociat 3 The Trust Association Implementation file com.ibm.ws.security.web.TAMTrustAssociationInterceptorPlus init method returned error status: -1. The expected status for success is 0

Does anyone know if TAI++ Interceptor is supported on WAS8.0 connecting to TAM eB / WebSeal?
If anyone have any idea why its failing or if there are any configurations required in WAS 8 for TAI++ to connect to WebSeal?

I have another similar system but on WAS NDM 7.0 and TAI++ Interceptor is working fine.

As a result user from my client application can not authenticate through WebSeal.

Appreciate your responce.

Irina Chvets
Updated on 2013-02-05T09:27:29Z at 2013-02-05T09:27:29Z by irina999
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-01T13:34:05Z  
    Found in TAM eB 6.1.1 that:
    Access Manager Runtime for Java only supports the following Java™ runtime environments (JREs):
    IBM® Java Runtime 1.5.0 SR5 provided with Tivoli Access Manager
    The JRE provided with WebSphere® Application Server 6.1.

    If I am using JRE provided with WAS 8.0 and it seems to be JRE 1.6 does it mean that Access Manager Runtime for Java was not qualified with WAS 8? Are there any fixes or patches available to support it with WAS8?

    Regards,
    Irina Chvets
  • hans.vandeweghe@be.ibm.com
    33 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-01T13:44:45Z  
    • irina999
    • ‏2013-02-01T13:34:05Z
    Found in TAM eB 6.1.1 that:
    Access Manager Runtime for Java only supports the following Java™ runtime environments (JREs):
    IBM® Java Runtime 1.5.0 SR5 provided with Tivoli Access Manager
    The JRE provided with WebSphere® Application Server 6.1.

    If I am using JRE provided with WAS 8.0 and it seems to be JRE 1.6 does it mean that Access Manager Runtime for Java was not qualified with WAS 8? Are there any fixes or patches available to support it with WAS8?

    Regards,
    Irina Chvets
    Hello Irina,

    I would recommend moving to the latest fixpack of TAM 6.1.1 (currently 6.1.1-ISS-TAM-FP0006):

    http://www-933.ibm.com/support/fixcentral/swg/selectFix?product=ibm%2FTivoli%2FTivoli+Access+Manager+for+e-business&fixids=6.1.1-ISS-TAM-FP0006-WIN&source=dbluesearch&function=fixId&parent=Security%20Systems

    There is a change introduced in WAS 8, which requires certain files to be stored in other directories.
    The influence of this change for the TAM product is discussed by the DOC APAR IV00007.
    http://www-01.ibm.com/support/docview.wss?uid=swg1IV00007

    PDJrte configuration into WAS 8 is not complying with WAS 8 requirement that the JRE must be read only. It provides no method to configure into the new WAS 8 locations for PD.jar and it configuration options at WAS_HOME/tivoli/tam.

    When you download the latest fixpack for TAM, make sure to also download the README. That has an important section discussing the required steps for integration wiht WAS 8.
    7.14 SUPPORT FOR CONFIGURING WEBSPHERE APPLICATION SERVER, VERSION 8 FOR PDJRTE (IV00007)

    Hope this will help! Ff not, feel free to raise a PMR

    Sincerely,
    Hans Vandeweghe
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-04T09:55:18Z  
    Hello Irina,

    I would recommend moving to the latest fixpack of TAM 6.1.1 (currently 6.1.1-ISS-TAM-FP0006):

    http://www-933.ibm.com/support/fixcentral/swg/selectFix?product=ibm%2FTivoli%2FTivoli+Access+Manager+for+e-business&fixids=6.1.1-ISS-TAM-FP0006-WIN&source=dbluesearch&function=fixId&parent=Security%20Systems

    There is a change introduced in WAS 8, which requires certain files to be stored in other directories.
    The influence of this change for the TAM product is discussed by the DOC APAR IV00007.
    http://www-01.ibm.com/support/docview.wss?uid=swg1IV00007

    PDJrte configuration into WAS 8 is not complying with WAS 8 requirement that the JRE must be read only. It provides no method to configure into the new WAS 8 locations for PD.jar and it configuration options at WAS_HOME/tivoli/tam.

    When you download the latest fixpack for TAM, make sure to also download the README. That has an important section discussing the required steps for integration wiht WAS 8.
    7.14 SUPPORT FOR CONFIGURING WEBSPHERE APPLICATION SERVER, VERSION 8 FOR PDJRTE (IV00007)

    Hope this will help! Ff not, feel free to raise a PMR

    Sincerely,
    Hans Vandeweghe
    Thank you Hans very much for this info.
    I have installed patch for TAM base components on TAM/WebSEAL server.
    I also installed TAMJRT from the patch on WAS8.0 server. Followed the instructions from the Readme for configuring WAS8.0 but got into problems. Since my TAM JRT env was already configured prior the patch I unconfigured the old env and now I need to run PDJrteCfg and SvrSslCfg again.

    When I run PDJrteCfg as per Readme using the following command

    java -Dpd.home="C:\IBM\WebSphere\AppServer\java\jre\PolicyDirector" com.tivoli.pd.jcfg.PDJrteCfg -action config -host tam611 -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -alt_config -config_type full -port 7135

    I am getting the following msg:
    "Access Manager License fileset not correct."

    Any idea what is causing it?

    Also its not clear from Readme what parameters I need to run SvrSslCfg after setting up a new TAMJRE env with the new PD.jar file?

    Appreciate your help.
    Regards,
    Irina
  • hans.vandeweghe@be.ibm.com
    33 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-04T10:29:01Z  
    • irina999
    • ‏2013-02-04T09:55:18Z
    Thank you Hans very much for this info.
    I have installed patch for TAM base components on TAM/WebSEAL server.
    I also installed TAMJRT from the patch on WAS8.0 server. Followed the instructions from the Readme for configuring WAS8.0 but got into problems. Since my TAM JRT env was already configured prior the patch I unconfigured the old env and now I need to run PDJrteCfg and SvrSslCfg again.

    When I run PDJrteCfg as per Readme using the following command

    java -Dpd.home="C:\IBM\WebSphere\AppServer\java\jre\PolicyDirector" com.tivoli.pd.jcfg.PDJrteCfg -action config -host tam611 -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -alt_config -config_type full -port 7135

    I am getting the following msg:
    "Access Manager License fileset not correct."

    Any idea what is causing it?

    Also its not clear from Readme what parameters I need to run SvrSslCfg after setting up a new TAMJRE env with the new PD.jar file?

    Appreciate your help.
    Regards,
    Irina
    Hi Irina,

    I'm not sure about the "Access Manager License fileset not correct.", I know I've seen it before but not able to track back my steps I've taken to resolve that in the past.

    Are you sure the correct PATH and JAVA_HOME variables are set? I typically run the setupCmdLine script from within the WAS profile that should be configured with the PDJRTE.

    Something like this:

    C:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\bin>setupCmdLine.bat
    C:\Program Files\Tivoli\Policy Director\sbin>pdjrtecfg.exe -action config -java_home "C:\IBM\WebSphere\AppServer\java\jre" -host tam611 -port 7135 -domain Default -config_type full -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -was -alt_config
    Still from the same commandline (so with the correct JAVA JRE environment variables):

    java -Dpd.cfg.home=WAS_HOME/tivoli/tam com.tivoli.pd.jcfg.SvrSslCfg -action config -admin_id sec_master -admin_pwd sec_master_password -appsvr_id tai-demo -appsvr_pwd tai-demo-pwd -mode remote -port 1234 -host hostname-tai-demo -policysvr tam611:7135:1 -authzsvr tam611:7136:1 -cfg_file "c:\TAI\eaidemo.conf" -domain Default -key_file "c:\TAI\eaidemo.kdb" -cfg_action create

    Hope it helps...!
    Sincerely,
    Hans Vandeweghe
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-04T11:29:11Z  
    Hi Irina,

    I'm not sure about the "Access Manager License fileset not correct.", I know I've seen it before but not able to track back my steps I've taken to resolve that in the past.

    Are you sure the correct PATH and JAVA_HOME variables are set? I typically run the setupCmdLine script from within the WAS profile that should be configured with the PDJRTE.

    Something like this:

    C:\Program Files\IBM\WebSphere\AppServer\profiles\AppSrv01\bin>setupCmdLine.bat
    C:\Program Files\Tivoli\Policy Director\sbin>pdjrtecfg.exe -action config -java_home "C:\IBM\WebSphere\AppServer\java\jre" -host tam611 -port 7135 -domain Default -config_type full -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -was -alt_config
    Still from the same commandline (so with the correct JAVA JRE environment variables):

    java -Dpd.cfg.home=WAS_HOME/tivoli/tam com.tivoli.pd.jcfg.SvrSslCfg -action config -admin_id sec_master -admin_pwd sec_master_password -appsvr_id tai-demo -appsvr_pwd tai-demo-pwd -mode remote -port 1234 -host hostname-tai-demo -policysvr tam611:7135:1 -authzsvr tam611:7136:1 -cfg_file "c:\TAI\eaidemo.conf" -domain Default -key_file "c:\TAI\eaidemo.kdb" -cfg_action create

    Hope it helps...!
    Sincerely,
    Hans Vandeweghe
    It seems that when I run the TAMJRE installer from the patch I didn't finish because initially I got a msg saying that TAMJRE 6.1.1.6 is already installed. I didn't proceed and said no to the msg. After running the installer second time I answered yes and finished the installer this fully completed the install.
    At the end of the install I got the msg asking to complete the installer and run pdjrteupg.bat -p command. The command does not run with the following msg:
    'java' is not recognized ...

    I had java configured in PATH env variable, but I did not have JAVA_HOME. I configured JAVA_HOME system env variable now however I am still getting the same error.
    Do I need to modify any parameters in pdjrteupg.bat file?

    I also tried to run as you mentioned pdjrtecfg.exe command rather than though java similar to yours:

    C:\IBM\Tivoli\Policy Director\sbin>pdjrtecfg.exe -action config -java_home "C:\IBM\WebSphere\AppServer\java\jre" -host tam611 -port 7135 -config_type full -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -was -alt_config

    but I got msg:
    Invalid option name -alt_config

    Could this msg be cased because the upgrade above was not fully finished since i was not able to run pdjrteupg.bat command?

    Regards,
    Irina Chvets
  • hans.vandeweghe@be.ibm.com
    33 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-04T11:52:58Z  
    • irina999
    • ‏2013-02-04T11:29:11Z
    It seems that when I run the TAMJRE installer from the patch I didn't finish because initially I got a msg saying that TAMJRE 6.1.1.6 is already installed. I didn't proceed and said no to the msg. After running the installer second time I answered yes and finished the installer this fully completed the install.
    At the end of the install I got the msg asking to complete the installer and run pdjrteupg.bat -p command. The command does not run with the following msg:
    'java' is not recognized ...

    I had java configured in PATH env variable, but I did not have JAVA_HOME. I configured JAVA_HOME system env variable now however I am still getting the same error.
    Do I need to modify any parameters in pdjrteupg.bat file?

    I also tried to run as you mentioned pdjrtecfg.exe command rather than though java similar to yours:

    C:\IBM\Tivoli\Policy Director\sbin>pdjrtecfg.exe -action config -java_home "C:\IBM\WebSphere\AppServer\java\jre" -host tam611 -port 7135 -config_type full -cfgfiles_path "C:\IBM\WebSphere\AppServer\tivoli\tam" -was -alt_config

    but I got msg:
    Invalid option name -alt_config

    Could this msg be cased because the upgrade above was not fully finished since i was not able to run pdjrteupg.bat command?

    Regards,
    Irina Chvets
    As the "-alt_config" was introduced with fixpack 3, it might be possible that the upgrade of the TAM JRTE did not work.

    What size does your PD.jar have in the Policy Director directory, and in the WAS directory?
    From my system, the PD.jar for 6.1.1.6 (fixpack 6) needs to be 1.333.605.

    C:\Program Files (x86)\Tivoli\Policy Director\java\export\pdjrte>dir
    Volume in drive C has no label.
    Volume Serial Number is 2E59-CF4F

    Directory of C:\Program Files (x86)\Tivoli\Policy Director\java\export\pdjrte

    04/02/2013 11:48 <DIR> .
    04/02/2013 11:48 <DIR> ..
    29/08/2012 10:19 1.333.605 PD.jar
    1 File(s) 1.333.605 bytes
    2 Dir(s) 15.244.091.392 bytes free

    Does that PD.jar have the same size on the WAS directory? C:\IBM\WebSphere\AppServer\tivoli\tam\PD.jar
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-04T13:28:32Z  
    As the "-alt_config" was introduced with fixpack 3, it might be possible that the upgrade of the TAM JRTE did not work.

    What size does your PD.jar have in the Policy Director directory, and in the WAS directory?
    From my system, the PD.jar for 6.1.1.6 (fixpack 6) needs to be 1.333.605.

    C:\Program Files (x86)\Tivoli\Policy Director\java\export\pdjrte>dir
    Volume in drive C has no label.
    Volume Serial Number is 2E59-CF4F

    Directory of C:\Program Files (x86)\Tivoli\Policy Director\java\export\pdjrte

    04/02/2013 11:48 <DIR> .
    04/02/2013 11:48 <DIR> ..
    29/08/2012 10:19 1.333.605 PD.jar
    1 File(s) 1.333.605 bytes
    2 Dir(s) 15.244.091.392 bytes free

    Does that PD.jar have the same size on the WAS directory? C:\IBM\WebSphere\AppServer\tivoli\tam\PD.jar
    In C:\IBM\Tivoli\Policy Director\java\export\pdjrte directory the size is the same as yours
    1,333,605

    But in C:\IBM\WebSphere\AppServer\tivoli\tam directory its only 202 bytes. But the strange thing is that the modification date is today, this is probably after I run the installer or attempted to run pdjrtecfg utility.

    Looks like the upgrade did not work. As I mentioned I got a mgs at the end of an upgrade asking to run pdjrteupg.bat -p that did not run successfully with 'java' is not recognized command error.

    Any advise how to proceed now very much appreciated.

    Regards,
    Irina Chvets
  • hans.vandeweghe@be.ibm.com
    33 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-05T09:04:34Z  
    • irina999
    • ‏2013-02-04T13:28:32Z
    In C:\IBM\Tivoli\Policy Director\java\export\pdjrte directory the size is the same as yours
    1,333,605

    But in C:\IBM\WebSphere\AppServer\tivoli\tam directory its only 202 bytes. But the strange thing is that the modification date is today, this is probably after I run the installer or attempted to run pdjrtecfg utility.

    Looks like the upgrade did not work. As I mentioned I got a mgs at the end of an upgrade asking to run pdjrteupg.bat -p that did not run successfully with 'java' is not recognized command error.

    Any advise how to proceed now very much appreciated.

    Regards,
    Irina Chvets
    Hi Irina,

    I suspect the very small PD.jar in C:\IBM\WebSphere\AppServer\tivoli\tam is probably due to the unsuccessful completion of the pdjrteupg or pdjrtecfg.

    I guess something that should be looked at by the Support team via a PMR.

    For now I would attempt to manually copy the PD.jar from C:\IBM\Tivoli\Policy Director\java\export\pdjrte to C:\IBM\WebSphere\AppServer\tivoli\tam, but still run the pdjrtecfg unconfig and config again afterwards.

    Sincerely,
    Hans Vandeweghe
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-02-05T09:27:29Z  
    Hi Irina,

    I suspect the very small PD.jar in C:\IBM\WebSphere\AppServer\tivoli\tam is probably due to the unsuccessful completion of the pdjrteupg or pdjrtecfg.

    I guess something that should be looked at by the Support team via a PMR.

    For now I would attempt to manually copy the PD.jar from C:\IBM\Tivoli\Policy Director\java\export\pdjrte to C:\IBM\WebSphere\AppServer\tivoli\tam, but still run the pdjrtecfg unconfig and config again afterwards.

    Sincerely,
    Hans Vandeweghe
    Thank you Hans,
    I was looking through the forum issues and there was one issue where you advised to set JAVA_HOME and PATH with WAS jre from the sbin location. Even through the env variables were set in Windows but I still run them.

    After that I was able to run pdjrtecfg successfully. This also changed PD.jar file in C:\IBM\WebSphere\AppServer\tivoli\tam location and the the size is now 1,151,220. Not quite the same as in C:\IBM\Tivoli\Policy Director\java\export\pdjrte.

    Then I tried to run pdjrteupg -p from the same location but got this time a different error
    c:\IBM\tivoli\Policy Director\sbin>pdjrteupg.bat -p
    Exception in thread "main" java.lang.NullPointerException
    at java.util.StringTokenizer.<init>(StringTokenizer.java:83)
    at java.util.StringTokenizer.<init>(StringTokenizer.java:61)
    at com.tivoli.pd.jcfg.PDJrteupg.main(PDJrteupg.java:144)

    Also tried to run SvrSslCfg since pdjrtecfg completed successfully based on the command you gave me before

    java -Dpd.cfg.home=WAS_HOME/tivoli/tam com.tivoli.pd.jcfg.SvrSslCfg -action config -admin_id sec_master -admin_pwd sec_master_password -appsvr_id tai-demo -appsvr_pwd tai-demo-pwd -mode remote -port 1234 -host hostname-tai-demo -policysvr tam611:7135:1 -authzsvr tam611:7136:1 -cfg_file "c:\TAI\eaidemo.conf" -
    domain Default -key_file "c:\TAI\eaidemo.kdb" -cfg_action create

    but got this error:

    HPDBF0234E
    Unable to load pd.properties

    Would you mind pls advise how can I log a PMR and what product, components have to be selected. Never logged a PMR before.

    Many thanks for your response.
    Regards,
    Irina Chvets
  • irina999
    irina999
    23 Posts

    Re: TAMTrustAssociationInterceptorPlus failed to initialized error in WAS 8

    ‏2013-09-18T14:53:45Z  
    This reply was deleted by Mathanleo 2015-01-22T05:58:26Z.

    Thank you Mathan for your reply. This was the old post and I was able to resolve this issue with Hans's great help. I was not aware that starting with WAS8.x TAM JRTE is installed on a different directory and I need TAM 6.1.1 FP4 at least.