Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
10 replies Latest Post - ‏2014-04-16T06:01:28Z by borislavbaros
Richard_Hine
Richard_Hine
12 Posts
ACCEPTED ANSWER

Pinned topic Beta3 startup issues

‏2013-12-11T16:54:59Z |

Hello. Am having problems starting the SCAI on a RHEL6 64 bit OS.

The install goes OK ...

...............

smai-apd-asf-support-07.20.00.00-1.el6
smai-apd-apmui-dashboard-resource-07.20.00.00-1.el6
Configuration is starting. It may take several minutes to complete.

All components are successfully installed and ready to use.
Please review the documentation at http://www-01.ibm.com/software/tivoli/products/application-monitoring for more information.
To start using the product, log in to https://<server-name>:9443 and run the "Configuration Wizard" and then review the topics on the "Getting Started" page.

...................

Go to the 'Configuration Wizard' URL, but smadmin / passw0rd gives me 'login failed - check userid and password'

I also get 'Error 404: javax.servlet.ServletException: java.io.FileNotFoundException: SRVE0190E: File not found: /smai' from http://<server-name>/smai

At the end of the /opt/ibm/ccm/logs/server1.log I see ..

...................

(52a896df.1be51d00-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.
[WARNING ] SRVE0190E: File not found: /smai
[WARNING ] SRVE0190E: File not found: /smai
(52a896e9.1c316840-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.

...............

looks like the Derby DB connection is OK as from ....../logs/ccm.trace.log I see

..............

 

2013-12-11 16:08:44.692+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CREATE TABLE KNOWN_ITM_SUBNODES ( TABLE_ID BIGINT NOT NULL PRIMARY KEY, INSTANCE_TABLE_ID BIGINT NOT NULL, NAME VARCHAR(  64 ) , AFFINITY VARCHAR(  64 ) , PRODUCT VARCHAR(  16 ) , VERSION VARCHAR(  16 ) , HOSTINFO VARCHAR(  32 ) , HOSTLOC VARCHAR(  32 ) , HOSTADDR VARCHAR( 256 ) , CONNECTION_STATE VARCHAR(  64 ) NOT NULL, TIME_SUBNODE_MISSING TIMESTAMP , ITM_DUP_OFFLINE TIMESTAMP  ) successful for KNOWN_ITM_SUBNODES.

2013-12-11 16:08:44.740+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CREATE TABLE KNOWN_CHANGE_LOG ( TABLE_ID BIGINT NOT NULL PRIMARY KEY, CHANGE_TIMESTAMP TIMESTAMP NOT NULL WITH DEFAULT CURRENT TIMESTAMP, ACTION VARCHAR(  64 ) NOT NULL, CHANGED_TABLE VARCHAR( 128 ) , CHANGED_TABLE_ID BIGINT , COLUMN_NAME VARCHAR( 128 ) , FROM_VALUE VARCHAR( 256 ) , TO_VALUE VARCHAR( 256 )  ) successful for KNOWN_CHANGE_LOG.

2013-12-11 16:08:44.814+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      TRUNCATE TABLE KNOWN_CHANGE_LOG successful for KNOWN_CHANGE_LOG.

2013-12-11 16:08:44.846+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CREATE INDEX KNOWN_CHANGE_LOG_BY_CHANGE_TIMESTAMP ON KNOWN_CHANGE_LOG ( CHANGE_TIMESTAMP ) post-create command successfully executed for KNOWN_CHANGE_LOG.

2013-12-11 16:08:45.254+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CALL SETLTFORRDBTABLE( 'ELAS_KNOWN_CHANGE_LOG', 'LOCALDERBY','KNOWN_CHANGE_LOG' ) post-create command successfully executed for KNOWN_CHANGE_LOG.

2013-12-11 16:08:45.263+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CREATE INDEX KNOWN_CHANGE_LOG_BY_CHANGE_TIMESTAMP ON KNOWN_CHANGE_LOG ( CHANGE_TIMESTAMP ) post-create command successfully executed for KNOWN_CHANGE_LOG.

2013-12-11 16:08:45.300+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CALL SETLTFORRDBTABLE( 'ELAS_KNOWN_CHANGE_LOG', 'LOCALDERBY','KNOWN_CHANGE_LOG' ) post-create command successfully executed for KNOWN_CHANGE_LOG.

2013-12-11 16:08:45.370+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      TRUNCATE TABLE KNOWN_ITM_SUBNODES successful for KNOWN_ITM_SUBNODES.

2013-12-11 16:08:45.682+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject initialize      CALL SETLTFORRDBTABLE( 'ELAS_KNOWN_ITM_SUBNODES', 'LOCALDERBY','KNOWN_ITM_SUBNODES' ) post-create command successfully executed for KNOWN_ITM_SUBNODES.

2013-12-11 16:08:45.880+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject insert      Inserted KNOWN_ITM_SUBNODES: TABLE_ID=11386778049, INSTANCE_TABLE_ID=0, NAME='DUMMY', AFFINITY=NULL, PRODUCT=NULL, VERSION=NULL, HOSTINFO=NULL, HOSTLOC=NULL, HOSTADDR=NULL, CONNECTION_STATE='00=GOOD', TIME_SUBNODE_MISSING=NULL, ITM_DUP_OFFLINE='1970-01-01 00:00:00.0'

2013-12-11 16:08:45.914+00:00 Thread VTIManagerTask-pool-thread-1: KnownObject delete      Deleted KNOWN_ITM_SUBNODES: TABLE_ID=11386778049, INSTANCE_TABLE_ID=0, NAME='DUMMY', AFFINITY=NULL, PRODUCT=NULL, VERSION=NULL, HOSTINFO=NULL, HOSTLOC=NULL, HOSTADDR=NULL, CONNECTION_STATE='00=GOOD', TIME_SUBNODE_MISSING=NULL, ITM_DUP_OFFLINE='1970-01-01 00:00:00.0'

2013-12-11 16:12:47.931+00:00 Thread ElasticTask: ElasticTask handleMessage      Processing elastic task 65536:192.168.190.143(READY:0:0:VM#0)

..................

In apmui.log I see the authentication problems from my login attempts

.............

[INFO    ] CWWKS4001E: The security token cannot be validated. This can be for the following reasons
1. The security token was generated on another server using different keys.
2. The token configuration or the security keys of the token service which created the token has been changed.
3. The token service which created the token is no longer available.
[INFO    ] CWWKS4001E: The security token cannot be validated. This can be for the following reasons
1. The security token was generated on another server using different keys.
2. The token configuration or the security keys of the token service which created the token has been changed.
3. The token service which created the token is no longer available.
[INFO    ] J2CA8050I: An authentication alias should be used instead of defining a user name and password on com.ibm.ws.jdbc.dataSource-derbyClient/properties.derby.client-0.
[INFO    ] DSRA8203I: Database product name : Apache Derby
[INFO    ] DSRA8204I: Database product version : 10.8.3.1 - (1505077)
[INFO    ] DSRA8205I: JDBC driver name  : Apache Derby Network Client JDBC Driver
[INFO    ] DSRA8206I: JDBC driver version  : 10.8.3.1 - (1505077)
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID scadmin. An invalid user ID or password was specified.
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID smadmin. An invalid user ID or password was specified.
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID smadmin. An invalid user ID or password was specified.
[ERROR   ] Missing value for property search_engines
[ERROR   ] Unable to start blueprint container for bundle com.ibm.tmsr.collectorcontroller.api due to unresolved dependencies [(objectClass=com.ibm.tmsr.nodecontroller.api.NodeController)]
java.util.concurrent.TimeoutException
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID root. An invalid user ID or password was specified.
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID smadmin. An invalid user ID or password was specified.
[INFO    ] CWWKS4001E: The security token cannot be validated. This can be for the following reasons
1. The security token was generated on another server using different keys.
2. The token configuration or the security keys of the token service which created the token has been changed.
3. The token service which created the token is no longer available.
[INFO    ] CWWKS4001E: The security token cannot be validated. This can be for the following reasons
1. The security token was generated on another server using different keys.
2. The token configuration or the security keys of the token service which created the token has been changed.
3. The token service which created the token is no longer available.
[AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID smadmin. An invalid user ID or password was specified.

...................

Can anyone suggest what might be wrong here.

I am NOT using a DNS server, my /etc/hosts is correct and name resolution works by IP address ad by host. I have commented out the ::1 IPV6 entry in /etc/hosts as that has given me trouble in the past. My hostname is domain qualified...... scai.cloud.loca

Many thanks, Richard Hine - UK


 

  • RM03_Chris_Barlock
    RM03_Chris_Barlock
    43 Posts
    ACCEPTED ANSWER

    Re: Beta3 startup issues

    ‏2013-12-11T16:59:41Z  in response to Richard_Hine

    The login URL is now http://<hostname>:8080 with default credentials apmuser/apmpass.

    Chris

    • Richard_Hine
      Richard_Hine
      12 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-11T17:55:18Z  in response to RM03_Chris_Barlock

      Hello Chris.

      Tried this as you suggested, but no luck.

      from apmui.log get ...yes, 3 times, checked, and checked and checked again.

      [AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID apmuser. An invalid user ID or password was specified.
      [AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID apmuser. An invalid user ID or password was specified.
      [AUDIT   ] CWWKS1100A: Authentication did not succeed for user ID apmuser. An invalid user ID or password was specified.

       Is there some way to reset password for apmuser? Or create another account? Thanks, Richard

       

    • Richard_Hine
      Richard_Hine
      12 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-11T17:57:32Z  in response to RM03_Chris_Barlock

      Am also seeing in server1.log ...

      (52a8a736.06146580-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.
      [INFO    ] Problems retrieving a connection -- attempting to recover. java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server localhost on port 6414 with message Connection refused.
      (52a8a740.0632ea00-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.
      [INFO    ] Problems retrieving a connection -- attempting to recover. java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server localhost on port 6414 with message Connection refused.
      (52a8a74a.06516e80-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.
      [INFO    ] Problems retrieving a connection -- attempting to recover. java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server localhost on port 6414 with message Connection refused.
      (52a8a754.066ff300-(null)Thread-44:SCMEventModelMgr,0,"SCMEventModelMgr.run()") Initial msys event data fetch failed. Retry in 10000 milliseconds.
       

      Not sure if this is related or cosmetic.

      Richard

    • Richard_Hine
      Richard_Hine
      12 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-11T18:00:10Z  in response to RM03_Chris_Barlock

      Maybe I have some DB connection issues here? found this script which seems unable to connect. Again not sure if this is significant

      [root@scai ccm]# ./gaianReadyTest.sh
      + export GDBH=/opt/ibm/gaian
      + GDBH=/opt/ibm/gaian
      + export JAVA_HOME=/opt/ibm/java-x86_64-70/jre
      + JAVA_HOME=/opt/ibm/java-x86_64-70/jre
      + ITERATIONS=0
      + ITER_LIMIT=30
      + SELECT='VALUES GDBRUNSTATUS()'
      + sleep 7
      + '[' 0 -lt 30 ']'
      ++ /opt/ibm/gaian/queryDerby.sh -raw 'VALUES GDBRUNSTATUS()'
      + RC='Unable to process arguments: [-raw, VALUES GDBRUNSTATUS()], cause: com.ibm.gaiandb.tools.SQLRunner$SQLRunnerException: java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server localhost on port 6414 with message Connection refused.'
      + '[' xUnable to process arguments: '[-raw,' VALUES 'GDBRUNSTATUS()],' cause: 'com.ibm.gaiandb.tools.SQLRunner$SQLRunnerException:' java.sql.SQLNonTransientConnectionException: java.net.ConnectException : Error connecting to server localhost on port 6414 with message Connection refused. = xRUN_STATUS_ON ']'
      ./gaianReadyTest.sh: line 24: [: too many arguments
      ++ expr 0 + 1
      + ITERATIONS=1
      + sleep 2
       

    • Richard_Hine
      Richard_Hine
      12 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-11T18:05:18Z  in response to RM03_Chris_Barlock

      gaindb.log gives me ....

      2013-12-11 16:07:31.401~851657411 GaianNode -------------> Starting Derby Network Server, host mask 0.0.0.0, port 6414

      Wed Dec 11 16:07:36 GMT 2013 : Could not connect to Derby Network Server on host 0.0.0.0, port 6414: Connection refused
       

      [root@scai gaian]# netstat -an|grep -i 6414
      tcp        1      0 ::ffff:127.0.0.1:45777      ::ffff:127.0.0.1:6414       CLOSE_WAIT
      tcp        1      0 ::ffff:127.0.0.1:44900      ::ffff:127.0.0.1:6414       CLOSE_WAIT
      tcp        1      0 ::ffff:127.0.0.1:44978      ::ffff:127.0.0.1:6414       CLOSE_WAIT
      tcp        1      0 ::ffff:127.0.0.1:45019      ::ffff:127.0.0.1:6414       CLOSE_WAIT
      tcp        1      0 ::ffff:127.0.0.1:45676      ::ffff:127.0.0.1:6414       CLOSE_WAIT
      [root@scai gaian]#
       

    • Richard_Hine
      Richard_Hine
      12 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-12T18:17:40Z  in response to RM03_Chris_Barlock

      OK, have now installed BETA3 and the fabric node now works OK.

      My bad, hostname resolution was the problem, so check DNS and /etc/hosts and make sure it is consistent before you do the installation.

      Many thanks to Chris for his support.

      Richard

  • RM03_Chris_Barlock
    RM03_Chris_Barlock
    43 Posts
    ACCEPTED ANSWER

    Re: Beta3 startup issues

    ‏2013-12-11T18:15:58Z  in response to Richard_Hine

    I'm going to grab beta 3 and install it...

    Chris

    • RM03_Chris_Barlock
      RM03_Chris_Barlock
      43 Posts
      ACCEPTED ANSWER

      Re: Beta3 startup issues

      ‏2013-12-11T19:39:28Z  in response to RM03_Chris_Barlock

      Talked with Richard offline.  He is going to try the 1.2 GA build (which is supposed to be posted to SMC by Friday).

      Chris

  • Richard_Hine
    Richard_Hine
    12 Posts
    ACCEPTED ANSWER

    Re: Beta3 startup issues

    ‏2013-12-12T18:19:52Z  in response to Richard_Hine

    I used apmadmin / apmpass as the default credentials and connected to the fabric node via http://<hostname>:8080

    Richard

  • borislavbaros
    borislavbaros
    3 Posts
    ACCEPTED ANSWER

    Re: Beta3 startup issues

    ‏2014-04-16T06:01:28Z  in response to Richard_Hine

    When you see the starting up page, stop the Spiceworks service and restart it. That should clear it up, it's worked for me many times.

    computer products online outlets

    Updated on 2014-04-16T06:02:06Z at 2014-04-16T06:02:06Z by borislavbaros