High Severity

Security Bulletin: Multiple vulnerabilities in Node.js affect IBM Rational Application Developer for WebSphere Software included in Rational Developer for i

Share this post:

Vulnerabilities detected in Node.js versions before v14.16.2 that affect the Cordova platform packaged with Rational Developer for i Software.

CVE(s): CVE-2021-3712, CVE-2021-37713, CVE-2021-39134, CVE-2021-37712, CVE-2021-39135

Affected product(s) and affected version(s):

Affected Product(s) Version(s)
Rational Developer for i (RDi) RPG and COBOL + Modernization Tools, Java Edition All

Refer to the following reference URLs for remediation and additional vulnerability details:  
Source Bulletin: https://www.ibm.com/support/pages/node/6525674
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/208073
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/208451
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/208462
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/208450
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/208464

More stories

Security Bulletin: Multiple vulnerabilities in Node.js affect IBM Event Streams

September 30, 2022 | High Severity

There are a number of vulnerabilities in Node.js that is used by IBM Event Streams. ...read more


Security Bulletin: The IBM® Engineering Requirements Management DOORS/DWA fixes for Log4j vulnerabilities CVE-2021-4104

September 30, 2022 | High Severity

Apache Log4j could allow a remote attacker to execute arbitrary code on the system, caused by the deserialization of untrusted data when the attacker has write access to the Log4j configuration. The IBM® Engineering Requirements Management DOORS/DWA product versions 9.6.1.x, 9.7.0.x, 9.7.1.x and 9.7.2.x are vulnerable to this attack, it has been addressed in this bulletin. ...read more


Security Bulletin: Multiple Vulnerabilities in Rational Change Fix Pack 04 for 5.3.2

September 30, 2022 | High Severity

Vulnerabilities in the Jetty 9.4.42 and earlier component shipped with Rational Change may affect the security of the product. ...read more