Critical Severity

Security Bulletin: Multiple vulnerabilities in Apache Log4j affects some features of IBM® Db2® (CVE-2021-45046, CVE-2021-45105)

Share this post:

Apache Log4j open source library used by IBM® Db2® is affected by multiple vulnerabilities that could allow a remote attacker to execute arbitrary code on the system or cause a denial of service. This library is used by the Db2 Federation feature. The fix for the vulnerability is to update the Apache Log4j library to 2.17.0. Please see CVE-2021-4104 for bulletin relating to Log4j V1. Please see CVE-2021-44832 and CVE-2021-44228 for bulletins relating to Log4j V2.

CVE(s): CVE-2021-45105, CVE-2021-45046

Affected product(s) and affected version(s):

Fix pack levels of IBM Db2 V11.5 for all editions on all platforms are affected only if the following features are configured:

Federation:  

  •   DVM JDBC wrapper driver,
  •   NoSQL wrapper driver (for Hadoop),
  •   Blockchain wrapper driver (for Hyperledger Fabric, Linux 64-bit, x86-64 only)

 

IBM Db2 V9.7, V10.1, V10.5 and V11.1 are not affected.  Please note that log4j v1.x was removed in a previous build, and customers are strongly recommended to apply those fixes if you are on an older version of Db2.  See Security Bulletin for details.

 

To determine if Federation is enabled, issue the following:

       db2 get dbm cfg | grep FEDERATED

If a value of NO is returned, you are not vulnerable.

 

You can determine if you are using one of the affected wrappers by performing:

To determine if the DVM JDBC wrapper is in use, issue the following statement:

        db2 "select servername from syscat.serveroptions where option = 'DRIVER_CLASS' and setting = 'com.rs.jdbc.dv.DvDriver'"

        If a servername is returned, then you are using the DVM JDBC wrapper via the DvDriver class.

To determine if the NoSQL hadoop wrapper is in use, issue the following statement:

       db2 "select * from syscat.servers where servertype = 'HDFSPARQUET'" 

       If 1 or more rows are returned, then NoSQL hadoop wrapper is in use.

 

To determine if the NoSQL Blockchain wrapper is in use, issue the following statement:

       db2 "select * from syscat.serveroptions where option='PEER_URL'"

       If 1 or more rows are returned, then NoSQL Blockchain wrapper is in use.

Refer to the following reference URLs for remediation and additional vulnerability details:  
Source Bulletin: https://www.ibm.com/support/pages/node/6528672
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/215647
X-Force Database: https://exchange.xforce.ibmcloud.com/vulnerabilities/215195

More stories

Security Bulletin: Multiple vulnerabilities in Curl affect PowerSC

September 23, 2022 | Critical Severity

There are multiple vulnerabilities in Curl that affect PowerSC. ...read more


Security Bulletin: A security vulnerability has been identified in Postgresql shipped with IBM Tivoli Netcool Impact (CVE-2022-26520, CVE-2022-21724, 220313)

September 21, 2022 | Critical Severity

Postgresql is shipped with IBM Tivoli Netcool Impact. Information about a security vulnerability affecting Postgresql has been published in a security bulletin. ...read more


Security Bulletin: Due to use of Apache Commons, IBM Cloud PAK for Watson AI Ops is vulnerable to remote code execution (CVE-2022-33980)

September 19, 2022 | Critical Severity

Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default. [CVE-2022-33980] ...read more