IBM Support

Controller cannot connect to Oracle database, caused by Oracle bug in their client software

Troubleshooting


Problem

Customer is creating new Controller application server. When testing connections to the Oracle database server, error messages appear. However, other applications (e.g. SQL Plus) can successfully connect.

Symptom

Different errors appear when using different parts of the Controller software:

(1) Using 'Controller Configuration' (ControllerConf.EXE):

    IBM Cognos Controller Configuration
    Connection failed.
    [OK]
(2) Using the 'main' Database Conversion Utility (launched from Controller Configuration
    ** ERROR: java.sql.SQLException: Io exception: Unknown host specified

(3) Using the old 'legacy' Database Conversion Utility (DbConv.EXE)
    DbConv
    ORA-12154: TNS:could not resolve the connect identifier specified
    [OK]

Cause

There are several possible causes for similar error messages

  • TIP: For more examples, see separate IBM Technotes #1587251 & 1580229 .

This IBM Technote specifically relates to the scenario where the problem is caused by a third-party (non-IBM) bug (reference 3807408) in Oracle's client product.
  • This is only triggered when Controller is installed in path that contains a parenthesis (e.g. "C:\Program Files (x86)\...".

Environment

Controller software has been installed in a folder name which contains brackets (e.g. "C:\Program Files (x86)\...)

  • Typically this is most likely to be Windows 64-bit.

Diagnosing The Problem

Successful applications (e.g. SQL Plus) are installed inside folders that do not contain a bracket () symbol. Therefore, to check that you are indeed suffering from this Oracle bug, perform the following steps:

  1. Take a copy of the folder C:\Program Files (x86)\ibm\cognos\c10\legacy
  2. Paste this folder into the root of the C:\ drive (i.e. creating a new folder C:\legacy)
  3. Run the legacy DbConv.exe from this folder (i.e. launch C:\legacy\dbconv.exe).
  4. Does this successfully connect to the database? If "yes" then you know you are suffering from the Oracle bug.

Resolving The Problem

Upgrade/patch Oracle client software (located on the Cognos application server) to a version which contains the fix for Bug 3807408.

TIP:

  • For more details on the Oracle bug, see separate IBM Technote #1370380
  • For more details on best practices for installing the Oracle 10G or 11G client on the Controller application server, see Cognos Proven Practice documents.

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Document Information

Modified date:
15 June 2018

UID

swg21595127