Troubleshooting
Problem
Administrator logs onto Controller application server, and launches "Controller Configuration". Administrator opens "Database Connections" and chooses database. Administrator clicks green 'play' button to launch "Database Conversion Utility", then connects to Controller database. An error message appears.
Symptom
** ERROR: java.sql.SQLException: Io exception: Unknown host specified
Cause
There are several possible causes for the "Io exception: Unknown host specified" error:
- Scenario #1 - (most likely for Controller 10.1.1 and earlier) DbConv.exe file incorrectly running as 64-bit, due to code production problem (APAR PM62537) with Controller 10.1.1 and earlier.
- Scenario #2 - (Controller 10.1.1 and earlier) DbConv.exe file correctly running as 32-bit, but the application server incorrectly has the Oracle 64-bit client installed.
- For more information, see separate IBM Technote #1572761.
- Scenario #3 - Third-party (Oracle) bug in their Oracle client software.
- For more information, see separate IBM Technote #1595127.
- Scenario #4 - (Controller 10.2 and later) Application server correctly has the Oracle 64-bit client installed, but DbConv.exe requires TNS_ADMIN variable to find it.
Environment
Controller application server installed on 64-bit version of Windows (e.g. Windows 2008 R2).
Resolving The Problem
Scenario #1
Fix:
Upgrade to Controller 10.2 or later.
- TIP: To find out when this version is released, subscribe to APAR PM62537.
Workaround:
Create a System Variable "TNS_ADMIN" on the Controller application server.
- TIP: For steps, see section 'Scenario #4' later in this Technote.
Scenario #2
See separate IBM Technote #1572761.
Scenario #3
See separate IBM Technote #1595127
Scenario #4
Create a System Variable "TNS_ADMIN" on the Controller application server.
Steps:
1. Create a new Windows "System Environment Variable" on the Controller application server, called "TNS_ADMIN"
2. Assign it a value of the path to the directory where the tnsadmin.ora file is located.
- For example: C:\app\Administrator\product\11.2.0\client_1\network\admin
3. Afterwards, reboot the Controller application server to ensure that the change is registered.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21587251