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** Troubleshooting ** "Connection failed" when click "Test" using "Database Connections" inside "Controller Configuration"

Troubleshooting


Problem

I.T. Administrator launches "Controller Configuration" and opens section "Database Connections". Administrator highlights relevant connection (e.g. "Default") and clicks 'test' icon (green tick button). User receives error

Symptom

IBM Cognos Controller Configuration
Connection failed.
[OK]

Cause

There are many potential causes of this error message:

  • Scenario #1 - SQL login's password has expired
    • See separate IBM Technote #1347333.
  • Scenario #2 - Microsoft SQL server's "SQL Browser" service not running
    • See separate IBM Technote #1411642.
  • Scenario #3 - Customer using DB2, but has configured incorrectly
    • For example, DB2 server is configured to not allow TCP/IP connections, or incorrect settings saved inside "Database Connections"
    • See separate IBM Technote #1578244.
  • Scenario #4 - Controller application server based on 64-bit, but customer has (incorrectly) installed 64-bit database client (e.g. 64-bit Oracle client) on application server.
  • Scenario #5 - Third-party (Oracle) bug in their Oracle client software.
    • See separate IBM Technote #1595127.

Resolving The Problem

Scenario #4
Uninstall 64-bit database client (e.g. Oracle 64-bit client) from Controller application server, and install 32-bit database client software (e.g. Oracle 11G R2 32-bit client "win32_11gR2_client.zip").

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;8.4;8.3;10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21580229