IBM Support

Installing your Optim™ solution in Windows® Vista and succeeding Windows platforms

Troubleshooting


Problem

Because of changes implemented in Windows Vista and subsequent versions of Windows, the installation of your Optim solution requires special handling.

Symptom

When beginning to install or upgrade your Optim solution on a Windows platform, you are asked for permission to run setup or are asked for full Windows Administrator credentials. If your Optim solution has been installed using Windows Administrator credentials, the same credentials are required to access or run your Optim solution; a user account in the Windows Administrator group or a domain equivalent cannot access or run the Optim solution.

Cause

New features in Windows Kernel Version 6.0 and subsequent versions restrict the installation of Optim so that it can only be installed under full Windows Administrator authority.

Environment

Windows Vista and subsequent versions

Resolving The Problem

First, install your Optim solution in the Windows platform:

  1. Install your Optim solution under the Administrator account defined during the installation of your Windows platform or a user account in the Administrator Group (the installation account).
  2. Install your Optim solution in a directory other than 'Program Files'.
  3. Complete the installation.
  4. After installing your Optim solution, choose the appropriate tab below for further directions.



tabs for single user, multiple user, and Optim server installations


If installing for a single user account.

If installing an Optim workstation for a single user (the Optim user account), remain logged on under the the installation account and complete the following steps.

  1. Ensure that the Optim user account or group to which it belongs has Full Control permission to the BIN directory and all subordinate directories and files.
  2. Copy the registry for the current user account to the Optim user account.
  3. Using REGEDIT:

    1. Using Start > Run, type REGEDIT to open the Registry Editor.
    2. In the Registry Editor, expand HKEY_CURRENT_USER.
    3. Expand Software, right-click Princeton Softech, and click Export.
    4. Using the default .reg file type, export HKEY_CURRENT_USER\Software\Princeton Softech to a directory accessible to the Optim user.

    Using the REG utility:

    1. Open a command prompt.
    2. Run the command:

      REG export "HKCU\Software\Princeton Softech" filename.reg.

  4. Save shortcuts in the Start Menu by selecting Start > All Programs.
    1. Right-click "IBM Optim" and drag to the directory for the exported registry file.
    2. Select Copy to create a directory named IBM Optim that contains the contents of the IBM Optim Start Menu.
  5. Merge the registry and shortcuts into the Optim user account:
    1. Log on as the Optim user
    2. From Windows Explorer, open the directory for the exported registry file.
    3. Right-click the name of the exported registry file and select Merge.
    4. To open the directory containing Start Menu entries for the Optim user, click Start, right-click All Programs, and click Open.
    5. Drag the IBM Optim directory to Start > All Programs.
  6. To create desktop icons, drag and copy them from Start > All Programs > IBM Optim.
  7. Open the Configuration program and Configure the First Workstation.

[{"Product":{"code":"SSMLQ4","label":"IBM InfoSphere Optim Test Data Management Solution"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Solution for Data Growth- Data Privacy- and Test Data Management","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;8.1;7.3.1;7.3;7.2.2;7.2.1;7.2.0;7.2;7.1.2;11.3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
08 July 2021

UID

swg21439335