IBM Support

Installing your Optim™ solution in Windows® Vista and succeeding Windows platforms

Troubleshooting


Problem

Because of changes implemented in Windows Vista and subsequent versions of Windows, the installation of your Optim solution requires special handling.

Symptom

When beginning to install or upgrade your Optim solution on a Windows platform, you are asked for permission to run setup or are asked for full Windows Administrator credentials. If your Optim solution has been installed using Windows Administrator credentials, the same credentials are required to access or run your Optim solution; a user account in the Windows Administrator group or a domain equivalent cannot access or run the Optim solution.

Cause

New features in Windows Kernel Version 6.0 and subsequent versions restrict the installation of Optim so that it can only be installed under full Windows Administrator authority.

Environment

Windows Vista and subsequent versions of Windows

Resolving The Problem

First, install your Optim solution in the Windows platform:

  1. Install your Optim solution under the Administrator account defined during the installation of your Windows platform or a user account in the Administrator Group.
  2. Install your Optim solution in a directory other than 'Program Files'.
  3. Complete the installation.
  4. After installing your Optim solution, choose the appropriate tab below for further directions.



tabs for single user, multiple user, and Optim server installations


If installing for multiple user accounts that share settings.

If installing an Optim workstation for multiple users (the Optim user accounts), so that all users share things such as Optim server and DB Alias log on credentials, data directories, and personal options for the use of Optim, remain logged on under the user account used to install your Optim solution and complete the following steps.

  1. Install as described, choosing the option to Install this application for Anyone who uses this computer (all users).
  2. Ensure that the Optim user accounts or group to which they belong is in the Windows Administrator group.
  3. Using Windows Explorer, open the BIN folder in the installation directory for your Optim solution and locate the following files:
    • PR0CMND.exe
    • PR0CNFG.exe
    • PR0SMON.exe
    • PR0ASAP.exe
    • PR0TOOL.exe
  4. For each file:
    1. Right-click the file name and select Properties.
    2. Select the Compatibility tab.
    3. Click Change settings for all users.
    4. Select the Run this program as an administrator check box.
    5. Click OK twice.
  5. Open the Configuration program and Configure the First Workstation.

[{"Product":{"code":"SSMLQ4","label":"IBM InfoSphere Optim Test Data Management Solution"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Solution for Data Growth- Data Privacy- and Test Data Management","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.1;8.1;7.3.1;7.3;7.2.2;7.2.1;7.2.0;7.2;7.1.2;11.3.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
08 July 2021

UID

swg21439195