Troubleshooting
Problem
Attempt to unmount a file system fails with errors such as:
umount: 0506-349 Cannot unmount /dev/lvname: The requested resource is busy
umount: error unmounting /dev/lvname: Device busy
Cause
- Open files in file system
- The file system contains a library that is loaded
- File system contains the mount point of a nested file system
- The file system or a subdirectory is exported by NFS
- The file system or directory is the root node or the public node of the NFSV4 tree
- The file system is used for audit logs
# fuser -dV /mountpoint
Resolution:
- Check any processes that are listed by the above fuser commands & close any open files gracefully where possible
- If processes have their current directory in the file system, change their current directory. (for example, shell users can cd to another directory)
- If necessary consider killing processes that cannot be handled gracefully. fuser -ck /mountpoint can be used to kill all processes using the file system.
- It is always good practice to attempt 'kill <processid>' first, and 'kill -9 <processid>' only as a last resort. kill -9 will prevent processes from doing any cleanup that they may be designed to do
- Use caution when using fuser -ck. The -c flag selects processes accessing the file system containing /mountpoint. If there is no file system mounted at /mountpoint, it kills processes in the parent file system which may negatively impact the system.
Resolution: Run 'slibclean' to unload unused libraries.
Diagnosis: Check the output of the df or mount command
Resolution: If the file system or a subdirectory of the file system is exported, understand the impact of making it unavailable to the NFS clients. Then unexport it using:
# exportfs -u /directory
5. The file system or directory is the root node or the public node of the NFSV4 tree
Diagnosis: use 'nfsd -getnodes' to check the version 4 nodes. /nfspublic will be busy in this example:
# nfsd -getnodes
#root:public
/:/nfspublic
6. The file system contains active audit logs
Diagnosis: Use the 'audit query' command to check if auditing is enabled. Check the location of the audit files in /etc/security/audit/config.
Resolving The Problem
| SUPPORT |
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If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract. 1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue. 2. Capture any logs or data relevant to the situation. 3. Contact IBM to open a case: -For electronic support, see the IBM Support Community: 4. Provide a clear, concise description of the issue. - For more information, see: Working with IBM AIX Support: Describing the problem. 5. If the system is accessible, collect a system snap, and upload all of the details and data for your case. - For more information, see: Working with IBM AIX Support: Collecting snap data |
Related Information
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Document Information
Modified date:
07 July 2022
UID
ibm10879213