Troubleshooting
Problem
After clicking on the "Run Test" button to initiate playback in the "UI Test" perspective of IBM DevOps Test UI (formerly IBM Rational Functional Tester), the user encounters a blocking pop-up with the following error message.
Error message:
Test run aborted due to error.
io.github.bonigarcia.wdm.config.WebDriverManagerException: io.github.bonigarcia.wdm.config.WebDriverManagerException: Error HTTP 403 executing https://msedgedriver.azureedge.net/125.0.2526.0/edgedriver_win64.zip
at
io.github.bonigarcia.wdm.WebDriverManager.handleException(WebDriverManager.java:1421)
at
io.github.bonigarcia.wdm.WebDriverManager.manage(WebDriverManager.java:1190)
at
io.github.bonigarcia.wdm.WebDriverManager.fallback(WebDriverManager.java:1437)....
The error trace indicates a failure in downloading the Edge WebDriver using "WebDriverManager". Additionally, the browser selection in the playback dialog is unresponsive, preventing the user from switching to a different browser.
Cause
IBM DevOps Test UI uses the "WebDriverManager" library to automatically download the compatible "WebDriver" for the installed browser. In this scenario, "WebDriverManager" fails with "HTTP 403 Forbidden" error, which typically indicates:
- Restricted network access.
- Missing proxy configuration.
- Lack of admin rights to download files.
Resolving The Problem
Refer the below steps to resolve the issue:
- Close IBM DevOps Test UI.
- Open the Microsoft Edge browser and then click on "Settings" --> "About Microsoft Edge" to check the version of the Edge browser.
- Click here to visit the official Microsoft Edge WebDriver download page.
- After launching the link from the previous step, navigate to the "Stable Channel" to find the correct Edge WebDriver that matches your browser's version. If your browser version isn't listed, then select a compatible WebDriver from this link.
- Download the correct architecture ZIP file (e.g., "x64") matching your browser version.
- Extract the ZIP file and locate the "msedgedriver.exe".
- Copy the "msedgedriver.exe" file to this path : "C:\ProgramData\IBM\DTUI\configuration".
- Reopen the IBM DevOps Test UI and re-run your test.
Similarly, follow the procedures mentioned in the article from this link to download the compatible Google Chrome driver manually.
Document Location
Worldwide
Was this topic helpful?
Document Information
Modified date:
05 January 2026
UID
ibm17255817