IBM Support

perl XML::LibXML::SAX errors

Question & Answer


Question

Why do I get libxml errors in my perl application?

# perl -e 'use XML::Simple; use Data::Dumper; ::Simple::PREFERRED_PARSER = XML::LibXML::SAX ;\
  = q{<?xml version=1.0 encoding=ISO-8859-1?><opt><action>actiontest</action><params><foo>bar</foo></params></opt>};\
print Dumper(XMLin(, keyattr => [], suppressempty => undef));'

Can't locate object method "new" via package "XML::LibXML::SAX" at /tmp/perl/perl510/usr/opt/perl5/lib/site_perl/5.10.1/XML/SAX/ParserFactory.pm line 43.
 


 

Cause

If you use LIBPATH=/opt/freeware/lib, and have a libxml2 package installed, there might be conflicts with the default /usr/ccs/lib/libxml2.a from bos.rte.control, which perl.rte  is built and tested against.

Answer

If you are using default perl.rte, use default LIBPATH.
# unset LIBPATH
TIP: See  AIX Perl Updates and Support for perl.rte  which explains (in summary):
  • The perl shipped with AIX in the perl.rte fileset is intended for sole use by the operating system. The AIX perl.rte will install in /usr/opt/perlN/ (where N is the version number) and create the symlink /usr/bin/perl. Operating system components rely on the specific level of perl shipped with the release. 
  • AIX does not migrate modules to this new version, since the modules are not tested by AIX.  They are usually left on the system in a directory left over from the previous version.
  •  Users are always encouraged to use the latest perl RPM version available on the AIX Toolbox for Linux to ensure they are using the latest versions tested on AIX. Since this perl version will install to a different location, this also gives the user control over any perl updates which could impact their environment.
SUPPORT

A) For all questions or issues with Toolbox packages, the support is handled by the AIX Open Source Team in the forum:

The AIX Open Source Team provides support through the forum, only. They answer questions, if possible, but they don't own the packages, or formally support them. For true expertise in usage of each package, users should consult the community for each respective package.  For Perl communities, see the Perl Community page (Perl Monks is a popular community for Perl usage discussions).

** Cases opened to address Toolbox problems will be canceled and users will be referred to the Open Source Forum.
 
If you experience technical issues accessing the AIX Open Source community or forum, refer to the footer of the IBM Community forum page.
There is email, and "Contact Us" information for community support

B) If there is a problem with installing or updating perl.rte, or loading a perl.rte executable file, you can open an AIX Case (See C ) for assistance.

Examples of perl.rte issues supported through AIX Support:
- Errors updating or migrating the perl.rte fileset
- Commands from the perl.rte fileset do not run, or core dump

Example of a perl.rte loading issue:

# perl -v
exec(): 0509-036 Cannot load program perl because of the following errors:
        0509-150   Dependent module libperl.a(libperl.o) could not be loaded.
        0509-022 Cannot load module libperl.a(libperl.o).
        0509-026 System error: A file or directory in the path name does not exist.

 
This example would be handled through an IBM AIX Support case, and the support team would help resolve the missing modules.
To learn what is provided and supported by the perl.rte fileset:

#  lslpp -f perl.rte

C) Opening an AIX Support Case

If additional assistance is required due to issues with rpm.rte fileset (see preceding B section), use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  The technical support specialist assigned to your case will confirm that you have completed these steps.

a.  Document or provide screen captures of all symptoms, errors, and messages that might have occurred

b.  Capture any logs or data relevant to the situation

c.  Contact IBM to open a case:

   -For electronic support, visit the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, visit the web page:
      https://www.ibm.com/planetwide/

d.  Provide a good description of your issue and reference this technote

e.  Upload all of the details and data to your case

   -You can attach files to your case in the IBM Support Community
   -Or upload to the IBM Enhanced Customer Data Repository
      https://www.secure.ecurep.ibm.com/app/upload_sf

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Document Information

Modified date:
09 December 2020

UID

ibm16380394