IBM Support

How to Rollback the IBM Installation Manager to a Previous Version on the IBM i OS

Troubleshooting


Problem

The IBM Installation Manager product has been upgraded to a new version that is no longer compatible with or will no longer function on the IBM i OS.  This document will discuss a scenario where the Installation Manager product has been upgraded to v1.10.x, but now no longer functions on IBM i 7.6 OS and needs to be rolled back to v1.9.x to be compatible.  If you are unsure if this scenario matches your issue, please contact IBM Support to verify whether a rollback is required.  The IBM Installation Manager v1.10.x on IBM i product requires the 5770JV1 Option 19 - Java 11 64 bit LPP and is only supported on IBM i 7.4 and 7.5 OS.

Symptom

The IBM Installation Manager imcl command will fail with Java version not found or another error during software package updates and/or administrative commands.

Cause

Upgrade to IBM Installation Manager v1.10.x.

Environment

IBM i OS (specifically 7.6)
IBM Installation Manager v1.10.x
IBM Java Development Kit 11 64 bit (5770-JV1 Option 19) - not available at IBM i 7.6

Diagnosing The Problem

Check the IBM Installation Manager version.  If v1.10.x, IBM recommends rolling back to the latest version of v1.9.x.
WRKLNK '/QIBM/ProdData/InstallationManager/properties/version/*'
     
Enter Option 5 next to the IBM_Installation_Manager.X.Y.Z.swtag file.

The value for <ProductVersion> is the currently installed version of the IBM Installation Manager product:

<ProductVersion>X.Y.Z</ProductVersion>

Resolving The Problem

If the IBM Installation Manager's current version is 1.10.x, IBM recommends rolling back to the latest 1.9.x version, which requires the IBM i 5770JV1 Option 16 Java 8 32 bit LPP.
The process to rollback your IBM Installation Manager version to a previous version can be completed by following these steps:
  1. Uninstall all software packages currently managed by the IBM Installation Manager product.
  2. Uninstall the current IBM Installation Manager version.
  3. Verify IBM i 5770-JV1 Option 16 and 17 - Java 8 32 & 64 bit LPPs are installed using GO LICPGM Option 10, press F11 twice to see the product option column.
  4. Download and install the latest 1.9.x IBM Installation Manager version.
  5. Download and install your IBM WebSphere Application Server product and any other software packages managed by the IBM Installation Manager.
  6. Restore all user data (including your WebSphere Application Server profiles) before updating to the latest WebSphere fix pack levels.
  7. Download and update your IBM WebSphere Application Server product and any other software packages to the desired fix pack level.
These steps are covered in more detail for the IBM WebSphere Application Server software package in the IBM document:

IBM WebSphere Application Server (WAS) Product Re-installation Process While Preserving Profile & Application Server Data

See related links for individual documents on how to uninstall and reinstall the IBM WebSphere Application server and Installation Manager products on the IBM i OS.

Document Location

Worldwide

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Document Information

Modified date:
07 May 2025

UID

ibm17182557