IBM Support

IBM WebSphere Application Server (WAS) Product Re-installation Process While Preserving Profile & Application Server Data

Troubleshooting


Problem

After a fix pack failure or data restore, WAS Fix Packs might no longer install successfully and/or the incorrect WAS Fix Pack version is displayed.

Cause

A version mismatch between the WAS product and Installation Manager product repository metadata. The WAS Fix Pack is partially installed due to a failure during installation.

Environment

IBM i; IBM WebSphere Application Server (WAS)

Diagnosing The Problem

Unable to successfully update the WAS product to a newer fix pack level.

Resolving The Problem

NOTE: This process assumes the source and target UserData profile installation directories are the same value. The target UserData IFS path cannot be different than the original location specified in the original product installation. The steps provided are to be performed on the same IBM i partition. If you wish to migrate the WAS product to a new IBM i partition, please refer to the document URL, https://www.ibm.com/support/pages/node/646205

Here is the process you will want to follow to preserve your IBM WAS Profile & Application Server data when re-installing the IBM WAS product.

Steps to preserve WAS Profiles during an uninstall/reinstall of the WAS product.
==========================================================
1) Follow steps 1-5 in the "READ FIRST - How to Preserve Your IBM WebSphere Application Server Profiles Before Uninstallation " section in the https://www.ibm.com/support/pages/node/684705 document to back up your WAS Profiles before you uninstall the WAS product.

2) Uninstall the WAS and IM products using the steps outlined in the "How to Uninstall IBM WebSphere Application Server V8.0 and Later" & "How to Uninstall the IBM InstallationManager (Optional)" sections of the https://www.ibm.com/support/pages/node/684705 document.

3) Reinstall the IM and WAS products using the steps outlined in the https://www.ibm.com/support/pages/node/645349 document.  You will want to complete the product installation, but DO NOT install the WAS Fix Pack just yet.  You will need to restore your WAS Profile data BEFORE the WAS Fix Pack is installed to ensure your WAS Profiles get updated with the WAS Fix Pack installation.

4) Restore your WAS Profiles using steps 7 and 8 in the "READ FIRST - How to Preserve Your IBM WebSphere Application Server Profiles Before Uninstallation " section in the https://www.ibm.com/support/pages/node/684705 document.

5) Install the latest WAS Fix Pack using the instructions for your WAS version.
WAS v8.0 and v8.5 = https://www.ibm.com/support/pages/node/645197
WAS v9.0 and later = https://www.ibm.com/support/pages/node/667053

6) Congratulations!  You have successfully re-installed the WAS product while preserving your WAS Profile and Application Server data.

[{"Product":{"code":"SWG60","label":"IBM i"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"WebSphere Application Server","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"Version Independent","Edition":"All Editions;WAS v9.0;WAS v8.5.5;WAS v8.0","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
25 January 2024

UID

nas8N1022237