Troubleshooting
Problem
IBM i Licensed Programs are no longer showing in WRKLICINF even though they are installed on the system.
Symptom
DSPLICPGM option 10, DSPSFWRSC, DSPLICKEY, and CALL QSFWINV show the licensed program but WRKLICINF no longer shows the licensed program.
You may also be receiving message CPI9E75 indicating that the Grace period expires in xx days on xx/xx/xx for a product that does not show up in WRKLICINF.
Cause
PTFs introduced through APAR SE79942 removed the need for licensing for several IBM i products as listed in
IBM i Portfolio Simplification:
R760 (Included in Base) - superseded by SJ04347
IBM i Portfolio Simplification:
R760 (Included in Base) - superseded by SJ04347
R740 SI83647(PTF in Error) - superseded and fixed by SJ05537
R730 SI83646 (PTF in Error) - superseded and fixed by SJ02851
R720 SI83645 (PTF in Error) - superseded and fixed by SJ02850
R710 SI84524 (PTF in Error) - fixed by SI84890
R730 SI83646 (PTF in Error) - superseded and fixed by SJ02851
R720 SI83645 (PTF in Error) - superseded and fixed by SJ02850
R710 SI84524 (PTF in Error) - fixed by SI84890
Products/Options that no longer require license keys after PTF is installed:
• 5770-SS1 Option 18: Media & Storage Extension
• 5770-SS1 Option 36: PSF 1-55 IPM Support
• 5770-SS1 Option 37: PSF 1-100 IPM Support
• 5770-SS1 Option 38: PSF AnySpeed
• 5770-SS1 Option 41: HA Switchable Resource
• 5770-SS1 Option 36: PSF 1-55 IPM Support
• 5770-SS1 Option 37: PSF 1-100 IPM Support
• 5770-SS1 Option 38: PSF AnySpeed
• 5770-SS1 Option 41: HA Switchable Resource
• 5770-SS1 Option 42: HA Journal Performance
• 5761-AP1: Advanced DBCS Printer Support
• 5761-CM1: Communications Utilities
• 5761-CM1: Communications Utilities
• 5722-IP1: InfoPrint Server
• 5770-JS1: Advanced Job Scheduler
• 5770-PT1: Performance Tools
• 5770-QU1: Query for i
• 5770-ST1: Db2 Query Mgr & SQL Dev Kit
• 5770-XW1: IBM i Access Family
• 5770-JS1: Advanced Job Scheduler
• 5770-PT1: Performance Tools
• 5770-QU1: Query for i
• 5770-ST1: Db2 Query Mgr & SQL Dev Kit
• 5770-XW1: IBM i Access Family
Diagnosing The Problem
DSPPTF LICPGM(5770SS1) SELECT(xxxxxx)
where xxxxxx is the PTF number that corresponds to your release.
Select option 1 for General information. If the PTF has a status of Temporarily Applied, Permanently Applied, Superseded, or Damaged, then the licensing has been removed for the products announced.
Resolving The Problem
There is no action needed to resolve the issue of the announced products not being listed in WRKLICINF since this is expected and even with an expiration showing, these products whose licensing is no longer needed, will continue to work.
However, if the original PTFs are applied and do not have their fixing PTFs applied, then it is strongly recommended to apply the fixing PTFs or the latest license management PTFs in order to prevent other licensing issues (See *Note2):
R760 (Included in Base) - superseded by SJ04347
If desired, the RMVLICKEY command can be used to remove the old and unneeded license keys from the repository view, but the PTF is needed to fix the license management issues. Do not RMVLICKEY for any product features that still require a license key.
*Note1: To check for remaining licensed products that will be expiring within so many days, use the SQL QSYS2.LICENSE_INFO :
Example in STRSQL or SQL Manager for checking within 14 days of expiration:
SELECT * FROM QSYS2.LICENSE_INFO WHERE LICENSE_EXPIRATION <= CURRENT DATE + 14 DAYS
*Note2: The original PTFs are marked in error and superseded and fixed by APAR SE80680. The latest fixing PTFs are recommended to fix multiple issues including but not limited to:
- Users with older unsupported code/products (5770XH2, 5770XE1, or version of ACS lower than 1.9.1 that used older licensing verification) to be able to connect their user sessions. ACS users receive MSGLM0017 RC2=0X0003 if they do not have the fixing PTF in SE80680.
- Erroneous licensing messages
- Grace Period messages: If you are still receiving grace period messages such as CPI9E75 and CI9E76 for the products that no longer need licensing, this will not prevent the licensed programs from functioning properly, but the superseded license management PTFs listed in this document will resolve those Grace Period messages as listed in APAR DT407046
- 5770SS1 5052 messages for Processor Group P20 and P30 systems (SE80780)
- QSYSARB ending with MCH3601 f/QLZAALK t/QLZAALK (FI0132520)
- non-Gregorian calendars may have license key expiration date issues (DT418811)
- The License Manager's object directory becomes corrupted and may fail the current operation while rebuilding.(DT437849)
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m3p000000PCSUAA4","label":"Internal LIC and Partitions-\u003ELicenses"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0;7.2.0;7.3.0;7.4.0;7.5.0;and future releases"}]
Was this topic helpful?
Document Information
Modified date:
09 October 2025
UID
ibm17066410