Troubleshooting
Problem
この技術情報では、/store/tmpディレクトリー配下のファイルに対するFileNotFoundExceptionが原因で、変更のデプロイが失敗したとき(特にコンソールの場合)の診断と解決の方法について説明します。
Symptom
変更のデプロイを実行すると、直接エラー状態になります。以下のようなエラーの形跡がqradar.logで見つかります。
127.0.0.1 [tomcat.tomcat] [xxxxxxxx (1030) /console/JSON-RPC/QRadar.scheduleDeployment QRadar.scheduleDeployment] java.io.FileNotFoundException: /store/tmp/status/addhost.txt (Permission denied)
127.0.0.1 [tomcat.tomcat] [xxxxxxxx (5985) /console/JSON-RPC/QRadar.scheduleDeployment QRadar.scheduleDeployment] java.io.FileNotFoundException: /store/tmp/forensics.yar (Permission denied)
Cause
この問題は、/store/tmpフォルダーが/storetmpに対するシンボリック・リンクとなっていないために発生します。また、その権限が/storetmpフォルダーと比較される事からも発生します。
Diagnosing The Problem
コマンドls -lを使用して、シンボリック・リンクが作成されているかどうかを確認します。所有者は、nobody: nobodyとなっている必要があります。ls -l /store/tmpの出力が以下と異なる場合は、「Resolving The Problem」セクションを確認する必要があります。
[root@xxxxx~]# ls -l /store/tmp
lrwxrwxrwx 1 nobody nobody 10 Jan 4 2022 /store/tmp -> /storetmp
Resolving The Problem
問題を解決するため、以下の手順に従ってください
- 以下のコマンドを実行して、新しくシンボリック・リンクを作成します。
# ln -s /storetmp /store/tmp
- /store/tmpと/store/tmp/statusの所有者を変更します。
# chown -h nobody:nobody /store/tmp # chown -h nobody:nobody /store/tmp/status
- /store/tmpがシンボリック・リンクとなっており、所有者がnobodyになっていることを確認します。
# ls -l /store/tmp lrwxrwxrwx 1 nobody nobody 10 Jan 4 2022 /store/tmp -> /storetmp/
- デプロイの変更を実行します。
- 結果
シンボリック・リンクと必要な所有権を割り当てた後、デプロイメントの変更は正常に完了します。
Related Information
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"ARM Category":[{"code":"a8m0z000000cwtNAAQ","label":"Deployment"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
12 May 2024
UID
ibm17040613