IBM Support

Cloud Pak for Security: User cannot authenticate when using an email with an irregular Top-Level Domain (TLD)

Troubleshooting


Problem

Users registered with a valid email address, but an irregular Top-Level Domain (TLD), cannot access the Case Management page or reset their password. An "Invalid email address ADDRESS@URL.COM" error appears in their logs when they attempt to access any resource that requires authentication.

Symptom

This issue can cause several symptoms that effect both LDAP and SAML users:
  • Users cannot access the case management page. When they click it, the page redirects to the CP4S home page.
  • Users cannot change their password.
  • When you try to add a user with an irregular email address, the UI returns a "bad request" message.

Cause

Cloud Pak for Security defines a list of "regular" Top-Level Domains (TLDs) that are supported by default, and "irregular" domains will cause issues.
Important: Some TLDs such as .lan, .internal, .local, and .lab are not supported because they conflict with the Reserved Top-Level DNS Names Standards. For more information see the relevant Request for Comments (RFC) documentation. If you are currently using an unsupported domain and want to change it to a standard supported domain, see this technical note for more information.

Diagnosing The Problem

After you collect the CP4S logs, search your logs for the following error with "ADDRESS@URL.COM" replaced with the email registered to the logged in user:
java.lang.IllegalArgumentException: Invalid email address ADDRESS@URL.COM

Resolving The Problem

Users must configuring LDAP authentication with a valid email address by using the following procedure. If you need additional assistance, contact support.

Document Location

Worldwide

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Document Information

Modified date:
18 May 2023

UID

ibm16982885