Troubleshooting
Problem
When users attempt to open the Cases Management or Orchestration & Automation application, the window redirects to the CP4S home page, so that the apps cannot be opened.
Symptom
Other apps open, but when you click any of the following, the screen redirects to the home page:
- The Case Management App.
- Accessing Case Management from the menu and selecting Cases, My tasks, Analytics, or any of the subpages.
- Orchestration & Automation > customization.
The isc-cases-event-handler pod might fail to start with the following error in the deployment YAML:
pods "isc-casee-event-handler-xxx-" is forbidden: unable to validate against any security context constraint: [spec.containers[0].securityContext.runAsUser: Invalid value: 1001: must be in the ranges: [1000720000, 1000072999]]
Important: While the Case Management app comes with the base CP4S license, Orchestration & Automation functionalities require a license. If your issue is only with accessing Orchestration & Automation features, ensure the proper license is installed.
Cause
A validation issue with the logged in user's email address can cause the apps to fail to open. Email addresses ending in .lan, .internal, .local, and .lab are not supported because they conflict with the Reserved Top-Level DNS Names Standards. For more information, see the relevant Request for Comments (RFC) documentation.
If you need a test email address, you can use one of the addressed reserved for testing purposes such as example.com, example.net, or example.org. In addition, the OpenLDAP default server and domain of @local.io is supported.
Diagnosing The Problem
- isc-demo@local.io
- Connect to the Red Hat OpenShift Platform Server with SSH.
- Use the following command to gather the application logs:
oc logs -lname=isc-cases-application -c cases-application-client-log-tailer -f
Results
Check the cases-application-client-log for the following error:ERROR com.co3.context.Co3ContextRunnable - Exception in runnable java.lang.IllegalArgumentException: Invalid email address user@emailaddressexample.local
If, in the error, user@emailaddressexample.local is the registered email address of the user you were logged in as when you could not access the Case Management app, you are experiencing an invalid email error.
Resolving The Problem
Open your user settings and edit the email attribute to a valid address. For more information on supported and unsupported email servers and domains, see the Cause section. For more information on administering accounts, see the documentation.
Document Location
Worldwide
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Document Information
Modified date:
15 March 2023
UID
ibm16959911