IBM Support

QRadar on Cloud: Data Gateway addition fails due to typo in the token input

Troubleshooting


Problem

The setup script /opt/qradar/bin/setup_qradar_host.py mh_setup interactive -p fails at retrieving the VPN client package with the following error:
"Failed to call VPN client API on host 'console-00xxx.qradar.ibmcloud.com' to retrieve client package: Unexpected failure occurred while processing API request: a bytes-like object is required, not 'str'"
To download the files, the script uses the token to identify the right VPN client packages associated with the Data Gateway to be added, but typographical errors in the token can cause this error. Administrators can use this technical note to identify when a typographical error exists that prevents successfully adding the Data Gateway.

Symptom

The setup script displays the following error:
 (UTC) [INFO] Failed to run command 'mh_setup': Failed to call VPN client API on host 'console-xxxxx.qradar.ibmcloud.com'
 to retrieve client package: Unexpected failure occurred while processing API request: a bytes-like object is required, not 'str'
 (UTC) [INFO] Traceback (most recent call last):
  File "/opt/qradar/lib/python/qradar/command_line.py", line 192, in executeCommand
    self.cmd.execute(self.opts, self.args, self.parser)
  File "/opt/qradar/bin/setup_qradar_host.py", line 412, in setup
    input_obj.proxy_port, input_obj.proxy_username, input_obj.proxy_password)
  File "/opt/qradar/bin/setup_qradar_host.py", line 427, in setupImpl
    downloaded_file = downloadPackageImpl(server, token)
  File "/opt/qradar/bin/setup_qradar_host.py", line 566, in downloadPackageImpl
    callVPNAPI(archive_file, server, token)
  File "/opt/qradar/bin/setup_qradar_host.py", line 1605, in callVPNAPI
    raise SystemException(error_message, exit_val)
qradar.command_line.SystemException: Failed to call VPN client API on host 'console-xxxxx.qradar.ibmcloud.com' to
 retrieve client package: Unexpected failure occurred while processing API request: a bytes-like object is required, not 'str' 

Cause

QRadar® on Cloud (QRoC) Data Gateways (DG) require an exact match between the DG's IP address and the VPN client package. The script verifies that both match by inspecting the token associated with each. When the token has a typographical error or the token is linked to another DG's IP address, the addition fails.

Environment

QRadar® on Cloud Data Gateways

Diagnosing The Problem

The administrator can review the token is correctly typed in the text-user interface and whether the token is associated with the DG's IP address to be added.
Steps
  1. Open the Admin settings, and click QRadar on Cloud Self-Serve.
  2. Click Host Token Management.
  3. Verify the token matches the correct DG's IP address.

    Result
    If the token does not match, take note of all the characters in the token and proceed to Resolving the Problem.

Resolving The Problem

The administrator must ensure the token is correctly typed in the text-user interface and whether the token is associated with the DG's IP address to be added.
Before you start
Follow the steps in the Diagnosing the Problem section to ensure:
  • The token is meant for the correct DG's IP address. If another host token was used, create a new token.
  • You recorded the token for use in the Procedure.
Procedure
  1. Log in to the Data Gateway as the root user.
  2. Run the setup script.
    /opt/qradar/bin/setup_qradar_host.py mh_setup interactive -p
  3. In the token section, input the token.
    Note: The tokens must be all lowercase and include hyphens (-).
    Token Example:
    3cbdeab9-ce42-4736-8654-1ff098d6cd86
    Figure01
  4. Complete the addition process for the Data Gateway. 

    Result
    The Data Gateway can request the VPN files from the Console's IP and continues until the appliance is successfully added to the deployment. If the administrator continues to experience issues, contact QRadar Support for assistance.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSKMKU","label":"IBM QRadar on Cloud"},"ARM Category":[{"code":"a8m0z000000cwtNAAQ","label":"Deployment"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
26 July 2022

UID

ibm16606913