IBM Support

Security Bulletin: IBM i components are vulnerable to data access due to CVE-2022-22481

Security Bulletin


Summary

IBM Navigator for i - heritage version GUI is vulnerable to data access as described in the vulnerability details section. IBM has addressed the vulnerability for IBM Navigator for i - heritage version with a fix as described in the remediation/fixes section.

Vulnerability Details

CVEID:   CVE-2022-22481
DESCRIPTION:   IBM Navigator for i (heritage version) could allow a remote attacker to obtain access to the web interface without valid credentials. By modifying the sign on request, an attacker can gain visibility to the fully qualified domain name of the target system and the navigator tasks page, however they do not gain the ability to perform those tasks on the system or see any specific system data.
CVSS Base score: 3.7
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/225899 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N)

Affected Products and Versions

Affected Product(s)Version(s)
IBM Navigator for i (heritage version only)IBM i 7.4, 7.3, and 7.2 (heritage version)

Remediation/Fixes

It is strongly recommended that IBM Navigator for i - heritage version not be used due to other vulnerabilities as documented in this security bulletin:  https://www.ibm.com/support/pages/node/6539162

The fix documented in that security bulletin disables IBM Navigator for i - heritage version however if there are key features required, heritage Navigator can be enabled and started temporarily at your own risk. 

If starting heritage Navigator, IBM recommends addressing the vulnerability described in this bulletin by applying additional fixes.

This issue can be fixed by applying PTFs to IBM i. The IBM i PTF numbers containing the fix for the CVE:

IBM i Release5770-SS1 PTF NumberPTF Download Link
7.4

SI79557
SI79558

https://www.ibm.com/support/pages/ptf/SI79557

https://www.ibm.com/support/pages/ptf/SI79558

7.3

SI79559
SI79560

https://www.ibm.com/support/pages/ptf/SI79559

https://www.ibm.com/support/pages/ptf/SI79560

7.2

SI79561
SI79562

https://www.ibm.com/support/pages/ptf/SI79561

https://www.ibm.com/support/pages/ptf/SI79562

Statement of direction - IBM intends in the future to remove IBM Navigator for i heritage version by deleting all associated files from the system for IBM i 7.3 & 7.4 releases.

Important note: IBM recommends that all users running unsupported versions of affected products upgrade to supported and fixed version of affected products.

Workarounds and Mitigations

Disable IBM Navigator for i - heritage version

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

The vulnerability was reported to IBM by Mohamed Shaban

Change History

06 May 2022: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY. In addition to other efforts to address potential vulnerabilities, IBM periodically updates the record of components contained in our product offerings. As part of that effort, if IBM identifies previously unidentified packages in a product/service inventory, we address relevant vulnerabilities regardless of CVE date. Inclusion of an older CVEID does not demonstrate that the referenced product has been used by IBM since that date, nor that IBM was aware of a vulnerability as of that date. We are making clients aware of relevant vulnerabilities as we become aware of them. "Affected Products and Versions" referenced in IBM Security Bulletins are intended to be only products and versions that are supported by IBM and have not passed their end-of-support or warranty date. Thus, failure to reference unsupported or extended-support products and versions in this Security Bulletin does not constitute a determination by IBM that they are unaffected by the vulnerability. Reference to one or more unsupported versions in this Security Bulletin shall not create an obligation for IBM to provide fixes for any unsupported or extended-support products or versions.

Document Location

Worldwide

[{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSC5L9","label":"IBM i 7.2"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.2.0","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SSTS2D","label":"IBM i 7.3"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.3.0","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Product":{"code":"SS9QQS","label":"IBM i 7.4"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.4.0","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}},{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.4.0,7.3.0,7.2.0","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
06 May 2022

UID

ibm16583553