IBM Support

Security Bulletin: IBM Security Verify Password Synchronization Plug-in for Windows AD is vulnerable to a denial of service vulnerability (CVE-2022-22323, CVE-2022-22312)

Security Bulletin


Summary

IBM Security Verify Password Synchronization Plug-in for Windows AD released a fix in response to a denial of service vulnerability caused by a heap-based buffer overflow in the Password Synch Plug-in.

Vulnerability Details

CVEID:   CVE-2022-22323
DESCRIPTION:   IBM Security Identity Manager is vulnerable to a denial of service, caused by a heap-based buffer overflow in the Password Synch Plug-in. An authenticated attacker could exploit this vulnerability to cause a denial of service.
CVSS Base score: 5.7
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/218379 for the current score.
CVSS Vector: (CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H)

CVEID:   CVE-2022-22312
DESCRIPTION:   IBM Security Identity Manager is vulnerable to a denial of service, caused by a heap-based buffer overflow in the Password Synch Plug-in. An authenticated attacker could exploit this vulnerability to cause a denial of service.
CVSS Base score: 5.7
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/217369 for the current score.
CVSS Vector: (CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H)

Affected Products and Versions

Affected Product(s) Version(s)
IBM Security Verify Password Synchronization Plug-in for Windows AD 10.x
Password Sync Plug-in for WinAD 64-bit 6.x
Password Sync Plug-in for WinAD 64-bit 7.x

Remediation/Fixes

IBM encourages customers to update their systems promptly.
Product(s) Version(s) Remediation/First Fix
IBM Security Verify Password Synchronization Plug-in for Windows AD 10.x IBM Security Verify Password Synchronization Plug-in for Windows AD  v10.0.4 or higher
Password Sync Plug-in for WinAD 64-bit 7.x IBM Security Verify Password Synchronization Plug-in for Windows AD  v10.0.4 or higher
Password Sync Plug-in for WinAD 64-bit 6.x IBM Security Verify Password Synchronization Plug-in for Windows AD  v10.0.4 or higher

To download IBM Security Verify Password Synchronization Plug-in for Windows AD v10.0.4 or higher, sign into IBM Passport Advantage Online (PAO) website. Note, you must be an authorized user from your company to sign in.
Enter "IBM Security Verify Password Synchronization Plug-in for Windows AD" text string for search by Product name.

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

The vulnerability was reported to IBM by Krzysztof Andrusiak (STM Cyber).

Change History

22 Apr 2022: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY. In addition to other efforts to address potential vulnerabilities, IBM periodically updates the record of components contained in our product offerings. As part of that effort, if IBM identifies previously unidentified packages in a product/service inventory, we address relevant vulnerabilities regardless of CVE date. Inclusion of an older CVEID does not demonstrate that the referenced product has been used by IBM since that date, nor that IBM was aware of a vulnerability as of that date. We are making clients aware of relevant vulnerabilities as we become aware of them. "Affected Products and Versions" referenced in IBM Security Bulletins are intended to be only products and versions that are supported by IBM and have not passed their end-of-support or warranty date. Thus, failure to reference unsupported or extended-support products and versions in this Security Bulletin does not constitute a determination by IBM that they are unaffected by the vulnerability. Reference to one or more unsupported versions in this Security Bulletin shall not create an obligation for IBM to provide fixes for any unsupported or extended-support products or versions.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSBM27","label":"IBM Security Verify Governance"},"ARM Category":[{"code":"a8m0z0000001hhBAAQ","label":"Identity Manager-\u003EAdapters \/ Services"}],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
22 April 2022

UID

ibm16574671