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** Troubleshooting ** Message "Please wait, loading the report..." constantly (does not disappear) when running Standard Reports

Troubleshooting


Problem

User launches a standard report (also known as a 'system report'). The expected 'browser' window opens. As expected, after a short time a message appears. However, this message does not disappear. In other words, the expected web session (displaying the report) does not ever appear.

Symptom

image-20190226154614-1
Please wait, loading the report...

Cause

Internet Explorer settings/configuration is blocking access to the required Report Server website/components.

There are several potential settings that can cause this:
  • Scenario #1a - "Internet Explorer Enhanced Security Configuration" (IE ESC) enabled
  • Scenario #1b - "Internet Explorer Enhanced Security Configuration" (IE ESC) appears to be disabled, but (in fact) it is enabled
    • In some rare cases, the server may appear to have IEESC already disabled, but in fact it is not.
    • For more information, see the examples of third-party (non-IBM) websites at the end of separate IBM Technote #367595
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
This IBM Technote mostly relates to Scenarios #1a & 1b
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
   
  • Scenario #2 - Client device's Internet Explorer has the website inside an untrusted internet zone
    • For more information, see separate IBM Technote #1347916
 
  • Scenario #3 - Client device's Internet Explorer has the option "Submit non-encrypted form data" disabled
    • For more information, see separate IBM Technote #1460793
 
  • Scenario #4 - Database server (hosting the contentstore) has an issue.
    • For more information, see separate IBM Technote #1699189
​​​​​​​ 
  • Scenario #5 - Citrix environment issues, triggered via the failure of 'auto setup' (Citrix "Active Setup") of the Microsoft Internet Explorer profile (for the affected users).
    • For more information, see separate IBM Technote #1614381

Environment

This IBM Technote mainly relates to Scenarios #1a & #1b which occurs when Controller client being run on a client device which contains the Microsoft feature "Internet Explorer Enhanced Security Configuration" (IE ESC).
  • Typically this is a Citrix/Terminal Server (or the Controller application server itself).

Resolving The Problem

Scenario #1a
Disable Microsoft Internet Explorer Enhanced Security Configuration (MS IEEC)
  • For instructions, see separate IBM Technote #1446816.
Scenario #1b
Toggle the system by performing the following steps:
1. First enable Microsoft Internet Explorer Enhanced Security Configuration (MS IEEC)
image 2244
2. Afterwards, disable MS IEEC
image 2243
  • TIP: For more detail, see separate IBM Technote #1446816.
                 
Workaround (for both Scenario #1a and #1b):
Bypass MSIEEC by adding the Controller website and components to the 'trusted zone'
   

Steps

Depending on your environment, the following steps may need to be performed by each and every one of your end users

  • This is to ensure that the changes appear inside their Windows user profiles.


You *must* ensure that the name of the server is exactly as per the value shown in the error.
TIP: If you are unsure, then check this setting by performing the following (on the client device):
  • Click "Start - Run"
  • Type the following: NOTEPAD %appdata%\Cognos\CCR\ccr.config
or http://controllerserver.company.com/ibmcognos/... (FQDN)


1. Logon to the 'bad' client PC as the end-user him/herself
2. Launch Internet Explorer
3. Click 'Tools - Internet Options'
4. Click 'Security' tab then 'trusted sites'
5. Click 'sites' and add the report server's website name WITHOUT the extra virtual directories at the end (for example: http://myserver.mycompany.com ):
    6. Untick the box "Require server verification..." and save changes
    7. Next, highlight “Trusted Sites” again
    8. Click “Custom Level”
    9. Change ‘Reset to’ to “Medium-Low(or you can change to "medium" if using IE6)
    10 .Click “Reset”
      11. Click “yes” to confirm the change
      12. In order to enable Windows Single Sign On (SSO) now scroll down to the bottom of the option list, and select "Automatic logon with current user name and password":
        13. Click OK, OK.
        14. Test.

        TIP: For more information on the above (including alternative method(s) of achieving the same objective) see separate IBM Technote #1347558

        Scenarios #2, #3, #4, #5

        See separate IBM Technotes, using the links below.

        [{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

        Document Information

        Modified date:
        03 February 2020

        UID

        swg21460774