IBM Support

Framework Manager help cannot be displayed

Troubleshooting


Problem

When trying to use the help out of Framework Manager, you get an error message from Internet Explorer.

Symptom

Internet Explorer:
  • Content within this application coming from the Web site listed below is being blocked by Internet Explorer Enhanced Security
    Configuration "file://D:\Program Files\cognos\crn\webcontent\documentation"

In Framework Manager:
  • To use Cognos product documentation, you must enable JavaScript in your Browser

Cause

Internet Explorer Enhanced Security is enabled on the client device. By design, this restricts all file/website access by default.

Environment

User logged onto Windows server (for example Windows 2003 Terminal Server or Citrix server).

Resolving The Problem

Deactivate the Internet Explorer Enhanced Security Configuration (IEESC) on the server.
  • NOTE: In some rare cases, the server may appear to have IEESC already disabled, but in fact it is not. For example, see links to third-party (non-IBM) websites below. In this scenario, since the problem is caused by bugs/limitations in third-party (non-IBM) products, the customer is advised to contact Microsoft directly for assistance.

Steps:
The steps vary depending on the operating system of the client device:
Windows 2012
See separate IBM Technote #1446816.
                      
Windows 2008
1. Ensure no users on the Terminal Server
2. Logon to the Terminal Server as an administrator
3. Click "Start - Administrative Tools - Server Manager"
4. In the top left of the left-hand Window, highlight "Server Manager (servername)"
5. In the right-hand Window, locate the section "Security Information"
6. On the right-hand side, click the option "Configure IE ESC"
7. Inside the section "Administrators", modify the option to 'Off'
8. Inside the section "Users" modify the option to 'Off'
9. Click "OK"
            
Windows 2003
1. Ensure no users on the Terminal Server
2. Logon to the Terminal Server as an administrator
3. Open the Windows Control Panel
4. Launch "Add/Remove Programs"
5. Click "Add/Remove Windows Components"
6. Uncheck the box next to "Internet Explorer Enhanced Security Configuration"

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"1.1;8.2","Edition":"","Line of Business":{"code":"","label":""}},{"Product":{"code":"SUNSET","label":"PRODUCT REMOVED"},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Component":"ReportNet","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"","label":""}}]

Historical Number

1017597

Document Information

Modified date:
28 November 2022

UID

swg21339302