IBM Support

MustGather: Read first for IBM DataPower Gateways

Troubleshooting


Problem

MustGather documents aid in problem determination and save time resolving Support cases. These documents contain a list of the documentation you should gather so DataPower Support can diagnose your specific problem. These documents might also include diagnostic tips that will aid in diagnosing and solving problems.

Cause

Collecting MustGather data early, even before opening the Support case, helps DataPower Support quickly determine if:
  • Symptoms match known problems (rediscovery)
  • There is a non-defect problem that can be identified and resolved
  • There is a defect that identifies a workaround to reduce severity
  • Locating root cause can speed development of a code fix

Resolving The Problem

   

  Gather the following information needed to entitle your case:

  • Serial number of the appliance
  • Firmware version
    • Use the WebGUI Navigation Bar Status > System > Version Information
  • IBM customer numbers
  • A valid contact e-mail address and phone number
  • Severity of this issue to your business
 

  Gather the following general problem information:

  •  A complete description of the problem, including the following:
    • List of steps to recreate the behavior
    • Capture images of the screen to help describe the steps
    • Error messages
    • Any changes to installed firmware version
  • Exported Error Report- Instructions to collect WebGUI or CLI

 Opening a DataPower Support Case
More information on opening Support Cases can be found at IBM Support page.


►  Exchanging information with IBM Support
You can keep updated on your issues through the case at IBM Support. Also, you can upload data directly to the case. *Note: If you have additional questions, please visit Support Portal FAQ

*General hints and tips*

[{"Type":"MASTER","Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9H2Y","label":"IBM DataPower Gateway"},"ARM Category":[{"code":"a8m50000000L0rvAAC","label":"API Connect"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"2018.4.1;and future releases"}]

Document Information

Modified date:
07 December 2022

UID

swg21269260