Troubleshooting
Problem
Collecting data for problems with IBM WebSphere Application Server programmatic logins using Java™ Authentication and Authorization Service (JAAS). Gathering this information before calling IBM support will help familiarize you with the troubleshooting process and save you time.
Cause
Unable to configure JAAS or receiving exceptions at runtime when using JAAS
Resolving The Problem
If you have already contacted support, continue on to the component-specific MustGather information. Otherwise, click: MustGather: Read first for all WebSphere Application Server products.
JAAS specific MustGather information
Collect the following information with your login module configured:
- Enable the following tracing:
*=info:SASRas=all:com.ibm.ws.security.*=all:com.ibm.websphere.security.*=all
- Run the collector tool on both Network Deployment (for federated environment only) and base Application Server profiles.
- Include the JAAS login module source code that you are trying to use.
- If possible, include a simplified testcase in EAR format that reproduces the problem. This is often the best way to solve problems with JAAS login modules.
- Follow directions in MustGather: Readme First to open PMR and send data to IBM Support.
- Follow instructions to send diagnostic information to IBM support.
For a listing of all technotes, downloads, and educational materials specific to JAAS, search the WebSphere Application Server support site.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21199332