IBM Support

Security Bulletin: Vulnerability in Flexera InstallAnywhere affects Watson Explorer and Watson Content Analytics (CVE-2016-4560)

Security Bulletin


Summary

Some components of this product include a version of Flexera InstallAnywhere that could allow a remote attacker to execute arbitrary code on the system. This vulnerability can be avoided by following the instructions included in this bulletin.

Vulnerability Details

CVEID: CVE-2016-4560
DESCRIPTION:
Flexera InstallAnywhere could allow a local attacker to gain elevated privileges on the system, caused by an untrusted search path. An attacker could exploit this vulnerability using a Trojan horse DLL in the current working directory of a setup-launcher executable file to gain elevated privileges on the system.
CVSS Base Score: 7.8
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/113016 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

  • Watson Explorer Analytical Components versions 11.0.0.0 - 11.0.0.3
  • Watson Explorer Analytical Components versions 10.0.0.0 - 10.0.0.2
  • Watson Explorer Annotation Administration Console versions 11.0.0.0 - 11.0.0.3
  • Watson Explorer Annotation Administration Console versions 10.0.0.0 - 10.0.0.2
  • Watson Content Analytics versions 3.5.0.0 - 3.5.0.3
  • Watson Content Analytics versions 3.0.0.0 - 3.0.0.6

Remediation/Fixes

Affected Product

Affected VersionsFix
Watson Explorer Analytical Components11.0.0.0 - 11.0.0.3Upgrade to Watson Explorer Analytical Components Version 11.0.1. For information about this version, and links to the software and release notes, see the download document for the analytical components. For information about upgrading, see the upgrade procedures.
Watson Explorer Annotation Administration Console11.0.0.0 - 11.0.0.3Upgrade to Watson Explorer Annotation Administration Console Version 11.0.1. For information about this version, and links to the software and release notes, see the download document for the foundational components. For information about upgrading, see the upgrade procedures.
Watson Content Analytics3.5.0.0 - 3.5.0.3Upgrade to Watson Content Analytics Version 3.5.0.4. For information about this version, and links to the software and release notes, see the download document. For information about upgrading, see the upgrade procedures.

For other affected products and versions, see Workarounds/Mitigations.

Workarounds and Mitigations

When installing, upgrading, or patching any of the affected components, use the following procedure:

  1. As an administrator, create a new directory which only the administrator has write permission to.
  2. Ensure that there are no DLL files in this directory
  3. Unzip or copy the files from your installation media into this new directory. Do not copy or move files from any other source into this directory.
  4. Important: Do not rename the installer executable. Renaming the installer to a name other than that provided by IBM may expose you to the vulnerability.
  5. Run the installer from this directory to install the product
  6. Proceed with the installation as normal.

Get Notified about Future Security Bulletins

References

Off

Change History

20 May 2016: Original version published
18 July 2016: A fix is provided for Watson Explorer versions 11.0.0.0 - 11.0.0.3 in version 11.0.1.
30 September 2016: A fix is provided for Watson Content Analytics versions 3.5.0.0 - 3.5.0.3.

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

[{"Product":{"code":"SS8NLW","label":"Watson Explorer"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.0.0;10.0.0.1;10.0.0.2;11.0.0;11.0.0.1;11.0.0.2;11.0.0.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS5RWK","label":"Watson Content Analytics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.5;3.0","Edition":"All Editions","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
17 June 2018

UID

swg21983753