Troubleshooting
Problem
Symptom
Cause
- For example this has been seen with Controller 10.4.1
- TIP: The log file (com.ibm.cognos.fcm.log) will typically contain the entry ''BadCredentialsException"
- TIP: For more details, see separate IBM Technote #885182
- TIP: For more details, see separate IBM Technote #6117838
- TIP: For more details, see separate IBM Technote #6155529
- TIP: For more details, see separate IBM Technote #6262335
- For example, when using Native security the end user has accidentally typed in their Windows password instead
- TIP: The log file (com.ibm.cognos.fcm.log) will typically contain the entry ''BadCredentialsException"
Diagnosing The Problem
- TIP: By default, this is located here: C:\Program Files\IBM\cognos\ccr_64\fcmweb\wlp\usr\servers\fcm.web\logs
2020-02-03 15:01:03 | <?>@<?> | INFO | [com.ibm.cognos.fcm.wmc.ccrws.DefaultCcrClient] [CCR-WS] Successfully logged in ADM@localhost\Blank (session id: C45620CB0FB64D1BB20F903349BA44EF).
2020-02-03 15:01:03 | <?>@<?> | INFO | [com.ibm.cognos.fcm.web.ui.infrastructure.auth.ccrnative.CustomAuthenticationProvider] Authenticated adm@Blank (session id: pP22oy1QYOLVsTqmG2lqShE): 72 595 ms
2020-02-03 15:01:11 | ADM@Blank | INFO | [com.ibm.cognos.fcm.web.ui.secure.WorkspaceController] /fcm.web/api/commonworkspace/entities: 2 186 ms
2020-02-03 15:01:11 | ADM@Blank | INFO | [com.ibm.cognos.fcm.web.ui.secure.WorkspaceController] /fcm.web/api/commonworkspace/entities: 2 221 ms
2020-02-03 15:03:17 | <?>@<?> | INFO | [com.ibm.cognos.fcm.web.ui.LoginController] Set session environment: prod (3 settings)
2020-02-03 15:03:18 | <?>@<?> | INFO | [com.ibm.cognos.fcm.wmc.repository.CacheValidator] Blank: validateSharedCache (2 entity versions updated): 345 ms
2020-02-03 15:03:18 | <?>@<?> | INFO | [com.ibm.cognos.fcm.web.ui.infrastructure.auth.ccrnative.CustomAuthenticationProvider] Authentication rejected: 'adm' (org.springframework.security.authentication.BadCredentialsException: Invalid authentication credentials.)
Resolving The Problem
- Fix: Upgrade to Controller 10.4.2 (or later)
- Workaround: Modify the end user's password so that it does not contain any unsupported character.
- Example: Remove any of the following characters: £
- TIP: For more details, see separate IBM Technote #885182
- TIP: For more information, see separate IBM Technote #6113944.
- TIP: For more information, see separate IBM Technote #6117838.
- TIP: For more information, see separate IBM Technote #6155529.
- TIP: For more information, see separate IBM Technote #6262335.
- For example, if using Controller 'native' authentication, then type in a 'native' username/password (not Windows username/password)
Related Information
885182 - "Not authorized" (Failed to authenticate) error when logon to one (new…
6115828 - "Not authorized" when logon to Controller Web, caused by not trusting…
6117838 - "Not authorized" when logon to Controller Web, caused by missing TLS …
6155529 - "Not authorized ... Invalid login response received (empty)" when log…
6262335 - One user gets "Not authorized" ("Invalid authentication credentials")…
Document Location
Worldwide
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Document Information
Modified date:
10 September 2020
UID
ibm11288582