IBM Support

Content Collector does not detect cluster or other nodes in version 4.0

Technical Blog Post


Abstract

Content Collector does not detect cluster or other nodes in version 4.0

Body

The following Tech Note describes an issue in some environments where IBM Content Collector version 4.0 does not detect cluster or other nodes in the cluster.

The following symptoms are typical of such an issue:

  • During installation of secondary nodes, the cluster name is not displayed in the drop down list.
  • When running afuClusterTool.exe, not all nodes in the cluster are displayed in the output.

Root Cause:

In some environment, multicast may not be working or reliable.

Resolving the problem:

  • Shut down all Content Collector services on all nodes in the cluster.
  • Verify the following registry settings on each node of the cluster:
    • SOFTWAR > Wow6432Node > IBM > EMRC > 4.0 > Datastores > ibm.ctms.datastore.soliddb > ConfigurationBackupHost = hostname of the configuration backup host
    • SOFTWAR > Wow6432Node > IBM > EMRC > 4.0 > Datastores > ibm.ctms.datastore.soliddb > ConfigurationHost = hostname of the configuration host
    • SOFTWAR > Wow6432Node > IBM > EMRC > 4.0 > ibm.ctms.datastore_monitor > nodes = hostname1 hostname2 hostname3 (type: multi-string)
  • In the file ContentCollector\Configuration\afu_install.properties, verify the following:

    CLUSTER_NAME=name_of_cluster

    The cluster name should be the same on all nodes.


  • In the file ContentCollector\ctms\DataStoreMonitor.reg, modify accordingly:

    scopes=name_of_cluster

    config-host=hostname_of_the_configuration_host

    config-backup-host= hostname_of_the_configuration_backup_host

    icc-nodes=hostname1 hostname2 hostname3


  • In the file ContentCollector\ctms\DataStoreMonitor.cfg, verify that

    net.slp.useScopes = name_of_cluster


  • Restart the following services:
    • IBM Content Collector Configuration Store
    • IBM Content Collector Configuration Store Manager
    • IBM Content Collector Configuration Access

/support/pages/node/513235

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSAE9L","label":"Content Collector"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

UID

ibm11139056