General Page
Introduction
Starting with IBM Personal Communications (PCOMM) v14.0.1.0, PCOMM is shipped in two types of delivery vehicles –
1. Refresh Pack
This is a complete installer image of the PCOMM product, which does not require any previous version of the product and can be installed independently.
2. Refresh Pack Update Installer
This delivery vehicle contains only the fixes developed after the release of the PCOMM v14.0 base version. Each update installer is cumulative in nature; in other words, a new update installer will also contain fixes from the previous update installers. This requires a PCOMM v14 base version or a Refresh Pack installed.
This document provides answers to some of the FAQs and lists some of the known issues in the Refresh Pack Update Installer.
Frequently Asked Questions (FAQs)
1. Question
Can I install PCOMM v14.0.0.0 (base version) over PCOMM Refresh Pack Update Installer v14.0.1.0?
Answer
No, the v14.0.1.0 Refresh Pack Update Installer permits this downgrade installation, but it is not recommended.
If you have accidentally installed PCOMM v14.0.0.0 over PCOMM Refresh Pack Update Installer v14.0.1.0, uninstall both the v14.0.1.0 Refresh Pack Update Installer and PCOMM v14.0.0.0 (base version) first, and then proceed to install PCOMM v14.0.0.0.
2. Question
After installing PCOMM v14.0.0.0, upgraded to PCOMM Refresh Pack Update Installer v14.0.1.0 or v14.0.2.0. Can I directly uninstall the base version?
Answer
No, the base version should not be uninstalled without uninstalling the Refresh Pack Update Installer. If done accidentally, then uninstall the Refresh Pack Update Installer.
3. Question
Can I install PCOMM Refresh Pack Update Installer over previous PCOMM versions, viz. v12.x, v13.x?
Answer
No, PCOMM Refresh Pack Update Installers must be installed only on PCOMM v14.x installations.
4. Question
What happens when I install a newer PCOMM Refresh Pack Update Installer over a previous PCOMM Refresh Pack Update Installer?
Answer
The PCOMM Refresh Pack Update Installer will be upgraded to the newer version. Since the Refresh Pack Update installer is cumulative, the Control Panel, Add/Remove Programs shows the PCOMM base version and the latest Refresh Pack Update Installer version.
Note: In case of installing a newer PCOMM Refresh Pack Update Installer over PCOMM v14.0.1.0 Refresh Pack Update Installer, we advise not to roll back to the base version. This is due to Known Issue #1 documented under the Known Issues section.
5. Question
Can a standard user perform the Auto-update?
Answer
Yes, A Standard User can upgrade to the latest version only with a base version of 14.0.5.0 or higher. But, if the base version is less than 14.0.5.0 the standard user cannot perform Auto-Update.
1. Issue
If a Windows User who is not an 'Administrator', tries to install PCOMM Refresh Pack Update Installer v14.0.1.0, the files of PCOMM v14.0 base version will not be backed up (before the installation) to aid the rollback feature. Failure to create a backup affects future Refresh Pack Update Installers.
Note: This known issue, Auto-update via Standard user is resolved in the PCOMM 14.0.5 version.
Cause
Installing PCOMM Refresh Pack Update Installer v14.0.1.0 requires an “Administrator” account. The problem occurs due to insufficient privileges provided to v14.0.1.0 Refresh Pack Update Installer, to update the Windows registry, “Program Files” folders, when installed from a Windows User other than “Administrator”.
Resolving the Problem
There is no resolution available. Because of this issue, v14.0.1.0 Refresh Pack Update Installer cannot be rolled back to the base version.
The issue is fixed in v14.0.2.0 Refresh Pack Update Installer.
Workaround
There is no workaround available. We advise not to install the PCOMM Refresh Pack Update Installer v14.0.1.0 with any Windows user other than “Administrator”.
2. Issue
Installed PCOMM v14.0.1.0 Refresh Pack. On top of this, I have installed PCOMM v14.0.2.0 Refresh Pack Update Installer.
When I try to uninstall PCOMM v14.0.1.0 Refresh Pack, I am getting the following incorrect error message:
“Installation of IBM Personal Communications cannot proceed further as a similar version of the product is already installed on the system”.
Cause
When a User tries to uninstall v14.0.1.0 Refresh Pack, it prompts a message to restrict the uninstallation. This message is incorrect.
Resolving the Problem
Uninstall the Refresh Pack Update Installer, before uninstalling the Refresh Pack.
Starting with the v14.0.2.0 Refresh Pack, the erroneous notification message has been corrected as below:
“An IBM Personal Communications Update Fix/Refresh pack is found on this system. Uninstall the 'Update Fix/Refresh Pack' first to uninstall the IBM Personal Communications base package.”
Workaround
Not applicable.
3. Issue
The Upgradation of Refresh Pack Update Installer IBM Personal Communications V14.0.3.0 over IBM Personal Communications Base package fails to upgrade for Korean IBM Personal Communications Refresh Pack update installer -x64 bit users.
Cause
Incorrect keypath for installer component, due to which, when a User tries to upgrade v14.0.3.0 Refresh Pack Update Installer, it prompts an error message which restricts the upgrade.
Error Message: Error 2715. The specified File key ('_A60E5A304D9DFE4E19825C54CFE4A91E') is not found in the File table.
Error Dialog:
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Resolving the Problem
Please Contact IBM Support for assistance.
Workaround
Not applicable.
4. Issue
When a refresh pack update installer of version 14.0.5.0 is installed for PCOMM x32-bit, the “Session Manager -Online” (Managed PCOMM) application doesn’t startup.
Cause
The “Session Manager – Online” application is dependent on the VC++ runtime libraries “msvcp100.dll” and “msvcr100.dll”, which are not installed with the refresh pack update installer.
Resolving the Problem
Install the x32-bit VC++ 2010 redistributable package that consists of the necessary runtime libraries and start the “Session Manager – Online” application.
Refer to the Download Link for downloading VC++ 2010 redistributable package.
Workaround
Not applicable.
5. Issue
The Upgrade of the IBM Personal Communications Refresh Pack installer (RP6) on top of base package v14.0.5.0 fails to install on Windows x86 bit operating systems using auto-update option.
Cause
The IBM Personal Communications Refresh Pack installer(RP6) installer hangs on top of the base package.
Resolving the Problem
Not Applicable.
Workaround
Install the IBM Personal Communications Refresh Pack (RP6) on top of the (v 14.0.5)base package, manually execute the MSI file.
6. Issue
After Upgrade of the IBM Personal Communications Refresh Pack (RP6) does not support Start or Configure Sessions -> Package -> Detect and Repair Menu option..
Cause
Start or Configure Sessions -> Package -> Detect and Repair does not support.
Resolving the Problem
Not Applicable.
Workaround
Not applicable.
7. Issue
The upgrade of the IBM Personal Communications from v1407iFix 001 to v1408 RPUI fails via Session Manager and Session Manager-Online.
Cause
RPUI Package code is not updated in the MPCOMM.cnf file.
Resolving the Problem
Before upgrading to v1408 RPUI, download the respective zip files attached to this technote, for PCOMM 32bit: PCOMM-14.0.8-MPCOMM-CNF-32Bit.zip and for PCOMM 64bit: PCOMM-14.0.8-MPCOMM-CNF-64Bit.zip. Extract the MPCOMM.cnf from the downloaded zip file and copy it to the WebServerURL location as per the steps mentioned in below link for auto-upgrade:
Workaround
Instead of auto-upgrade, perform the installation manually by double clicking on the IBM Personal Communications RP1408 xx.msi file.
8. Issue
When upgrading from v1407iFixRPUI to v1408 RPUI, uninstallation or rollback via Session Manager or Session Manager-Online fails.
Cause
The PCOMMService is not restarted, leading to the error message:
"Failed to send or receive events using named pipes."
Resolving the Problem
Not Applicable
Workaround
- Reboot the system or restart the PCOMMService to resolve the issue.
(OR)
- To rollback the v1408 RPUI package, uninstall the application using the Control Panel Application Wizard.
9. Issue
In version 14.0.8 of RPUI, when upgraded from a v14.0.5 or lower base version and combined with an RPUI of RP6, R6 iFix, or RP7, an issue occurs where the SendKey API fails to function properly in HACL automation on Windows 11 24H2 OS only.
Cause
Necessary file(s) are not updated.
Resolving the Problem
Not Applicable
Workaround
Rename the autps.tlb file located at C:\Program Files\IBM\Personal Communications and install v14.0.8 RPUI.
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Document Information
Modified date:
12 May 2025
UID
ibm11115253