Troubleshooting
Problem
User launches FAP client ("IBM Cognos FAP") from the start menu. User logs on. User clicks tab 'Data Marts' and highlights the relevant data mart. User clicks "Start" (to start the initial publish).
After a few seconds, the 'status' changes to 'Error'. User clicks the 'logs' tab. Inside there, there are more errors.
If the user hovers their mouse over the error, a new message is seen.
If the user hovers their mouse over the error, a new message is seen.
Symptom
Could not logon to TM1
SystemServerClientNotFound
SystemServerClientNotFound
Cause
There are many possible causes for the generic error 'Could not login to TM1'.
- TIP: For more examples, see separate IBM Technote #1664572.
There are also several scenarios where the logs also has the following error mentioned: SystemServerClientNotFound
- TIP: For more examples, see separate IBM Technote #1449704.
This Technote specifically relates to the scenario where the cause is that the user defined in the FAP Data Mart does not have admin rights in the target PA (TM1) instance (sometime known as 'TM1 server').
Resolving The Problem
Modify the rights of the PA instance, so that the relevant user (the one configured inside the FAP client) has full 'ADMIN' rights to the PA instance.
Steps:
1. Launch FAP client
2. Click tab 'Data Marts'
3. Highlight the relevant data mart, and click "Edit"
4. Make a note of the value of 'Client'
2. Click tab 'Data Marts'
3. Highlight the relevant data mart, and click "Edit"
4. Make a note of the value of 'Client'
- For example: NAMESPACE\Controller_FAP
5. Launch TM1 Architect
6. Open the relevant (target) PA instance ("TM1 Server")
7. Right-click on the instance, and choose "Security - Clients/Groups":
8. Add an entry in there, for that user (for example "NAMESPACE\Controller_FAP")
9. Make sure that 'ADMIN' is ticked/enabled:
Related Information
Document Location
Worldwide
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Document Information
Modified date:
04 November 2019
UID
ibm11102839