IBM Support

No password prompt for Centrify Users

Troubleshooting


Problem

Non-root users do not get a password prompt.

Cause

Determine the authentication methods for the user.

1. Check /etc/security/user
     SYSTEM = "CENTRIFYDC OR CENTRIFYDC[NOTFOUND] AND (compat)"

2) Check /etc/methods.cfg 
CENTRIFYDC:
    program = /usr/lib/security/CENTRIFYDC
    program_64 = /usr/lib/security/CENTRIFYDC64
    options = noprompt
The "noprompt" setting means that Centrify's loadable authentication module provides the password prompt. 

Resolving The Problem

This configuration is not supported by AIX. Users should consult with their vendor for configuration support.
 

SUPPORT

If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1.  Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2.  Capture any logs or data relevant to the situation.

3.  Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

4.  Provide a clear, concise description of the issue.

5.  If the system is accessible, collect a system snap, and upload all of the details and data for your case.

 - For guidance, see: Working with IBM AIX Support: Collecting snap data

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"ARM Category":[{"code":"a8m0z000000cvzlAAA","label":"Security->Authentication"}],"ARM Case Number":"TS003692236","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
12 May 2020

UID

ibm16208753