IBM Support

IP devices become inactive with I/O errors

Troubleshooting


Problem

IP devices receive I/O errors, resulting in an EZZ4310I message and become inactive. These errors occur at various times, usually with a cluster of them affecting several devices. You may also experience various other unexplained errors in other (unrelated) address spaces.

Symptom

Check the SYSLOG to see if this is accompanied by an IOS000I (or possibly an IOS1000I) message, similar to the following:
IOS000I 05D1,05,CDC,01,**18,,,,NET

  • CDC is Channel Data Check.

  • The 1 in **18 means protection exception.

  • NOTE: These could also be CCC (Channel Control Check) and **14.

  • NET is the name of the VTAM address space.

Alternatively, there can be VTAM messages generated. Note that these messages may not appear in the SYSLOG if certain network monitoring tools are installed. Check that tool or the VTAM JOBLOG in that case.

    IST1222I DATA DEVICE uuuu IS INOPERATIVE, NAME IS dddddddd
    IST1578I DEVICE INOP DETECTED FOR dddddddd BY ISTTSCMA CODE = 104
    IST314I END

Cause

The cause of this condition is that one (or more) of the I/O buffers whose pages have been assigned fixed slots in real storage have been released by some other process. Known problems that can cause this condition are as follows:

Product/component

ReleaseFixRSU
DFSMSz/OS 1.6OA079720409
z/OS 1.8 - 1.11OA323441006
NPM2.5-2.7OW558860212
IMSR7PQ990920503
R8PQ964570502
RSMz/OS 1.11 - 1.13OA381281201
z/OS 1.13-2.1OA447051410
Computer Associates CA-11 (Automated Restart Tracking System)3.0QO39922N/A
BMC Mainview
Version 2.2.02 of ARC (Automated Restart Control)
Oracle Systems RDBMS804 or 806BUG# 1268868

Diagnosing The Problem

If none of the known problems are applicable to this system, the procedure to capture a dump of the program causing the problem involves identifying the real address for one of the involved control structures for a QDIO device and setting a SLIP on the page table entry for that buffer. This is a multiple step process that needs to be coordinated with IBM support, and will need to be repeated every time TCPIP is recycled. The first step is to collect a console dump of the *MASTER* address space:


    DUMP TITLE='First Step'
    R xx,ASID=1,JOBNAME=(RASP),CONT
    R xx,SDATA=(RGN,LSQA,SWA,TRT,ALLNUC,LPA,PSA,SUM,CSA,SQA)

Contact IBM Support (or use the Service Request tool) to open a PMR, then use the directions in Technote 1298465 to send in the resultant dump.

Resolving The Problem

Ensure that all applicable PTFs have been applied to the system. Contact the vendor for any ISV product fixes.

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.6;1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2;2.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

TCPIP;TCP/IP;Communications Server;CS/390

Document Information

Modified date:
15 June 2018

UID

swg21164108