IBM Support

Informix Server System Requirements

Product Documentation


Abstract

This document describes the operating system requirements for the current releases of IBM® Informix® server.

Content


Last Modified: August 29, 2019

IBM Informix runs on most systems that have a UNIX, Linux, or Windows operating system, as well as the Mac OS X operating system.

Minimum disk space and memory requirements:

  • UNIX and Linux: 750 MB of disk space and 256 MB of memory.
  • Mac OS X: 750 MB of disk space and 512 MB of memory.
  • Windows: 600 MB of disk space and 256 MB of memory.


Many applications require substantially larger systems. Your IBM sales team can help optimize the hardware required for your application.

Related system requirements:


System requirements are listed by operating system (OS). In this document:



Platform: IBM AIX

Required hardware: IBM POWER (System p, System i, POWER blades)

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:

  • F = 64-bit
    U = 32-bit
Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
AIX 6.1 12.10.FC13
Minimum TL 4, Service Pack 3
11.70.FC9
Minimum TL 4, Service Pack 3
AIX 7.1 12.10.FC13 11.70.FC9
AIX 7.2 14.10.FC2 12.10.FC13



Platform: HP-UX (Itanium)

Required hardware: Itanium

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following code is used in this table:

  • F = 64-bit

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
HP-UX 11.31 14.10.FC2 12.10.FC13 11.70.FC9


Platform: HP-UX (PA-RISC)

Required hardware: PA-RISC

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:

  • F = 64-bit
    H = 32-bit on HP PA-RISC 11.x and HP PA-RISC 11.x 64-bit

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
HP-UX 11.11 11.70.FC9
HP-UX 11.23 11.70.FC9
HP-UX 11.31 11.70.FC9



Platform: Linux Intel

Required hardware: Intel x86, Intel Itanium, Intel EM64T, AMD64

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements. For Developer Edition, you can view the machine notes in the product download before you install.

The following codes are used in this table:
F = 64-bit
U = 32-bit
RHEL = RedHat Enterprise Linux

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
RHEL 5 12.10.UC13
12.10.FC13
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
11.70.UC9
11.70.FC9
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
RHEL 6 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
RHEL 7
14.10.FC2
Additional OS requirements: 
- Minimum update 4
- Base kernel version 3.10.0
- Glibc version 2.17
- Compiler 4.8.5
12.10.FC13
Additional OS requirements:
- Base kernel version 3.10
- Glibc version ​2.17
- Compiler 4.8.2
RHEL 8
14.10.FC2
Additional OS requirements:
- Base kernel version 4.18.0
- Glibc version 2.28
- Compiler 8.2.1
CentOS 6 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
CentOS 7 14.10.FC2
Additional OS requirements:
- Minimum update 4
- Base kernel version 3.10.0
- Glibc version 2.17
- Compiler 4.8.5
12.10.FC13
Additional OS requirements:
- Base kernel version 3.10
- Glibc version ​2.17
- Compiler 4.8.2
SuSE SLES 11 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3
SuSE SLES 12
14.10.FC2
Additional OS requirements:
- Minimum service pack 3
- Base kernel version 4.4.73
- Glibc version 2.22
- Compiler 4.8.5
12.10.FC13
Additional OS requirements:
- Base kernel version 3.12.28
- Glibc version ​2.19
- Compiler 4.8.3
SuSE SLES 15 14.10.FC2
Additional OS requirements:
- Base kernel version 4.12.14
- Glibc version 2.26
- Compiler 7.3.1
Asianux 3.0 12.10.UC13
12.10.FC13
Additional OS requirements:
- Minimum service pack 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
11.70.UC9
11.70.FC9
Additional OS requirements:
- Minimum service pack 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
Debian 5.0 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.26
- Glibc version ​2.7
- Compiler 4.3.2
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.26
- Glibc version ​2.7
- Compiler 4.3.2
Ubuntu 8.04 LTS 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.24
- Glibc version ​2.7
- Compiler 4.2.4
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.24
- Glibc version ​2.7
- Compiler 4.2.4
Ubuntu 10.04 LTS 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.32
- Glibc version ​2.11.1
- Compiler 4.4.3
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.32
- Glibc version ​2.11.1
- Compiler 4.4.3
Ubuntu 12.04 LTS 12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​3.2.0
- Glibc version ​2.15
- Compiler 4.6.3
Ubuntu 14.04 LTS
 
12.10.FC13
Additional OS requirements:
- Base kernel version ​3.13
- Glibc version 2.19
- Compiler 4.8.4
Ubuntu 16.04 LTS 14.10.FC2
Additional OS requirements:
- Base kernel version 4.4.0
- Glibc version 2.23
- Compiler 5.4.0
12.10.FC13
Additional OS requirements:
- Base kernel version ​4.4.0
- Glibc version 2.23
- Compiler 5.4.0
Ubuntu 17.10 14.10.FC2
Additional OS requirements:
- Base kernel version 4.13
- Glibc version 2.26
- Compiler 7.2
12.10.FC13
Additional OS requirements:
- Base kernel version ​4.13.0
- Glibc version 2.26
- Compiler 7.2
openSuSE 11.1 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9.2
- Compiler 4.3.2
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9.2
- Compiler 4.3.2
openSuSE 11.2 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version 2.6.31​
- Glibc version ​2.10.1
- Compiler 4.4.0
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version 2.6.31​
- Glibc version ​2.10.1
- Compiler 4.4.0
openSuSE 11.3 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.34
- Glibc version ​2.11.2
- Compiler 4.5.0
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.34
- Glibc version ​2.11.2
- Compiler 4.5.0
Fedora 11 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.29
- Glibc version ​2.10.1
- Compiler 4.4.0
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.29
- Glibc version ​2.10.1
- Compiler 4.4.0
Fedora 12 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.31
- Glibc version ​2.11
- Compiler 4.4.2
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.31
- Glibc version ​2.11
- Compiler 4.4.2
Fedora 13 Developer Edition only
12.10.UC13
12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.33
- Glibc version ​2.12
- Compiler 4.4.4
Developer Edition only
11.70.UC9
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.33
- Glibc version ​2.12
- Compiler 4.4.4



Platform: Linux - IBM POWER (Big Endian)

Required hardware: IBM POWER (System p, System i, POWER Blades)

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:

  • F = 64-bit
    RHEL: RedHat Enterprise Linux
Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
RHEL 5 12.10.FC13
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
11.70.FC9
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
RHEL 6 12.10.FC13
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
11.70.FC9
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
RHEL 7 12.10.FC13
Additional OS requirements:
- Base kernel version 3.10
- Glibc version ​2.17
- Compiler 4.8.2
SuSE SLES 11 12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3



Platform: Linux - IBM POWER (Little Endian)

Required hardware: IBM POWER8® for ppc64le

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:
F = 64-bit
RHEL: RedHat Enterprise Linux

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
RHEL 7
14.10.FC2
Additional OS requirements:
- Minimum update 4
- Base kernel version 3.10.0
- Glibc version ​2.17
- Compiler 4.8.5
12.10.FC13
Additional OS requirements:
- Base kernel version 3.10
- Glibc version ​2.17
- Compiler 4.8.3
SuSE SLES 12
14.10.FC2
Additional OS requirements:
- Minimum service pack 3
- Base kernel version 4.4.73 
- Glibc version 2.22
- Compiler 4.8.5
12.10.FC13
Additional OS requirements:
- Base kernel version ​3.12.28
- Glibc version ​2.19
- Compiler 4.8.3
SuSE SLES 15

14.10.FC2
Additional OS requirements:
- Base kernel version 4.12.14
- Glibc version 2.26
- Compiler 7.3.1

Ubuntu 14.04 LTS 12.10.FC13
Additional OS requirements:
- Base kernel version ​3.16.0
- Glibc version 2.19
- Compiler 4.8.4


Platform: Linux - IBM System z

Required hardware: IBM eServer System z

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:
F = 64-bit
RHEL: RedHat Enterprise Linux

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
RHEL 5 12.10.FC13
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
11.70.FC9
Additional OS requirements:
- Minimum update 3
- Base kernel version ​2.6.18
- Glibc version ​2.5
- Compiler 4.1.2
RHEL 6 12.10.FC13
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
11.70.FC9
Additional OS requirements:
- Base kernel version 2.6.32​
- Glibc version ​2.12
- Compiler 4.4.4
RHEL 7 12.10.FC13
Additional OS requirements:
- Base kernel version 3.10.0
- Glibc version ​2.17
- Compiler 4.8.2
SuSE SLES 11 12.10.FC13
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3
11.70.FC9
Additional OS requirements:
- Base kernel version ​2.6.27
- Glibc version ​2.9
- Compiler 4.3.3
SuSE SLES 12 12.10.FC13
Additional OS requirements:
- Base kernel version ​3.12.28
- Glibc version ​2.19
- Compiler 4.8.3


Platform: Mac OS X

Required hardware: Intel EM64T

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following code is used in this table:

  • F = 64-bit
Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
Mac OS X 10.5.2 "Leopard" 11.70.FC4
Mac OS X 10.6 "Snow Leopard" 11.70.FC4
Mac OS X 10.9 "Mavericks" 12.10.FC13
Mac OS X 10.10 "Yosemite" 12.10.FC13


Platform: Solaris SPARC

Required hardware: SPARC
Informix is supported with or without Zones. For more information about Zones, see this PDF .

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following codes are used in this table:

  • F = 64-bit
    U = 32-bit
Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
Solaris 10 12.10.FC13
Minimum update 8 is required
11.70.FC9
Minimum update 6 is required
Solaris 11 14.10.FC2
Minimum update 3 is required
12.10.FC13 11.70.FC9



Platform: Solaris x64

Required hardware: AMD AMD64, Intel EM64T
Informix is supported with or without Zones. For more information about Zones, see this PDF .

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.

The following code is used in this table:

  • F = 64-bit
Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
Solaris 10 12.10.FC13
Minimum update 8 is required
11.70.FC9
Minimum update 6 is required
Solaris 11 12.10.FC13 11.70.FC9



Platform: Windows

Required hardware: Intel x86, x64 (AMD AMD64, Intel EM64T)

The version numbers are links to the appropriate Machine Notes, which contain important information about additional OS requirements.


  • The following codes are used in this table:
    T = 32-bit on Windows platforms
    F = 64 bit on x64 (AMD AMD64, Intel EM64T)

Operating System Version Informix 14.10 Informix 12.10 Informix 11.70
Windows 10 12.10.FC13
Windows 8 12.10.TC13
12.10.FC13
Windows 7 12.10.TC13
12.10.FC13
11.70.TC9
11.70.FC9
Windows Vista 12.10.TC7
12.10.FC8
11.70.TC8
11.70.FC8
Windows XP 12.10.TC5
12.10.FC5
Service pack 2 required
11.70.TC8
11.70.FC8
Windows 2016 14.10.FC2 12.10.TC13
12.10.FC13
Windows 2019 14.10.FC2
Windows 2012 R2 12.10.TC13
12.10.FC13
Windows 2012 12.10.TC13
12.10.FC13
Windows 2008 R2 (64-bit) 12.10.TC13
12.10.FC13
11.70.TC9
11.70.FC9
Windows 2008 12.10.TC7
12.10.FC7
11.70.TC9
11.70.FC9
Windows 2003 12.10.TC5
12.10.FC5
Service pack 2 required
11.70.TC9
11.70.FC9

Internal Use Only

Operating System
Software
Hardware
AIX
Read the operating system prerequisites.

 
Platform: IBM -- AIX
Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
U = 32-bit on any UNIX/Linux platform
 

 
INFORMIX 11.70
Product Version
Operating System Version
Comments
INFORMIX 11.70.FC4
AIX 6.1 Minimum AIX 6.1 TL 4 Service Pack 3 is required
AIX 7.1
INFORMIX 11.50
Product Version
Operating System Version
Comments
INFORMIX 11.50.UC8
AIX 5L 5.3
AIX 6.1
AIX 7.1
INFORMIX 11.50.FC8
AIX 5L 5.3
AIX 6.1
AIX 7.1

 
Informix 11.10
Product Version
Operating System Version
Comments
Informix 11.10.UC4
AIX 5L 5.3
AIX 6.1
Informix 11.10.FC4
AIX 5L 5.3
AIX 6.1
IBM POWER (System p, System i, POWER Blades)
HP-UX
Read the operating system prerequisites for:

HP-UX on Itanium

 
Platform: HP -- HP-UX (Itanium)

HP-UX is supported on PA-RISC and Itanium. Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
 

 
INFORMIX 11.70
Product Version
Operating System Version
INFORMIX 11.70.FC4
HP-UX 11.31

 
INFORMIX 11.50
Product Version
Operating System Version
INFORMIX 11.50.FC8
HP-UX 11.23
HP-UX 11.31
 

 
Informix 11.10
Product Version
Operating System Version
Informix 11.10.FC4
HP-UX 11.23
HP-UX 11.31

HP-UX on PA-RISC

 
Platform: HP -- HP-UX (PA-RISC)
HP-UX is supported on PA-RISC and Itanium. Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
H = 32-bit build on any HP PA-RISC 11.x platform; also runs on HP PA-RISC 11.x 64-bit
U = 32-bit on any Unix/Linux platform
 

 
INFORMIX 11.70
Product Version
Operating System Version
INFORMIX 11.70.FC4
HP-UX 11.11
HP-UX 11.23
HP-UX 11.31
 

 
INFORMIX 11.50
Product Version
Operating System Version
INFORMIX 11.50.HC8
HP-UX 11.11
HP-UX 11.23
HP-UX 11.31
INFORMIX 11.50.FC8
HP-UX 11.11
HP-UX 11.23
HP-UX 11.31
 

 
Informix 11.10
Product Version
Operating System Version
Informix 11.10.HC4
HP-UX 11.11
HP-UX 11.23
HP-UX 11.31
Informix 11.10.FC4
HP-UX 11.11
HP-UX 11.23
HP-UX 11.31

 
Either PA-RISC or Itanium is required
Linux
Read the operating system prerequisites.

 
 
Informix® for Linux®
Informix supports Linux on a variety of platforms including Intel x86, Intel Itanium, Intel EM64T, AMD64, IBM eServer System z, and IBM POWER (System p, System i, POWER Blades).

Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
U = 32-bit on any Linux platform
RHEL = RedHat Enterprise Linux
 

 
INFORMIX 11.70
Product version
Platform
Distributions
Base Kernel version
Glibc version
Compiler version
Comments
Informix
11.70.UC4
Intel x86 RHEL 5 2.6.18 2.5 4.1.1 Minimum Update 3 of RHEL 5 is required
RHEL 6 2.6.32 2.12 4.4.4
Asianux 3.0 2.6.18 2.5 4.1.2 Minimum Service Pack 3 of Asianux 3.0 is required
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)
libaio1 (required for KAIO)
pdksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 10.04 LTS 2.6.32 2.11.1 4.4.3 Install the following:
bc utility (required by
installserver)
libaio1 (required for KAIO)
pdksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
x86_64
(EM64T/AMD64)
RHEL 5 2.6.18 2.5 4.1.1 Minimum Update 3 of RHEL 5 is required
RHEL 6 2.6.32 2.12 4.4.4
Asianux 3.0 2.6.18 2.5 4.1.2 Minimum Service Pack 3 of Asianux 3.0 is required
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6- i386,
lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)

libaio1 (required for KAIO)
pdksh (required by ISM)
libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 10.04 LTS 2.6.32 2.11.1 4.4.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
Informix
11.70.FC4
x86_64 (EM64T/AMD64) RHEL 5 2.6.18 2.5 4.1.1 Minimum Update 3 of RHEL 5 is required
RHEL 6 2.6.32 2.12 4.4.4
Asianux 3.0 2.6.9 2.3.4 4.1.2 Minimum Service Pack 3 of Asianux 3.0 is required
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386, lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)

libaio1 (required for KAIO)
pdksh (required by ISM)
libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 10.04 LTS 2.6.32 2.11.1 4.4.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
Informix
11.70.FC4
IBM System z RHEL 5 2.6.18 2.5 4.1.1 Minimum Update 3 of RHEL 5 is required
SuSE SLES 11 2.6.27 2.9 4.3.2
Informix
11.70.FC4
IBM POWER (System p, System i, POWER Blades) RHEL 5 2.6.18 2.5 4.1.1 Minimum Update 3 of RHEL 5 is required
RHEL 6 2.6.32 2.12 4.4.4
SuSE SLES 11 2.6.27 2.9 4.3.2
 

 
INFORMIX 11.50
Product version
Platform
Distributions
Base Kernel version
Glibc version
Compiler version
Comments
Informix
11.50.UC8
Intel x86 RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
RHEL 6 2.6.32 2.12 4.4.4
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required by
installserver)
libaio1 (required for KAIO)
pdksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)
libaio1 (required for KAIO)
pdksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
x86_64
(EM64T/AMD64)
RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
RHEL 6 2.6.32 2.12 4.4.4
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386,
lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6- i386,
lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)

libaio1 (required for KAIO)
pdksh (required by ISM)
libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
Informix
11.50.FC8
x86_64 (EM64T/AMD64) RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
RHEL 6 2.6.32 2.12 4.4.4
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386, lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Debian 5.0 2.6.26 2.7 4.3.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386, lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
SuSE SLES 11 2.6.27 2.9 4.3.2
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO) pdksh,libc6-i386,
libncurses 32bit(required for ISM)
Note:
libncurses 32bit(required
for ISM)needs to be
copied from a x86 (32-bit) installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Ubuntu 8.04 LTS 2.6.24 2.7 4.2 Install the following:
bc utility (required by
installserver)

libaio1 (required for KAIO)
pdksh (required by ISM)
libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
openSuSE 11.1 2.6.27 2.9.2 4.3.2 Supported by Informix Developer Edition only
openSuSE 11.2 2.6.31 2.10.1 4.4.0 Supported by Informix Developer Edition only
openSuSE 11.3 2.6.34 2.11.2 4.5.0 Supported by Informix Developer Edition only
Fedora 11 2.6.29 2.10.1 4.4.0 Supported by Informix Developer Edition only
Fedora 12 2.6.31 2.11 4.4.2 Supported by Informix Developer Edition only
Fedora 13 2.6.33 2.12 4.4.4 Supported by Informix Developer Edition only
Informix
11.50.FC8
IBM System z RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
SuSE SLES 10 2.6.16 2.4-31 4.1.0
SuSE SLES 11 2.6.27 2.9 4.3.2
Informix
11.50.FC8
IBM POWER (System p, System i, POWER Blades) RHEL 4 2.6.9 2.3.4 3.4.6 Minimum Update
6 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
RHEL 6 2.6.32 2.12 4.4.4
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
SuSE SLES 10 2.6.16 2.4-31 4.1.0
SuSE SLES 11 2.6.27 2.9 4.3.2

 
Informix 11.10
Product version
Platform
Distributions
Base Kernel version
Glibc version
Compiler version
Comments
Informix
11.10.UC4
Intel x86 RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required by
installserver)
libaio1 (required for KAIO)
pdksh (required by ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
x86_64 (EM64T/AMD64) RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386,
lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO)
pdksh,libc6-i386,
libncurses 32bit
(required for ISM)
Note:
libncurses 32bit
(required for ISM)
needs to be copied
from a x86 (32-bit)
installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit
compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Informix
11.10.FC4
x86_64 (EM64T/AMD64) RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
Debian 4.0 2.6.18 2.3.6 4.1.2 Install the following:
libaio1 (required for KAIO)
ksh, libc6-i386, lib32ncurses5
(all required for ISM)

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
SuSE SLES 10 2.6.16 2.4-31 4.1.0
Ubuntu 6.06.1 LTS 2.6.15 2.3.6 4.0.3 Install the following:
bc utility (required
by installserver)

libaio1 (required for KAIO) pdksh,libc6-i386,
libncurses 32bit(required for ISM)
Note:
libncurses 32bit(required
for ISM)needs to be
copied from a x86 (32-bit) installation.

Copy /lib/libncurses.so.5
from x86 (32bit)
installation to
x86_64(64bit)32bit compat libs:
/lib32/libncurses.so.5

Requires RPM to be installed and initialized. Use the following commands to initialize RPM: mkdir -p /var/lib/rpm rpm --initdb
Informix
11.10.FC4
IBM System z RHEL 4 2.6.9 2.3.4 3.4.5 Minimum Update
3 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
SuSE SLES 10 2.6.16 2.4-31 4.1.0
Informix
11.10.FC4
IBM POWER (System p, System i, POWER Blades) RHEL 4 2.6.9 2.3.4 3.4.6 Minimum Update
6 of RHEL 4
is required
RHEL 5 2.6.18 2.5 4.1.1
Asianux 2.0 2.6.9 2.3.4 3.4.3
Asianux 3.0 2.6.18 2.5 4.1.1
SuSE SLES 10 2.6.16 2.4-31 4.1.0
Intel® x86, Itanium, x86_64(EM64T/ AMD64), System z, and IBM POWER (System p, System i, POWER Blades)
Mac OS X
Read the operating system prerequisites.

 
Platform: Apple -- Mac OS X (Intel EM64T)

Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
 

 
INFORMIX 11.70
Product Version
Operating System Version
Comments
INFORMIX 11.70.FC4
Mac OS X 10.5 "Leopard" Minimum Mac OS X 10.5.2 is required
Mac OS X 10.6 "Snow Leopard"
 

 
INFORMIX 11.50
Product Version
Operating System Version
Comments
INFORMIX 11.50.FC8
Mac OS X 10.5 "Leopard" Minimum Mac OS X 10.5.2 is required
Mac OS X 10.6 "Snow Leopard"
Intel EM64T is required
Solaris
Read the operating system prerequisites for:

Solaris for Sparc

 
Platform: Sun -- Solaris (Sparc)
Solaris is supported on Sparc and Intel x86. Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.

 
F = 64-bit on any platform
U = 32-bit on any UNIX/Linux platform
 

 
INFORMIX 11.70
Product Version
Operating System Version
Comments
Informix
11.70.FC4
Solaris 10 Minimum Solaris 10, Update 6 is required. Informix is supported to work with and without Zones.
Click here for details. (PDF, 16KB)
 

 
INFORMIX 11.50
Product Version
Operating System Version
Comments
Informix
11.50.UC8
Solaris 9
Solaris 10 Informix is supported to work with and without Zones.
Click here for details. (PDF, 16KB)
Informix
11.50.FC8
Solaris 9
Solaris 10 Informix is supported to work with and without Zones.
Click here for details. (PDF, 16KB)
 

 
Informix 11.10
Product Version
Operating System Version
Comments
Informix
11.10.UC4
Solaris 9
Solaris 10 Informix is supported to work with and without Zones.
Click here for details. (PDF, 16KB)
Informix
11.10.FC4
Solaris 9
Solaris 10 Informix is supported to work with and without Zones.
Click here for details. (PDF, 16KB)

 


Solaris for Intel

 
Platform: Sun -- Solaris (Intel x86, x64 (AMD AMD64, Intel EM64T))
Informix versions shown below are for the most current versions for each code line.
Note: The following codes are used in the tables on this page.

 
U = 32-bit on any Unix/Linux platform
F = 64 bit on any platform
64-bit product requires x64(AMD AMD64, Intel EM64T)
 

 
INFORMIX 11.70
Product Version
Operating System Version
Comments
INFORMIX 11.70.FC4
Solaris 10 Minimum Solaris 10, Update 6 is required. Informix is supported to work with and without Zones.
Click here for details (PDF, 15.5KB).
 

 
INFORMIX 11.50
Product Version
Operating System Version
Comments
INFORMIX 11.50.FC8
Solaris 10 Informix is supported to work with and without Zones.
Click here for details (PDF, 15.5KB).
 

 
Informix 11.10
Product Version
Operating System Version
Comments
Informix 11.10.FC4
Solaris 10 Informix is supported to work with and without Zones.
Click here for details (PDF, 15.5KB).
Sparc, Intel x86 or x64(AMD AMD64, Intel EM64T) is required
Windows
Read the operating system prerequisites.

 
 
INFORMIX 11.70
Product Version
Operating System Version
INFORMIX 11.70.TC4
Windows XP
Windows 2003
Windows Vista
Windows 2008
Windows 2008 R2 (64-bit)
Windows 7
INFORMIX 11.70.FC4
Windows XP
Windows 2003
Windows Vista
Windows 2008
Windows 2008 R2 (64-bit)
Windows 7


Platform: Microsoft -- Windows (Intel x86, x64 (AMD AMD64, Intel EM64T))
Below are the current releases of Informix and their supported operating systems.
Note: The following codes are used in the tables on this page.
T = 32-bit on Windows platform
U = 32-bit on any Unix/Linux platform
F = 64 bit on any platform
64-bit product requires x64(AMD AMD64, Intel EM64T)

 
INFORMIX 11.50
Product Version
Operating System Version
INFORMIX 11.50.TC8
Windows XP
Windows 2003
Windows Vista
Windows 2008
Windows 2008 R2 (64-bit)
Windows 7
INFORMIX 11.50.FC8
Windows XP
Windows 2003
Windows Vista
Windows 2008
Windows 2008 R2 (64-bit)
Windows 7
 

 
Informix 11.10
Product Version
Operating System Version
Informix 11.10.TC4
Windows XP
Windows 2003
Windows Vista
Windows 2008
Informix 11.10.FC4
Windows XP
Windows 2003
Windows Vista
Windows 2008

 
Intel x86 or x64(AMD AMD64, Intel EM64T) is required

[{"Business Unit":{"code":"BU001","label":"Analytics Private Cloud"},"Product":{"code":"SSGU8G","label":"Informix Servers"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF022","label":"OS X"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"11.5;11.7;12.1;14.1","Edition":""}]

Document Information

Modified date:
29 August 2019

UID

swg27013343