IBM Support

IBM i Access Client Solutions (ACS) Return Code 1018

Troubleshooting


Problem

An IBM i Access Client Solutions component returns an error code or return code of 1018.

Cause

This error code means that the component is attempting to read a Windows registry key that was deleted (unloaded) since that component was first used.  This error is typically caused by having the Windows profile that created the connection unloaded by Windows profile services.

Diagnosing The Problem

For evidence of when and what unloaded the registry key the Windows Process Monitor (PROCMON) tool can be used.  The Windows event log also logs a warning with an event ID 1530.

Resolving The Problem

To resolve this problem, enable the policy that says: "Do not forcefully unload the user registry at user logoff".
The policy can be found in the group policy editor (gpedit.msc): Computer Configuration->Administrative Templates->System-> UserProfiles
Alternate resolution:
"IIS could be part of the problem if it was sharing a user with other processes:
 * I had a user assigned to an IIS resource and was using the same user in another process – which I suspect was causing contention.
 * Once I switched to a different user for the other process, the connection errors stopped."

Document Location

Worldwide

[{"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SSRQKY","label":"IBM i Access Client Solutions"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB66","label":"Technology Lifecycle Services"}}]

Document Information

Modified date:
29 August 2022

UID

ibm16116692