IBM Support

IBM AIX: How to ssh into a AIX system with no authentication

Troubleshooting


Problem

A user might need to log in with ssh into an AIX® system without any form of authentication, such as password, public key, or some other method.

Symptom

Users logging in to AIX with ssh must authenticate in some way.

Cause

OpenSSH supports different ssh authentication methods like password, public key, and others. By default, the ssh server on AIX is configured to use at least one of these authentication methods and any attempt to log in without authentication fails.

Diagnosing The Problem

By default, unless public key authentication is configured, users are prompted to authenticate with a password. For example,

$ ssh lathy@userlab122
lathy@userlab122's password:

Resolving The Problem

To allow a user to log in to AIX with ssh without any authentication, follow these steps.

  1. Add or set "PermitEmptyPasswords yes" in /etc/ssh/sshd_config.
  2. Stop and restart sshd.
    # stopsrc -s sshd
    # startsrc -s sshd
  3. Edit /etc/security/passwd, locate the stanza for the user that needs to log in without a password, set "password = " (that is, no password string), and remove the "flags = ADMCHG" line, if present.
  4. Set the user's maxage, minlen, minother, and minalpha attributes to zero with the chuser command. For example, use this command string for user lathy.
    # chuser maxage=0 minlen=0 minother=0 minalpha=0 lathy

The user can now log in to the server with ssh but without a password.

SUPPORT:

If the instructions in this document do not lead to resolution of the problem, follow these instructions to open a case.  The product must be under warranty or have an active and valid support contract.

a.  Document or take screen captures of all symptoms, errors, or messages.

b.  Capture any logs or data relevant to the issue.

c.  Contact IBM to open a case.

   -For electronic support, visit the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, visit this web page:
      https://www.ibm.com/planetwide/

d.  Provide a detailed description of the issue and reference this technote.

e.  Upload all of the details and data to the case.

   -You can attach files to the case in the IBM Support Community, or
   -Upload data to IBM test case server analysis at this URL:

    http://www.ibm.com/support/docview.wss?uid=ibm10733581

f.  Click here to submit feedback for this document.


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Document Information

More support for:
AIX

Software version:
All Versions

Operating system(s):
AIX

Document number:
6128889

Modified date:
01 April 2020

UID

ibm16128889

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