IBM Support

How to flush queued mail from clientmqueue directory

Troubleshooting


Problem

Sendmail has mail queued in /var/spool/clientmqueue and it is filling up /var.

Symptom

How to flush mail queue clientmqueue

Cause

For various reasons if sendmail is unable to deliver mail it queues the mail in /var/spool/clientmqueue.

Environment

This procedure is for AIX 7200-04 and higher and also for AIX 7.3.

Diagnosing The Problem

Check the contents of /var/spool/mqueue for undeliverable mail.
 

Resolving The Problem

To flush queued mail that is in clientmqueue do the following:
# sendmail -oQ/var/spool/clientmqueue -q -v
 

SUPPORT

If you require more assistance, use the following step-by-step instructions to contact IBM to open a case for software with an active and valid support contract.  

1. Document (or collect screen captures of) all symptoms, errors, and messages related to your issue.

2. Capture any logs or data relevant to the situation.

3. Contact IBM to open a case:

   -For electronic support, see the IBM Support Community:
     https://www.ibm.com/mysupport
   -If you require telephone support, see the web page:
      https://www.ibm.com/planetwide/

4. Provide a clear, concise description of the issue.

 - For guidance, see: Working with IBM AIX Support: Describing the problem.

5. If the system is accessible, collect a system snap, and upload all of the details and data for your case.

 - For guidance, see: Working with IBM AIX Support: Collecting snap data

6. Upload all of the details and data to your case

   - Attach files to your case in the IBM Support Community

     https://www.ibm.com/mysupport/s/?language=en_US

    -Or Upload data to IBM testcase server analysis:
f. Provide feedback for clicking on "Contact and feedback" button on the right side of the document.

[{"Type":"MASTER","Line of Business":{"code":"LOB08","label":"Cognitive Systems"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"ARM Category":[{"code":"a8m0z000000cvwrAAA","label":"Communication Applications"}],"ARM Case Number":"","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.2.0;7.3.0"}]

Document Information

Modified date:
13 June 2023

UID

ibm17002769