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Error 'object was not found in registry' when click on COM+ application

Troubleshooting


Problem

I.T. administrator logs onto the Controller Application server. Administrator clicks on 'Start - Settings - Control Panel - Administrative Tools - Component Services'. Admin expands the top row by clicking on the plus (+) symbol repeatedly. Admin expands COM+ application (for example called 'COGNOSCONTROLLER'), and clicks on 'Components'. Admin receives error message. TIP: For Controller 8.4 and later, the COM+ application is called 'IBMCOGNOSCONTROLLER' (not 'COGNOSCONTROLLER').

Symptom


Screen message:

    Errors Occurred
    Some object properties could not be read due to the following errors:

    Name Reason
    FrDIBT.DIdefineT Object was not found in registry
    FrDIBT.DILogT Object was not found in registry
    FrDIBT.DILDetailsT Object was not found in registry
    FrDIBT.DILookupT Object was not found in registry
    FrDIBT.DIwizspecT Object was not found in registry

    OK Details

Then if click 'Details':
    Explanation
    You may need to reinstall this component to restore the required registry settings.
    OK

Cause

One or more of the many (typically over 250) COGNOSCONTROLLER COM+ application's objects ('components') have not registered correctly.

TIP: Different versions of Controller have different numbers of component objects inside their COM+ application. For example, Controller 8.4 FP1 has 259 objects.

There are several potential root causes of why the COM+ object(s) did not register correctly, including:

  • Server prerequisites were not correctly performed before Controller was installed
    • For example, the 'Windows 2003 Support Tools' were not installed before installing Controller
  • Previous version of Controller was not uninstalled first before installing the later version of Controller.
For more details, see the related IBM Technotes listed at the end of this Technote.

Resolving The Problem

Both of the following two methods involve fundamental changes to the application server. Therefore, the following should only be done by an experienced I.T. professional, during a period of downtime:

  • Method #1 - Uninstall and re-install Controller 8.x server, on the application server.
  • Method #2 - Delete all of the COM+ objects and re-register them.

Steps for Method #2
  1. Ensure no users are using Controller
  2. Logon to the Controller application server, as an Administrator
  3. Click 'Start - Settings - Control Panel'
  4. Launch 'Administrative Tools - Component Services'
  5. Expand the 'top row' by repeatedly clicking the '+' ("plus") icon, until you find the COM+ application. TIP: For Controller 8.3 and earlier, this is named 'COGNOSCONTROLLER'. For Controller 8.4 and later, this is named 'IBMCOGNOSCONTROLLER'
  6. Expand the folder 'components'
  7. Click 'OK' at the error message
  8. Click 'View - Detail' to see the list more easily
  9. Highlight one of the components
  10. Tap 'Ctrl - A' on the keyboard, to select *all* components
  11. Right-click on any part of the blue 'highlighted' components, and choose 'delete'
  12. Click 'yes' to confirm
  13. Launch Windows Explorer and open the folder: <install location>\Cognos\C8\Server
  14. Click on the column title 'Type' (to order the files by extension)
  15. Scroll down to the first .DLL file that begins with 'Fr' (in this case 'FrAccountB.dll'). Click to highlight this file.
  16. Scroll down to the last Fr*.DLL file (in this case 'FrworkflowS.dll')
  17. Hold down the 'shift' key on the keyboard, and click this DLL file
  18. Now you will find that all the FR*.DLL files are selected
  19. Drag and drop these selected files into the open/blank 'Components' subsection of COGNOSCONTROLLER
  20. Wait for approximately 1+ minutes, and see that all (for example 252 for Controller 8.3) objects are successfully registered inside 'Components'
  21. Click any one of the objects inside 'components'
  22. Click 'Ctrl -A' on the keyboard, to select/highlight all of them
  23. Right-click on the components, and choose 'properties'
  24. Click 'security' tab
  25. Tick the box 'Enforce component level access checks'
  26. Tick the box next to 'CognosUsers' (or whatever your group is called, perhaps "ControllerUsers" or whatever)
  27. Click OK. IMPORTANT: This may take a few minutes to register all the security changes. Be patient!
  28. Test

TIP: For precise instructions, including print-screens, see attached document 'KB 1039292 - Error 'object was not found in registry' when click on COM+ application.pdf'.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1039292

Document Information

Modified date:
15 June 2018

UID

swg21372678