Troubleshooting
Problem
I.T. administrator logs onto the Controller Application server. Administrator clicks on 'Start - Settings - Control Panel - Administrative Tools - Component Services'. Admin expands the top row by clicking on the plus (+) symbol repeatedly. Admin expands COM+ application (for example called 'COGNOSCONTROLLER'), and clicks on 'Components'. Admin receives error message. TIP: For Controller 8.4 and later, the COM+ application is called 'IBMCOGNOSCONTROLLER' (not 'COGNOSCONTROLLER').
Symptom
Screen message:
- Errors Occurred
Some object properties could not be read due to the following errors:
Name Reason
FrDIBT.DIdefineT Object was not found in registry
FrDIBT.DILogT Object was not found in registry
FrDIBT.DILDetailsT Object was not found in registry
FrDIBT.DILookupT Object was not found in registry
FrDIBT.DIwizspecT Object was not found in registry
OK Details
Then if click 'Details':
- Explanation
You may need to reinstall this component to restore the required registry settings.
OK
Cause
One or more of the many (typically over 250) COGNOSCONTROLLER COM+ application's objects ('components') have not registered correctly.
TIP: Different versions of Controller have different numbers of component objects inside their COM+ application. For example, Controller 8.4 FP1 has 259 objects.
There are several potential root causes of why the COM+ object(s) did not register correctly, including:
- Server prerequisites were not correctly performed before Controller was installed
- For example, the 'Windows 2003 Support Tools' were not installed before installing Controller
- Previous version of Controller was not uninstalled first before installing the later version of Controller.
Resolving The Problem
Both of the following two methods involve fundamental changes to the application server. Therefore, the following should only be done by an experienced I.T. professional, during a period of downtime:
- Method #1 - Uninstall and re-install Controller 8.x server, on the application server.
- Method #2 - Delete all of the COM+ objects and re-register them.
Steps for Method #2
- Ensure no users are using Controller
- Logon to the Controller application server, as an Administrator
- Click 'Start - Settings - Control Panel'
- Launch 'Administrative Tools - Component Services'
- Expand the 'top row' by repeatedly clicking the '+' ("plus") icon, until you find the COM+ application. TIP: For Controller 8.3 and earlier, this is named 'COGNOSCONTROLLER'. For Controller 8.4 and later, this is named 'IBMCOGNOSCONTROLLER'
- Expand the folder 'components'
- Click 'OK' at the error message
- Click 'View - Detail' to see the list more easily
- Highlight one of the components
- Tap 'Ctrl - A' on the keyboard, to select *all* components
- Right-click on any part of the blue 'highlighted' components, and choose 'delete'
- Click 'yes' to confirm
- Launch Windows Explorer and open the folder: <install location>\Cognos\C8\Server
- Click on the column title 'Type' (to order the files by extension)
- Scroll down to the first .DLL file that begins with 'Fr' (in this case 'FrAccountB.dll'). Click to highlight this file.
- Scroll down to the last Fr*.DLL file (in this case 'FrworkflowS.dll')
- Hold down the 'shift' key on the keyboard, and click this DLL file
- Now you will find that all the FR*.DLL files are selected
- Drag and drop these selected files into the open/blank 'Components' subsection of COGNOSCONTROLLER
- Wait for approximately 1+ minutes, and see that all (for example 252 for Controller 8.3) objects are successfully registered inside 'Components'
- Click any one of the objects inside 'components'
- Click 'Ctrl -A' on the keyboard, to select/highlight all of them
- Right-click on the components, and choose 'properties'
- Click 'security' tab
- Tick the box 'Enforce component level access checks'
- Tick the box next to 'CognosUsers' (or whatever your group is called, perhaps "ControllerUsers" or whatever)
- Click OK. IMPORTANT: This may take a few minutes to register all the security changes. Be patient!
- Test
TIP: For precise instructions, including print-screens, see attached document 'KB 1039292 - Error 'object was not found in registry' when click on COM+ application.pdf'.
Related Information
Historical Number
1039292
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Document Information
Modified date:
15 June 2018
UID
swg21372678