Troubleshooting
Problem
ユーザーがケース・アプリケーションに移動すると、次のエラーが表示されます:
upstream connect error or disconnect/reset before headers. reset reason: connection failure.
Cause
このエラーは、アプリケーション・ポッドが完全に初期化されていないために発生します。これは、アプリケーション・ポッドのステータスを見ることで確認できます。
Kubectl get pods |grep isc-cases
isc-cases-application ポッドが完全に初期化されていない可能性があります。ポッドは 7/8 がデプロイされている可能性があります。
Diagnosing The Problem
"kubectl logs -lname=isc-cases-application -c cases-application-client-log-tailer -f" を実行してログを確認します。
次のログが表示される場合は、以下の解決策をご実施ください。
Exception in runnable com.ibm.resilient.common.license.InvalidLicenseException: License file does not exist
次に、"kubectl describe pod -lname=isc-cases-application" を実行します。
ライセンス・キーの確認: フィールドで使用されているライセンスを確認します。isc-cases-license-key の場合、製品に同梱されているライセンスを使用しています。isc-cases-customer-license の場合、作成されたカスタム・ライセンスが使用されています。
複数のライセンスがインストールされている場合は、"Kubectl get secret |grep license" を実行することで表示することが可能です。
「ライセンス・ファイルが存在しません」と表示されない場合は、"Kubectl delete pod -lname=isc-cases-application" を実行して isc-cases-application を再起動するか、IBM サポートにご連絡ください。
Resolving The Problem
"kubectl delete secret isc-cases-customer-license" を実行して、ケース・アプリケーションが出荷時のライセンスで動作することを確認するために、最初に顧客ライセンスを削除します。
次に、アプリケーション Pod が自動的に再起動するのを待つか、"Kubectl delete pod -lname=isc-cases-application" を実行して手動で再起動します。
ケース・アプリケーションが UI から動作したら、顧客ライセンスを再インポートします。
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Document Location
Worldwide
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Document Information
Modified date:
30 July 2021
UID
ibm16457607