IBM Support

Unable to access cases application - error "connection failure"

Troubleshooting


Problem

User navigates to cases application and receives error: "upstream connect error or disconnect/reset before headers. reset reason: connection failure.

Cause

This error is caused due to application pods not being initialized completely. This can be viewed by simply checking application pod status:
Kubectl get pods |grep isc-cases
isc-cases-application pod may not be completely initialized. Pods may be 7/8 deployed.

Diagnosing The Problem

check logs by performing "kubectl logs -lname=isc-cases-application -c cases-application-client-log-tailer -f"
if following logs are displayed then use below solution:
Exception in runnable
com.ibm.resilient.common.license.InvalidLicenseException: License file does not exist
then perform "kubectl describe pod -lname=isc-cases-application"
check license key: field to verify which license is being used. If isc-cases-license-key then it is using license which is shipped with the product. if   isc-cases-customer-license  then custom license which was created is being used.
You can perform "Kubectl get secret |grep license" in order to view if one or more license is installed.
If you do not see the "License file does not exist", then please restart isc-cases-application by performing "Kubectl delete pod -lname=isc-cases-application" or reach out to IBM Support.

Resolving The Problem

Remove customer license first to ensure cases application is working with shipped license by performing "kubectl delete secret isc-cases-customer-license".
Then either you can wait for application pod to restart on its own or perform "Kubectl delete pod -lname=isc-cases-application" to restart it manually.
Once cases application is working from UI then reimport customer license.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTDPP","label":"IBM Cloud Pak for Security"},"ARM Category":[{"code":"a8m0z0000001h8pAAA","label":"Cases"}],"ARM Case Number":"TS004238594","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]

Document Information

Modified date:
23 September 2020

UID

ibm16336543