IBM Support

Collect IBM MQ Appliance MustGather data to solve problems

Question & Answer


Question

The IBM MQ Appliance is not working as expected and you need to collect MustGather data to find a solution.

Cause

Note for M2001 users: support ends July 2023.
- Click here for information on the latest model and click here for migration instructions

These instructions apply only to IBM MQ V9.3.x, V9.3.0.x, V9.2.x, V9.2.0.x, V9.1.x, V9.1.0.x, V9.0.x, and V8.0 on the IBM MQ Appliance M2000, M2001,  M2002 or M2003. Refer to the IBM MQ Read First page for instructions on other environments.

Answer

Answer these questions about the problem and then follow the steps:

  • What problem did you observe on the IBM MQ Appliance?
  • What time did the problem start and when did it stop?
  • Which is the IBM MQ Appliance serial number and version of IBM MQ? Use the show version command to obtain this information.

Step 1: Generate Data

It is important to gather information from the IBM MQ Appliance when the problem is happening to identify the cause:

  1. Generate a DataPower® error report:
    1. Access the IBM MQ Appliance command line interface .
    2. Enter configuration mode by entering the following command on the command line:
      mqa# config
    3. Run the save error-report command to create a .gz file containing diagnostic information. The file is created in the temporary:/// URI.
      mqa(config)# save error-report
    4. Type dir temporary:/// to make sure the file is there.
    5. Exit configuration mode by typing exit in the command line.
  2. If requested by IBM Support, generate a trace on the IBM MQ Appliance while the problem is occurring
    1. Enter the IBM MQ administration mode by entering the following command on the command line:
      mqa# mqcli
    2. Delete any previous traces.
      mqa(mqcli)# dltmqras -t
    3. Start the trace.
      mqa(mqcli)# strmqtrc -m <qmgrName> -t all -t detail
      Note: Change QMgrName with the name of your Queue manager.
    4. Reproduce the issue.
    5. End the trace for the IBM MQ queue manager:
      mqa(mqcli)# endmqtrc -a
  3. If problem is related to a High Availability (HA) configuration, collect the following documentation in both, primary, and secondary appliances:
    1. Access the IBM MQ Appliance command line interface and collect the output of the following commands:
      • show system
      • show time
      • show link
      • show link-aggregation
      • show link-aggregation-status
      • show int
      • show ipaddr
      • show route
      • show ethernet
      • show filesystem
    2. Ping results from both appliances while pinging the IP address of the other appliance.
  4. If problem is related to a Disaster Recovery (DR) configuration, then similar outputs and files as previous steps are required from the DR systems as well.
  5. If problem is related to performance issues, then along with the general data, collect the dpmon output as well. The dpmon output is enabled by default and the logs are created in the following URI: temporary:///dpmon.

Step 2: Collect Data

  1. Run the runmqras automation tool to create a .zip file containing diagnostic information. Be sure to collect the runmqras defs and trace sections, and to specify your case number. The file is created in the mqdiag:/// URI.


    Collecting runmqras output from queue manager

    1. mqa# mqcli
      mqa(mqcli)# runmqras -qmlist <qmgrName> -section defs,trace -caseno <caseNumber>

      Note: If reported problem is related to HA/DR issues, then collect the runmqras from ALL appliances (HA and DR appliances) involve on the configuration. 
    2. If reported problem is performance-related, then collect runmqras output with the following options:
      mqa(mqcli)# runmqras -qmlist <qmgrName> -section defs,trace,dap,kernel,logger,topic -caseno caseNumber
  2. Download the error report, runmqras output file, and any other relevant documents from the IBM MQ Appliance.


    How to download data from the appliance

    1. Use the copy command with the scp or sftp protocol. Need to be on the config mode to be able to use the copy command. 

      mqa(config)# copy mqdiag://runmqras_191029_133456-APP1.zip scp://user@x.yy.zzz.153/Downloads

    2. Use the File Management tab in the IBM MQ Appliance web UI to download the files to your local server.
      Currently, you cannot download files larger than 100 MB from the web UI. You need to use the copy command for larger files.
 

Step 3: Send Data to IBM

Exchanging data with IBM Support


If you need to speak with IBM Software Support, call your country representative. If you need to speak with IBM Software Support in the US call 1-800-IBM-SERV.

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Product Synonym

IBM MQ Appliance; IBM MQ

Document Information

Modified date:
06 September 2022

UID

swg22004976