IBM Support

IT31794: Upgrade Apache Commons BeanUtils & Apache Commons Digester jar levels for IBM MQ

Subscribe to this APAR

By subscribing, you receive periodic emails alerting you to the status of the APAR, along with a link to the fix after it becomes available. You can track this item individually or track all items by product.

Notify me when this APAR changes.

Notify me when an APAR for this component changes.

 

APAR status

  • Closed as program error.

Error description

  • IBM MQ ships the Apache Commons BeanUtils library within its
    installation, and the level of Apache Commons BeanUtils supplied
    is back-level.
    

Local fix

Problem summary

  • ****************************************************************
    USERS AFFECTED:
    The components of MQ which utilise the embedded Apache Commons
    BeanUtils & Apache Commons Digester jars include:
    
    - IBM MQ Managed File Transfer Edition.
    
    
    Platforms affected:
    MultiPlatform
    
    ****************************************************************
    PROBLEM DESCRIPTION:
    The IBM MQ v9.0.0.8/v9.1.0.4 releases are supplied with the
    Apache Commons BeanUtils(v1.9.3) and Apache Commons
    Digester(v1.8) jars.
    
    The latest version of these utilities are:
    
      Apache Commons BeanUtils v1.9.4
      Apache Commons Digester v2.1
    
    Upgrading these libraries also required an additional
    prerequisite to be included, the Apache Commons Collections jar.
    

Problem conclusion

  • The version of Apache Commons BeanUtils, Apache Commons Digester
    and Apache Commons Collections jars shipped within the IBM MQ
    Managed File Transfer component has been updated to the
    following versions:
    
    - Apache Commons BeanUtils v1.9.4
    - Apache Commons Digester v2.1
    - Apache Commons Collections v3.2.2
    
    ---------------------------------------------------------------
    The fix is targeted for delivery in the following PTFs:
    
    Version    Maintenance Level
    v9.0 LTS   9.0.0.10
    v9.1 CD    TBC.
    v9.1 LTS   9.1.0.5
    
    The latest available maintenance can be obtained from
    'WebSphere MQ Recommended Fixes'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006037
    
    If the maintenance level is not yet available information on
    its planned availability can be found in 'WebSphere MQ
    Planned Maintenance Release Dates'
    http://www-1.ibm.com/support/docview.wss?rs=171&uid=swg27006309
    ---------------------------------------------------------------
    

Temporary fix

Comments

APAR Information

  • APAR number

    IT31794

  • Reported component name

    IBM MQ BASE M/P

  • Reported component ID

    5724H7261

  • Reported release

    900

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt / Xsystem

  • Submitted date

    2020-02-07

  • Closed date

    2020-03-24

  • Last modified date

    2020-03-24

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    IBM MQ BASE M/P

  • Fixed component ID

    5724H7261

Applicable component levels

[{"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.0","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
24 March 2020