IBM Support

IC86528: ERROR "PACKAGE (OR FILE) SLES-RELEASE NOT FOUND." INSTALLING DB2 9.7 FIX PACK 5 OR LATER ON SUSE LINUX (SLES) FOR VMWARE

Subscribe

You can track all active APARs for this component.

 

APAR status

  • Closed as program error.

Error description

  • When you install DB2 9.7 Fix Pack 5 or later on SUSE Linux
    Enterprise Server (SLES) for VMWare, you might get this error:
    
        ERROR:
           package (or file) sles-release not found.
           Required minimum level is 10-15.2
        ERROR:
           The required minimum version of SUSE Linux is 10 SP 2.
           Check the following web site for the up-to-date system
    requirements
           of IBM DB2 9.7
           http://www.ibm.com/software/data/db2/udb/sysreqs.html
           http://www.software.ibm.com/data/db2/linux/validate
          Aborting the current installation ...
          Run installation with the option "-f sysreq" parameter to
    force the installation.
    
    That error happens because on SUSE Linux starting with DB2 9.7
    Fix Pack 5 there is a check that the package
    "sles-release" is installed. But SUSE Linux Enterprise Server
    (SLES) for VMWare might have a package called
    "SLES-for-VMware-release" instead of "sles-release".
    
    The change that this APAR introduces is to replace the check on
    SUSE Linux that package "sles-release" is installed with a check
    that EITHER the "sles-release" OR the "SLES-for-VMware-release"
    package is installed.
    

Local fix

  • As a workaround, you can use the "-f sysreq" option of the
    "installFixPack" command to force the installation.
    

Problem summary

  • ****************************************************************
    * USERS AFFECTED:                                              *
    * Users of DB2 on SuSE Linux (SLES) FOR VMWare                 *
    ****************************************************************
    * PROBLEM DESCRIPTION:                                         *
    * See Error Description                                        *
    ****************************************************************
    * RECOMMENDATION:                                              *
    * .                                                            *
    ****************************************************************
    

Problem conclusion

  • Problem was first fixed in Version 9.7 Fix Pack 8.
    At a minimum, this fix should be applied on the machine where
    you install DB2.
    

Temporary fix

  • As a workaround, you can use the "-f sysreq" option of the
    "installFixPack" command to force the installation.
    

Comments

APAR Information

  • APAR number

    IC86528

  • Reported component name

    DB2 FOR LUW

  • Reported component ID

    DB2FORLUW

  • Reported release

    970

  • Status

    CLOSED PER

  • PE

    NoPE

  • HIPER

    NoHIPER

  • Special Attention

    NoSpecatt

  • Submitted date

    2012-09-13

  • Closed date

    2013-04-10

  • Last modified date

    2013-04-10

  • APAR is sysrouted FROM one or more of the following:

  • APAR is sysrouted TO one or more of the following:

Fix information

  • Fixed component name

    DB2 FOR LUW

  • Fixed component ID

    DB2FORLUW

Applicable component levels

  • R970 PSN

       UP

[{"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SSEPGG","label":"DB2 for Linux, UNIX and Windows"},"Component":"","ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"9.7","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
10 April 2013